+1-888-365-2779
Try Now
More in this section

Forums / 3.x Pre-release forums (retired) / HELP! Sitefinity goes into endless loop!!!

HELP! Sitefinity goes into endless loop!!!

6 posts, 0 answered
  1. fregas baratis
    fregas baratis avatar
    185 posts
    Registered:
    14 Nov 2002
    10 Apr 2007
    Link to this post
    We were upgrading one of our sites from Beta 3 to RC1 Update.  I literally took the admin, content, bin and web.config settings from a working RC1 site and copied them to the Beta 3 site.

    Now the site doesn't work at all.  On the front end, we get some kind of browser endless loop, like SItefinity keeps redirecting the browser over and over.  If we look in the sitefinity log, there are tons of duplicate error messages that look like this, showing missing DLLs for both our own DLLs and Sitefinitys.  If i had to guess, i would think sitefinity is getting an error, redirecting the error page and then getting the same error.

    4/10/2007 6:45:59 PM [EXCEPTION]
    ************************************************************************************
    ID: e41bfc27-22da-4405-b9c3-9a0b1876061f; Code: 100103; Occurrence: 81; Sequence: 82
    - L0 -------------------------------------------------------------------------------

    Exception Type: System.IO.FileLoadException

    Message: Could not load file or assembly 'Nolics.Engine.v4.2, Version=4.2.2507.4, Culture=neutral, PublicKeyToken=c50af72fde0670b7' or one of its dependencies. The located assembly's manifest definition does not match the assembly reference. (Exception from HRESULT: 0x80131040)

    Source:

    Stack Trace:

    ------------------------------------------------------------------------------------


    In the admin, after we log in, it gives us this error:


    Server Error in '/' Application.
    --------------------------------------------------------------------------------

    Configuration Error
    Description: An error occurred during the processing of a configuration file required to service this request. Please review the specific error details below and modify your configuration file appropriately.

    Parser Error Message: Error: The new name 'KeyValue' is already in use as a column name and would cause a duplicate that is not permitted.

    Source Error:


    Line 204:                      versioningProviderName=""
    Line 205:                      connectionStringName="DefaultNolicsConnection"
    Line 206:                      type="Telerik.Cms.Engine.DefaultContentProvider, Telerik.Cms.Engine"
    Line 207:                      listTemplate="~/Admin/Templates/GenericContent/ControlPanelList.ascx"
    Line 208:                      insertTemplate="~/Admin/Templates/GenericContent/ControlPanelInsert.ascx"
     

    Source File: C:\projects\DFWI\DFWI.org v2\Development\Enilon.DFWI.Web\web.config    Line: 206


    --------------------------------------------------------------------------------
    Version Information: Microsoft .NET Framework Version:2.0.50727.42; ASP.NET Version:2.0.50727.42
  2. fregas baratis
    fregas baratis avatar
    185 posts
    Registered:
    14 Nov 2002
    11 Apr 2007
    Link to this post
    Additional Information:

    I think something bad happened when i tried to upgrade.  There were differences between our database and another site running under RC1, so i pushed the stored procs and table changes to our database.  This fixed the second error.

    The endless loop is still happening.  It only seems to happen when someone browses to the default page like this:

    http://localhost/default.aspx

    or just

    http://localhost/

    either one starts an endless loop.  I installed fiddler to see the Http requests and headers come and go and the site is indeed causing a redirect to /default.aspx over and over.

    Thanks,
    Craig
  3. Rebecca
    Rebecca avatar
    536 posts
    Registered:
    24 Sep 2012
    11 Apr 2007
    Link to this post
    Hi Craig,

    Please check if you have a CMS page with name "Default", set as a home page or if you have set the home page's  optional URL to "Default.aspx". Most probably, this is causing the "endless loop".
    This is a known issue and it has already been fixed.

    If this does not solve the problem, can you please send us the old project and database so we can try upgrading it locally?

    All the best,
    Rebecca
    the telerik team

    Instantly find answers to your questions at the new telerik Support Center
  4. fregas baratis
    fregas baratis avatar
    185 posts
    Registered:
    14 Nov 2002
    11 Apr 2007
    Link to this post

    I was able to fix the endless loop, but now i am getting other errors.  Sometimes, pages do not show up at all, other times i get the keyvalue error again.  I think Sitefinity is trying to back to and old version of the stored procedures and tables that beta 3 was using, but i'm not sure.  I'm using the latest RC1 DLLs i believe so it shouldnt be doing that.  but when i compare a working RC1 site and database to this one, there is a difference in the [sf_CmsContentMetaData] table.

    Is there some flag in the database t

  5. fregas baratis
    fregas baratis avatar
    185 posts
    Registered:
    14 Nov 2002
    11 Apr 2007
    Link to this post
    sorry for the duplicate posts.  My browser went crazy all of sudden and i was posting a bunch of times.

    What i was trying to say, is there some flag in the database that tells sitefinity what version it should be using?

    Thanks,
    Craig
  6. Rebecca
    Rebecca avatar
    536 posts
    Registered:
    24 Sep 2012
    12 Apr 2007
    Link to this post
    Hello Craig,

    Sitefinity should upgrade the database automatically when the application is started but sometimes this brings about problems. Can you please send us your old project so we can try to upgrade it? Make sure you send us the project database as well as a detailed description of the steps you took when upgrading. Also, can you tell us if you have followed any of our upgrading instructions?
    Please open a new support ticket and attach the archived project. You may remove the RadControls folder as this will shorten the file by about 10MB.

    We are sorry we could not help you immediately and thank you for your cooperation.

    Sincerely yours,
    Rebecca
    the telerik team

    Instantly find answers to your questions at the new telerik Support Center
Register for webinar
6 posts, 0 answered