+1-888-365-2779
Try Now
More in this section

Forums / 3.x Pre-release forums (retired) / Issue with templates in production

Issue with templates in production

3 posts, 0 answered
  1. UI Crew
    UI Crew avatar
    151 posts
    Registered:
    27 Sep 2012
    20 Feb 2007
    Link to this post
    Hi,

    I have uploaded both a new Sitefinity v3 project to a production environment and also the TIU demo to production to demo the product to a development partner of ours.

    The app is working fine but in both cases I cannot view or edit templates - I go to the templates area and then click the template I want to view and get the following in the viewing window:

    The page cannot be found

    The page you are looking for might have been removed, had its name changed, or is temporarily unavailable.

    Please try the following:

    • Make sure that the Web site address displayed in the address bar of your browser is spelled and formatted correctly.
    • If you reached this page by clicking a link, contact the Web site administrator to alert them that the link is incorrectly formatted.
    • Click the Back button to try another link.

    HTTP Error 404 - File or directory not found.
    Internet Information Services (IIS)


    Any ideas why this might be so? This is the only thing we have noticed play up on prod.

    Cheers,

    Seth

  2. Sean
    Sean avatar
    271 posts
    Registered:
    31 May 2006
    20 Feb 2007
    Link to this post
    Hi Seth,

    This is because the templates need the .master file extension mapped to the ASP.Net isapi dll.

    If you look in the RC1 User Manual on page 17 and 18 it gives you instructions on how to do this.

    Cheers
    Sean
  3. UI Crew
    UI Crew avatar
    151 posts
    Registered:
    27 Sep 2012
    20 Feb 2007
    Link to this post
    errrr... those pages must have been missing from my manual.

    :-) Thanks that worked.
Register for webinar
3 posts, 0 answered