+1-888-365-2779
Try Now
More in this section

Forums / 3.x Pre-release forums (retired) / Jobs site errors and upgrade errors

Jobs site errors and upgrade errors

5 posts, 0 answered
  1. fregas baratis
    fregas baratis avatar
    185 posts
    Registered:
    14 Nov 2002
    24 Jan 2007
    Link to this post
    When I try to run the sitefinity JobsIntraSite in the update to beta 3, i get this error:
     

    Server Error in '/telerik/JobsIntraSite' Application.

    Compilation Error

    Description: An error occurred during the compilation of a resource required to service this request. Please review the following specific error details and modify your source code appropriately.

    Compiler Error Message: CS0115: 'JobsModule.CreateControlPanel(System.Web.UI.TemplateControl)': no suitable method found to override

    Source Error:

    Line 102:  /// </summary>
    Line 103:  /// <returns>Instance of the ControlPanel object of the module.</returns>
    Line 104:  public override Control CreateControlPanel(TemplateControl parent)
    Line 105:  {
    Line 106:    return parent.LoadControl("~/Jobs/ControlPanel.ascx");

    Source File: c:\Program Files\telerik\Sitefinity3.0\JobsIntraSite\App_Code\JobsModule.cs    Line: 104






    Version Information: Microsoft .NET Framework Version:2.0.50727.42; ASP.NET Version:2.0.50727.210



    I also followed the instructions in the user manual to upgrade one of the sites we're working on, and its having a problem with the Telerik.Security DLL:

    Configuration Error

    Description: An error occurred during the processing of a configuration file required to service this request. Please review the specific error details below and modify your configuration file appropriately.

    Parser Error Message: An error occurred creating the configuration section handler for telerik/security: Could not load type 'Telerik.Security.Configuration.SectionHandler' from assembly 'Telerik.Security'.

    Source Error:

    Line 13:       <section name="sitefinity" type="Telerik.Sitefinity.Configuration.SectionHandler, Telerik.Cms" requirePermission="false"/>        
    Line 14: 			<section name="cmsEngine" type="Telerik.Cms.Engine.Configuration.SectionHandler, Telerik.Cms.Engine" requirePermission="false"/>
    Line 15:       <section name="security" type="Telerik.Security.Configuration.SectionHandler, Telerik.Security" requirePermission="false"/>
    Line 16:       <section name="nolics" type="Telerik.DataAccess.ConnectionSectionHandler, Telerik.DataAccess" requirePermission="false"/>
    Line 17:       <section name="workflow" type="Telerik.Workflow.WorkflowSectionHandler, Telerik.Workflow" requirePermission="false"/>

    Source File: C:\projects\DFWI\DFWI_Mainstreet v2\Development\Enilon.MainStreetArts.Web\web.config    Line: 15


    I did not see the Telerik.Security.Configuration namespace in the object browser for that DLL.

  2. fregas baratis
    fregas baratis avatar
    185 posts
    Registered:
    14 Nov 2002
    24 Jan 2007
    Link to this post
    The security exception also occurs if i create my own project thru the project manager. 

    Craig

  3. Rebecca
    Rebecca avatar
    536 posts
    Registered:
    24 Sep 2012
    25 Jan 2007
    Link to this post
    Hi Fregas,

    These parameters were introduced with the latest build to support User Controls for Intra-Site modules. Please make sure you are using the correct version 3.0.2578.38253 of the assembly Telerik.Cms.dll.
    It is rather disturbing that JobsIntraSite is not compiling. We assume something went wrong with your installation. Please uninstall Sitefinity 3.0, delete \Program Files\telerik\Sitefinity 3.0 folder and install again. If the problem persists please open a support ticket.

    Does any one else experience this problem?

    Best wishes,
    Rebecca
    the telerik team
  4. fregas baratis
    fregas baratis avatar
    185 posts
    Registered:
    14 Nov 2002
    25 Jan 2007
    Link to this post
    I'll try that and let you know if it works. 

    Thanks.
  5. fregas baratis
    fregas baratis avatar
    185 posts
    Registered:
    14 Nov 2002
    25 Jan 2007
    Link to this post
    That fixed it!  It was just a bad install.  I thought I uninstalled the previous sitefinity but maybe i didn't or maybe it left some junk.

    The jobs site now compiles and the meta data looks right.

    If i have any other problems i'll keep you posted.

    Craig
Register for webinar
5 posts, 0 answered