+1-888-365-2779
Try Now
More in this section

Forums / 3.x Pre-release forums (retired) / Known issue when creating new project

Known issue when creating new project

14 posts, 0 answered
  1. rabchev
    rabchev avatar
    11 posts
    Registered:
    15 Sep 2006
    23 Dec 2006
    Link to this post
    When creating new project you may receive an error on the last step caused by improperly set permissions for the project folders. To fix it select C:\Program Files\telerik\Sitefinity3.0\WebSites, right click > properties > security > advanced > permissions, check the box next to “Replace permissions entries on all child objects…” and click OK.
  2. Ben Alexandra
    Ben Alexandra avatar
    215 posts
    Registered:
    15 Sep 2012
    26 Dec 2006
    Link to this post
    Hi,

    I'm still getting an error.  It works for about 3 minutes trying to create the site.  I creates all the folders and files, but then suddenly rolls it all back and gives the error below.  I've set the permissions as suggested below.

    Any other suggestions?

    Ben 

    Server Error in '/telerik/Sitefinity3.0' Application.

    Request timed out.

    Description: An unhandled exception occurred during the execution of the current web request. Please review the stack trace for more information about the error and where it originated in the code.

    Exception Details: System.Web.HttpException: Request timed out.

    Source Error:

    An unhandled exception was generated during the execution of the current web request. Information regarding the origin and location of the exception can be identified using the exception stack trace below.

    Stack Trace:

    [HttpException (0x80004005): Request timed out.]
    


    Version Information: Microsoft .NET Framework Version:2.0.50727.42; ASP.NET Version:2.0.50727.210
  3. Bogdana Ivanova
    Bogdana Ivanova avatar
    66 posts
    Registered:
    24 Sep 2012
    29 Dec 2006
    Link to this post
    Dear all,

    For the sake of your convenience we post a list of Sitefinity 3.0's known issues:

    1. Pages:
    • Design time – there are still problems with design time with some of the controls. All controls work fine in run time mode;
    • An exception appears on a given page when deleting its template;
    • Upload Controls - custom controls cannot be uploaded into the Toolbox under Mozilla Firefox;
    • Upload Controls - the code behind file (.cs) does not upload along with the ascx file;
    • There is no content in the Upload Control FAQ sections;

    2. Templates – being recently introduced as part of Sitefinity 3.0, templates work but are a bit unstable:

    • Cannot delete a duplicated template from the Template library – an exception appears;
    • An exception is thrown when binding navigation controls and SiteMapDataSource in templates;
    • If you edit a duplicated template, save changes and select another template from the Template library, you will notice that all templates look like those that you just modified. To fix, simply go to another tab (Pages for example) and come back to Templates;
    • There is no content in the Template Properties FAQ sections;

    3. Generic content:

    • The History is not finished yet;

    3. Modules public controls:

    • News – Syndication Feeds control throws an exception when adding it to a page without setting its properties;
    • Exception is shown when adding the Syndication Feed control to a page, setting RssType property to All News, and saving changes;
    • Polls - when voting once in a given poll an exception appears in all pages that contain the PollBox control set to this poll;
    • Blogs – exception error message right after the BlogId property of the Blog Archiver public control is set;
    • Posts Search, one of the Blogs public control does not display search results.

    4. Modules:

    • When deleting a news category, all pages that contain the NewsList public control raise exceptions;
    • Problems when removing modules altogether;
    • Adding a formatted text as a blog comment (Blogs Module -> Comments) and opening the comment into the public part of site reveals that there are html tags in front of and behind the formatted text;
    • There is no content in the FAQ sections of Comment section of the Blog module;
    • The calendar CSS (calendar.css) is not applied correctly in News and Blogs Modules. It is hard to select From/To dates;
    • Polls - cannot select a color from the Color picker under Mozilla Firefox;

    5. Security:

    • Security exception is thrown when Creating a new user with View and Create permissions for the site map;
    • When login as an user who has no permissions to create new pages and clicking the Create a Page button on the Dashboard, an exception error appears.

     

    Kind regards,
    the telerik team
  4. Ben Alexandra
    Ben Alexandra avatar
    215 posts
    Registered:
    15 Sep 2012
    24 Jan 2007
    Link to this post
    I downloaded Beta 3 and had this problem, then I did as instructed ("right click > properties > security > advanced > permissions, check the box next to “Replace permissions entries on all child objects…” and click OK.") and that fixed it.

    Then I downloaded Beta 3 v2 and have the same problem.  I tried the fix again, but no luck!  It says: Access is denied. in a red rectangle.  I don't think that's the same error, but I don't remember.

    Anyone else having trouble?  Is there a work around?

    Thanks

    Ben
  5. Vlad
    Vlad avatar
    498 posts
    Registered:
    15 Jul 2016
    25 Jan 2007
    Link to this post
    Hello Ben,

    As for the timeout exception, you can try to add the following line in the Sitefinity Project Manager Web.config (C:\Program Files\telerik\Sitefinity3.0\ProjectManager\Web.Config):

    <system.web>
        ...
        <
    httpRuntime executionTimeout="120"/>

    ...
    Please let us know if you need any further assistance.

    Greetings,
    Vlad
    the telerik team
  6. Ben Alexandra
    Ben Alexandra avatar
    215 posts
    Registered:
    15 Sep 2012
    25 Jan 2007
    Link to this post
    I got around it by copying the folder "ProjectManager\EmptyProject" to a location I could use it and creating the IIS virtual directory myself.  Seems to work fine (had me point it at a db when I opened it up and created my users)

    Should be a work around for other people who are having trouble, I guess

    Ben
  7. Vlad
    Vlad avatar
    498 posts
    Registered:
    15 Jul 2016
    26 Jan 2007
    Link to this post

    Hi Ben,

    It seems you have retired your Sitefinity Project Manager and did his job ;-)
    But apart from copying the files from "ProjectManager\EmptyProject" and setting properly the web site in the IIS, you need to add additional mapping to the script maps for the site in the IIS:




    Best wishes,

    Vlad
    the telerik team
  8. Ben Alexandra
    Ben Alexandra avatar
    215 posts
    Registered:
    15 Sep 2012
    26 Jan 2007
    Link to this post
    Hi Vlad,

    It's been working fine without that and in the past I've created projects using the project manager and then moved them to other servers or FTP'd them somewhere and they've seemed to work.

    What, exactly, does the scripts mapping do and when would I see errors show up if I don't do it?  Like I said, I haven't had problems yet.

    Ben
  9. Vassil Daskalov
    Vassil Daskalov avatar
    261 posts
    Registered:
    18 May 2013
    26 Jan 2007
    Link to this post
    Hello Ben,

    Without mapping, you will not be able to preview or edit templates in the admin section. Try to see what is the result if you go to the templates section. You should see a 404 error if you do not have the mapping.

    Best wishes,
    Vassil Daskalov
    the telerik team
  10. Vangelis
    Vangelis avatar
    153 posts
    Registered:
    07 Jan 2006
    08 Jul 2007
    Link to this post
    Hi Vassil,

    It would help if you provide the same info for template  mapping in IIS7 in case someone creates manually projects. I have created one and sure I had a problem on editing templates.

    Best regards

    Vagelis
  11. Rebecca
    Rebecca avatar
    536 posts
    Registered:
    24 Sep 2012
    09 Jul 2007
    Link to this post
    Hi Vagelis Kretsimos,

    Thanks for your suggestion. We will definitely add this information in the documentation.

    All the best,
    Rebecca
    the Telerik team

    Instantly find answers to your questions at the new Telerik Support Center
  12. Beau
    Beau  avatar
    8 posts
    Registered:
    18 Apr 2007
    23 Jul 2007
    Link to this post
    Hi, I'm having a similar problem. I'm clicking on create project and it starts creating a project just fine and copying all the files/folders etc... After about 3 minutes it gives me the same Access is Denied in the red rectagle box as well and deletes all the files/folders that it created. Anyone?
  13. Vangelis
    Vangelis avatar
    153 posts
    Registered:
    07 Jan 2006
    23 Jul 2007
    Link to this post
    Hi Beau,

    I also have this problem and the only workaround for the moment is create manually projects.

    Please read this thread which describes all is needed to setup up a new project.

    http://www.sitefinity.com/support/forums/support-forum-thread/b1043S-mhmbg.aspx

    Best regards

    Vagelis
  14. Vlad
    Vlad avatar
    498 posts
    Registered:
    15 Jul 2016
    24 Jul 2007
    Link to this post
    Hi,

    Also (for IIS5 and IIS6) this error could be caused by the following:

    • The user you are logging in with does not impersonated to an existing windows account. Make sure that Integrated Windows Authentication is enabled and Anonymous access is disabled for the Sitefinity3.0 virtual directory in the IIS.
    • The windows account the users is impersonated to has no rights to create virtual directories.

    Kind regards,
    Vlad
    the Telerik team

    Instantly find answers to your questions at the new Telerik Support Center
Register for webinar
14 posts, 0 answered