+1-888-365-2779
Try Now
More in this section

Nolic DB Error

4 posts, 0 answered
  1. Richard Baugh
    Richard Baugh avatar
    201 posts
    Registered:
    22 Aug 2012
    23 Mar 2007
    Link to this post
    I created a new template from a new master file. While I was still in the template manager section in the admin section I was trying to modify the template look. While I was adjusting the css file and refreshing the page to view the changes, I encountered this error message. Now I can't view the site at all.

    The object belongs already into a different transaction

    Description: An unhandled exception occurred during the execution of the current web request. Please review the stack trace for more information about the error and where it originated in the code.

    Exception Details: Nolics.ORMapper.Base.NolnetException: The object belongs already into a different transaction

    Source Error:

    An unhandled exception was generated during the execution of the current web request. Information regarding the origin and location of the exception can be identified using the exception stack trace below.

    Stack Trace:

    [NolnetException: The object belongs already into a different transaction]
       Nolics.ORMapper.Base.OdbClassHelper.JoinTransaction(IOdbClass cl, Transaction tran, Transaction& curTransaction, OdbObjectStates& state) +376
       Telerik.Cms.PageBase.Nolics.ORMapper.Base.IOdbClass.Join(Transaction tran) +17
       Nolics.ORMapper.Base.Transaction.Join(IOdbClass mem) +75
       Telerik.Cms.CmsProvider.Initialize(String name, NameValueCollection config) +126
       Telerik.Cms.NolicsCmsProvider.Initialize(String name, NameValueCollection config) +557
       Telerik.ObjectManager`1.InstantiateProvider(ProviderSettings providerSettings, Type providerType) +711
       Telerik.ObjectManager`1.InstantiateProviders(ProviderSettingsCollection configProviders, IDictionary`2 providers, Type providerType) +134
       Telerik.ObjectManager`1.Initialize() +569
       Telerik.ObjectManager`1..ctor(String provider) +12
       Telerik.ObjectManager`1..ctor() +11
       Telerik.Cms.Web.UrlHelper.FillTable() +112
       Telerik.Cms.Web.UrlHelper..cctor() +99
    
    [TypeInitializationException: The type initializer for 'Telerik.Cms.Web.UrlHelper' threw an exception.]
       Telerik.Cms.Web.UrlHelper.GetUrl(String url) +0
       Telerik.Cms.Web.CmsHttpModule.BeginRequest(Object sender, EventArgs e) +703
       System.Web.SyncEventExecutionStep.System.Web.HttpApplication.IExecutionStep.Execute() +92
       System.Web.HttpApplication.ExecuteStep(IExecutionStep step, Boolean& completedSynchronously) +64
    


    Is there anything that I can do, may DB side, to get the site working again?
  2. Rebecca
    Rebecca avatar
    536 posts
    Registered:
    24 Sep 2012
    23 Mar 2007
    Link to this post
    Hello Richard,

    We could not reproduce this. Can you please give us more detailed information about the steps you take to get the error? How did you "create a new template from a new master file"? Did you upload the master file first?

    Kind regards,
    Rebecca
    the telerik team

    Instantly find answers to your questions at the new telerik Support Center
  3. Richard Baugh
    Richard Baugh avatar
    201 posts
    Registered:
    22 Aug 2012
    23 Mar 2007
    Link to this post
    I created a new master file through VS2005. This was pretty much a duplicate of another master page. Once I got the master file setup, I FTP'd the file up to the development server. From ther I added the master file to the site through the Upload master file feature. After this I was able to edit the template and change the Theme. I then saved the changes and began to try and get the template looking the way I wanted it. I made some changes to the css file associated with the theme and also made some changes to the actual master file. All the time, I would refresh the page to see the changes. This worked wonderful for a little while. Then when I made a change to the css file and tried to refresh the page, I got the error. I never assigned the template to a page, just was refreshing to view changes.

    The problem I am having now is, that I can't view the site at all. Everytime I try to view the site, whether in the admin section or just try to bring the site up from the end-user's view, I get this error. 

    I have two templates and one page. Nothing fancy here. The first template is assigned to the main page and that page has two Generic Content controls on it. I was able to view this with no problems this morning. The second template was only uploaded. No controls were assigned to it and no pages are using it.
  4. Vassil Daskalov
    Vassil Daskalov avatar
    261 posts
    Registered:
    18 May 2013
    26 Mar 2007
    Link to this post
    Hi Richard,

    Unfortunately, we are not able to reproduce the problem. Can you please follow the steps below and let us know if the problem still persists? Be sure to back up your project and database:

    1. Remove all the .master files from the App_Master folder except the Dummy.master file and put them in a temporary directory.

    2. Restart IIS and run the application.

    3. Move back the files back to App_Master folder.

    4. Restart IIS once again.

    If the problem still persists, please send us your project along with the database to see what we can do about it. Your problem occurs in the module initialization which in the next version will use different implementation and the problem should not exist any more.

    Hope this helps.

    Sincerely yours,
    Vassil Daskalov
    the telerik team

    Instantly find answers to your questions at the new telerik Support Center
Register for webinar
4 posts, 0 answered