+1-888-365-2779
Try Now
More in this section

Forums / 3.x Pre-release forums (retired) / Resource not found without Virtual Directory in path

Resource not found without Virtual Directory in path

3 posts, 0 answered
  1. bnye
    bnye avatar
    332 posts
    Registered:
    22 Sep 2005
    11 May 2007
    Link to this post
    I created a site with a virtual directory. Now for deployment (today). We are removing all referenced to the virtual directory. All pages work fine with the Virtual Directory. All pages (except one set of sub pages) work fine without the sub pages.

    virtual/company/about.aspx - works fine
    virtual/contact/contactUs.aspx - works fine
    virtual/products/productAbout.aspx - Resource not found
    virtual/products/modules.aspx - Resource not found
    virtual/products/features.aspx - Resource not found

    Please advise.

    PS:
    1. this project was created in RC1 and upgraded.
    2. the virtual directory has the same name as the products page where sub items fail. /SITEFINITY/sitefinity.aspx

    Sincerely,

    Ben
  2. bnye
    bnye avatar
    332 posts
    Registered:
    22 Sep 2005
    11 May 2007
    Link to this post
    If I change the Page Name of the Products page while accessing sitefinity without the Virtual Directory the problem goes away.

    Strange.
  3. Pepi
    Pepi avatar
    981 posts
    Registered:
    28 Oct 2016
    15 May 2007
    Link to this post
    Hello Ben,

    We can not reproduce such a behavior. If I understand correctly the problem has appeared after the deployment, so have a look again at “Migrating Projects to the Production Web Server” chapter in User Manual. Follow all the instructions there and if you still can’t access products pages, please send your project and we will check.

    Sincerely yours,
    Pepi
    the Telerik team

    Instantly find answers to your questions at the new Telerik Support Center
Register for webinar
3 posts, 0 answered