+1-888-365-2779
Try Now
More in this section

SQL 2000

5 posts, 0 answered
  1. Karl Wigart
    Karl Wigart avatar
    2 posts
    Registered:
    01 Feb 2006
    23 Oct 2006
    Link to this post
    I'm running SQL 2000. Do you have a database for that or does Sitefinity only run against 2005?
    I have trie dto attach the database but the get error 602 which is the error you get if you try to attach a 2005 database to 2000.

    Karl
  2. Rebecca
    Rebecca avatar
    536 posts
    Registered:
    24 Sep 2012
    23 Oct 2006
    Link to this post
    Hi Karl,

    First of all, thank you for choosing to evaluate or CMS.
    In the official release of Sitefinity 3.0 this process will be automatically handled by the Sitefinity Project Manager.
    For the time being you can do this manually, following the steps below:
    1. Create a new database in SQL Server 2000, for example "test" and set the ASPNET account as db owner.

    2. To create the Membership database objects in SQL Server Database, run C:\WINDOWS\Microsoft.NET\Framework\<versionNumber>\aspnet_regsql.exe tool. For more information about using aspnet_regsql.exe, refer to http://msdn2.microsoft.com/en-US/library/ms229862.aspx

    3. Set the connection string in the C:\Program Files\telerik\Sitefinity3.0\Web.config file:

      <configuration>
        ...
        <connectionStrings>
          <add name="Sitefinity" connectionString="data source=(local);Integrated Security=SSPI;initial catalog=test" providerName="System.Data.SqlClient"/>

    4. In the C:\Program Files\telerik\Sitefinity3.0\Web.config file change:
      <nolics>
                  <connections>
                      <add name="DefaultNolicsConnection" driver="Nolics.ORMapper.DataProviders.SqlServer2005Provider, Nolics.Engine.v4.1, Version=4.1.2405.4, Culture=neutral, PublicKeyToken=c50af72fde0670b7" driverAssembly="C:\WINDOWS\assembly\GAC_MSIL\Nolics.Engine.v4.1\4.1.2405.4__c50af72fde0670b7\Nolics.Engine.v4.1.dll" connectionStringName="Sitefinity" defaultSource=""/>
                  </connections>
              </nolics>

      with:

      <nolics>
                  <connections>
                      <add name="DefaultNolicsConnection" driver="Nolics.ORMapper.DataProviders.SqlServer2000Provider, Nolics.Engine.v4.1, Version=4.1.2405.4, Culture=neutral, PublicKeyToken=c50af72fde0670b7" driverAssembly="C:\WINDOWS\assembly\GAC_MSIL\Nolics.Engine.v4.1\4.1.2405.4__c50af72fde0670b7\Nolics.Engine.v4.1.dll" connectionStringName="Sitefinity" defaultSource=""/>
                  </connections>
              </nolics>

    5. Create the Sitefinity administrator in the Membership services database.To do this, open Sitefinity 3.0 web site in Visual Studio.NET 2005. Open the Login.aspx file in design mode, click the smart tag and from the dropdown menu, select Administer Website. The ASP.NET Web Site Administration Tool opens. From the Security tab, create "Administrators" role and create admin user in this role.

    6. Log in Sitefinity 3.0 web site with the user you have created.

    Please do not hesitate to contact us if you have any other inquiries.

    Sincerely yours,
    Rebecca
    the telerik team
  3. Karl Wigart
    Karl Wigart avatar
    2 posts
    Registered:
    01 Feb 2006
    23 Oct 2006
    Link to this post
    I tried that and I can now login to the Sitefinity admin page.

    When I try to go to the Modules section I get this error:

     

    Server Error in '/telerik/Sitefinity3.0' Application.

    Configuration Error

    Description: An error occurred during the processing of a configuration file required to service this request. Please review the specific error details below and modify your configuration file appropriately.

    Parser Error Message: The text, ntext, and image data types cannot be compared or sorted, except when using IS NULL or LIKE operator.

    Source Error:

    Line 159:			<providers>
    Line 160:				<clear/>
    Line 161:				<add name="NolicsBlogsProvider" connectionStringName="DefaultNolicsConnection" type="Telerik.Blogs.NolicsBlogsProvider, Telerik.Blogs"/>
    Line 162:			</providers>
    Line 163:		</blogs>

    Source File: C:\Program Files\telerik\Sitefinity3.0\web.config    Line: 161


    Version Information: Microsoft .NET Framework Version:2.0.50727.42; ASP.NET Version:2.0.50727.210

    And I get this error when I try to add a new page:

     

    Server Error in '/telerik/Sitefinity3.0' Application.

    Object reference not set to an instance of an object.

    Description: An unhandled exception occurred during the execution of the current web request. Please review the stack trace for more information about the error and where it originated in the code.

    Exception Details: System.NullReferenceException: Object reference not set to an instance of an object.

    Source Error:

    An unhandled exception was generated during the execution of the current web request. Information regarding the origin and location of the exception can be identified using the exception stack trace below.

    Stack Trace:

    [NullReferenceException: Object reference not set to an instance of an object.]
       Telerik.Cms.Web.UI.PageProperties.Update(CmsPage page) +366
       Telerik.Cms.Web.UI.PageProperties.Button_Command(Object sender, CommandEventArgs e) +199
       System.Web.UI.WebControls.LinkButton.OnCommand(CommandEventArgs e) +105
       System.Web.UI.WebControls.LinkButton.RaisePostBackEvent(String eventArgument) +163
       System.Web.UI.WebControls.LinkButton.System.Web.UI.IPostBackEventHandler.RaisePostBackEvent(String eventArgument) +7
       System.Web.UI.Page.RaisePostBackEvent(IPostBackEventHandler sourceControl, String eventArgument) +11
       System.Web.UI.Page.RaisePostBackEvent(NameValueCollection postData) +174
       System.Web.UI.Page.ProcessRequestMain(Boolean includeStagesBeforeAsyncPoint, Boolean includeStagesAfterAsyncPoint) +5102
    


    Version Information: Microsoft .NET Framework Version:2.0.50727.42; ASP.NET Version:2.0.50727.210



    I have missed somthing in the Web.config file.

    Karl
  4. UI Crew
    UI Crew avatar
    99 posts
    Registered:
    24 Sep 2012
    24 Oct 2006
    Link to this post
    Hi Karl,

    Everyone is getting that error when trying to add a new page. Apparently there is a new build with the fix coming later this week. It is in another post.

    Cheers,

    Seth
  5. Vassil Daskalov
    Vassil Daskalov avatar
    261 posts
    Registered:
    18 May 2013
    24 Oct 2006
    Link to this post
    Hello Seth,

    The mistake with the blogs provider is ours. We are sorry for the inconvenience caused. It should be fixed with the new beta release. Please, let us know if there is still a problem with it.

    Greetings,
    Vassil Daskalov
    the telerik team
Register for webinar
5 posts, 0 answered