Try Now
More in this section

Forums / 3.x Pre-release forums (retired) / Still problem with SiteMapPath

Still problem with SiteMapPath

4 posts, 0 answered
  1. Len Ford
    Len Ford avatar
    25 posts
    29 Apr 2004
    24 Dec 2006
    Link to this post
    I assume that there is still a problem with SiteMapPath in this beta. I thought that there was going to be a new BreadCrumb control but I can't find it at the moment. Did it make it to this beta?
  2. rabchev
    rabchev avatar
    11 posts
    15 Sep 2006
    24 Dec 2006
    Link to this post


    I guess we have forgotten to put the Breadcrumb control in the toolbox. You can do it your self by adding the flowing line in the web.config in section <tlerik><cms><toolboxControls>:

    <add name=”Breadcrumb” section=”Navigation” type=”Telerik.Web.UI.Breadcrumb, Telerik.Web.UI”>

    You can remove the SiteMapPath control as it will not work.


  3. FredW
    FredW avatar
    5 posts
    21 Feb 2007
    21 May 2007
    Link to this post

    I have a site that was build before the official release of sitefinity which uses breadcrumbs in the master page. Unfortunately, I get an error which complains about an assembly reference that I need for breadcumbs. How can I make breadcrumbs work in master pages in Sitefinity 3.0's official Release 2 

    Parser Error
    Description: An error occurred during the parsing of a resource required to service this request. Please review the following specific parse error details and modify your source file appropriately.

    Parser Error Message: Could not load file or assembly 'Telerik.Web.UI' or one of its dependencies. The system cannot find the file specified.

    Source Error:

    Line 3:  <%@ Register Assembly="RadTreeView.Net2" Namespace="Telerik.WebControls" TagPrefix="radT" %>
    Line 4:  <%@ Register Namespace="Telerik.Cms.Web" Assembly="Telerik.Cms" TagPrefix="sf1" %>
    Line 5:  <%@ Register Namespace="Telerik.Web.UI" Assembly="Telerik.Web.UI" TagPrefix="sfbc" %>
    Line 6:  <%@ Register Src="/UserControls/google/GoogleForm.ascx" TagName="GoogleForm" TagPrefix="GoogleSearch1" %>
    Line 7:  <%@ Register TagPrefix="radr" Namespace="Telerik.WebControls" Assembly="RadRotator.Net2" %>


  4. Bob
    Bob avatar
    330 posts
    24 Sep 2012
    22 May 2007
    Link to this post
    Hi Fred,

    We renamed the namespace and assembly Telerik.Web.UI to Telerik.Cms.Web.UI to avoid conflicts with Prometheus. Please replace your declaration with this one:

    <%@ Register Namespace="Telerik.Cms.Web.UI" Assembly="Telerik.Cms.Web.UI" TagPrefix="sfbc" %>

    Best wishes,
    the Telerik team

    Instantly find answers to your questions at the new Telerik Support Center
Register for webinar
4 posts, 0 answered