+1-888-365-2779
Try Now
More in this section

Strips JS

8 posts, 0 answered
  1. Matt Shepherd
    Matt Shepherd avatar
    5 posts
    Registered:
    02 Nov 2006
    29 Mar 2007
    Link to this post
    When adding inline js code to the Generic Text area, (to include a flash file without the "click to activate" issue) the code is stipped on saving. 

    Any ideas?
    Cheers
  2. hibri
    hibri avatar
    12 posts
    Registered:
    06 Dec 2006
    30 Mar 2007
    Link to this post
    In your Admin/Common/Configuration/ContentConfigFile.xml

    Set the following
    <property name="AllowScripts">true</property>
  3. rmp
    rmp avatar
    13 posts
    Registered:
    26 Jun 2007
    16 Jul 2007
    Link to this post
    where is this ContentConfigFile.xml?

    I'm having a similar problem - sitefinity is stripping out an <embed /> tag that I need for a flash object to display in FireFox.

    Any suggestions?
    Thanks.
  4. Pepi
    Pepi avatar
    981 posts
    Registered:
    16 Sep 2016
    17 Jul 2007
    Link to this post
    Hello Mark,

    In the new versions of Sitefinity the ContentConfigFile.xml file is not used anymore. You can allow script tags in the RadEditor content from ~/Sitefinity/Admin/ControlTemplates/EditorConfigFile.xml. You should set the following:

    <property name="AllowScripts">true</property>

    Hope this helps. Don't hesitate to ask if there is some misunderstanding.

    Greetings,
    Pepi
    the Telerik team

    Instantly find answers to your questions at the new Telerik Support Center
  5. rmp
    rmp avatar
    13 posts
    Registered:
    26 Jun 2007
    17 Jul 2007
    Link to this post
    Hi Pepi,

    I tried changing allowscripts to true in that xml file and I'm still having the same problem. When I put an <embed /> element inside of an <object></object> element on a generic content area, it gets stripped out.
  6. Pepi
    Pepi avatar
    981 posts
    Registered:
    16 Sep 2016
    18 Jul 2007
    Link to this post
    Hi Mark,

    Could you please give us the following details to specify the problem:

    1. Exact browser version.
    2. Exact RadEditor version.
    3. Steps to reproduce the problem.
    4. End result.
    5. Describe what is wrong with the result.

    Also, I would recommend that you use the RadEditor Flash manager dialog. It inserts flash files in the editor's content area and uploads new flash files, which will be available for inserting.

    Thanks for your cooperation in advance.

    Best wishes,
    Pepi
    the Telerik team

    Instantly find answers to your questions at the new Telerik Support Center
  7. Ahmed Salman
    Ahmed Salman avatar
    31 posts
    Registered:
    13 Apr 2010
    27 Jul 2010
    Link to this post
    Dear Sir,

       i am using sitefinity 3.7 but i cannot file the file 
       ~/Sitefinity/Admin/ControlTemplates/EditorConfigFile.xml.


    ????
  8. Radoslav Georgiev
    Radoslav Georgiev avatar
    3370 posts
    Registered:
    01 Feb 2016
    27 Jul 2010
    Link to this post
    Hello Ahmed Salman,

    In versions after Sitefinity 3.6 the file is ~/Sitefinity/Admin/ControlTemplates/EditorToolsFile.xml

    All the best,
    Radoslav Georgiev
    the Telerik team
    Do you want to have your say when we set our development plans? Do you want to know when a feature you care about is added or when a bug fixed? Explore the Telerik Public Issue Tracking system and vote to affect the priority of the items
Register for webinar
8 posts, 0 answered