+1-888-365-2779
Try Now
More in this section

Forums / 3.x Pre-release forums (retired) / web.config RSS HttpModue error

web.config RSS HttpModue error

8 posts, 0 answered
  1. bnye
    bnye avatar
    332 posts
    Registered:
    22 Sep 2005
    20 Nov 2006
    Link to this post
    I get a web.conig error. It's probably something simple, but any help would be appreciated:

    Parser Error Message: Could not load type 'Telerik.RSS.RssHttpHandler' from assembly 'Telerik.RSS'.

    <system.web>
    Line 28:     <httpHandlers>
    Line 29:       <add verb="*" path="*.rss" type="Telerik.RSS.RssHttpHandler, Telerik.RSS"/>
    Line 30:     </httpHandlers>
    Line 31: <customErrors mode="Off"/>
  2. bnye
    bnye avatar
    332 posts
    Registered:
    22 Sep 2005
    21 Nov 2006
    Link to this post
    First time I uninstalled/rebooted/installed beta 2.

    This time I did the following:

    Stopped IIS
    Deleted previous Sitefinity 3.0 Virtual Directory
    Uninstalled Sitefinity 3.0
    ReInstalled Beta 2
    Works like a champ must have been my machine or the clown working the keyboard.

    The new RSS feature is a nice touch. I did notice that the IE 7 Feed finder does not recognize the link as a link to a feed. Not sure why.

    I too am getting the request for license that pops up periodically if you do not have a valid license. Would it be possible to drop the license file from the last build into the RadControls directory to avoid this?

    Thanks,

    Ben
  3. Sean
    Sean avatar
    271 posts
    Registered:
    31 May 2006
    21 Nov 2006
    Link to this post
    Yeah it doesn't get picked up by the feed finder because it actually had to be advertised in the header.  By using the syntax:

    <link rel="alternate" type="application/rss+xml" title="Friendly title" href=http://blogaddress />

    I think it would be great if Telerik can add that funcationality... I tried to add it myself to test it but I noticed the address would need to be dynamic as it refers to the page it is on....  also I noticed a bug when I tried to add it myself where when trying to add the "link" meta tag that it renders in the browser as a "span" instead....

    Otherwise I think the RSS is a great addition, it is funny because I had the idea of asking if that could be included, but they beat me to it.  Really on the ball Telerik!

    The product is really shaping up...
  4. Vassil Daskalov
    Vassil Daskalov avatar
    261 posts
    Registered:
    18 May 2013
    21 Nov 2006
    Link to this post
    Hi,

    Thank you very much for the RSS feedback you are giving us. You are right that we should add the link tag in the page header. It will be included in our next release.

    Can you give us more information about how are you adding the link tag in the page header so we could reproduce and fix the problem?

    Sincerely yours,
    Vassil Daskalov
    the telerik team
  5. Sean
    Sean avatar
    271 posts
    Registered:
    31 May 2006
    21 Nov 2006
    Link to this post
    Hi,

    To replicate the span problem, I went to:
    1. Pages
    2. Clicked Blog
    3. Next to Add a Tag Clicked link
    4. Set "type" to "application/rss+xml"
    5. set "rel" to "alternate"
    6. set "href" to http://localhost/telerik/Sitefinity3.0/blog.rss?showAllBlogs=true&blogsLink=http%3a%2f%2flocalhost%2ftelerik%2fSitefinity3.0%2fBlog.aspx&postsLink=http%3a%2f%2flocalhost%2ftelerik%2fSitefinity3.0%2fBlog%2fSingleBlog.aspx

    Then saved and when I viewed the source of the live site in IE this is what it has in the head:

    <span href="http://localhost/telerik/Sitefinity3.0/blog.rss?showAllBlogs=true&amp;blogsLink=http%3a%2f%2flocalhost%2ftelerik%2fSitefinity3.0%2fBlog.aspx&amp;postsLink=http%3a%2f%2flocalhost%2ftelerik%2fSitefinity3.0%2fBlog%2fSingleBlog.aspx" rel="alternate" type="application/rss+xml"></span>

    Another thing is you can't add the property title to the link tag, I am not sure if that is just something MS use...

    Cheers
    Sean

  6. Vlad
    Vlad avatar
    498 posts
    Registered:
    15 Jul 2016
    21 Nov 2006
    Link to this post
    Hello Sean,

    Thank you for reporting the bug with the header tags. We will fix it in the next release of Sitefinity. Also we will add a title attribute to the link tag.
     

    Sincerely yours,
    Vlad
    the telerik team
  7. Szymon
    Szymon avatar
    22 posts
    Registered:
    04 Jan 2008
    09 Feb 2008
    Link to this post
    Hi,

    I have a blog on my website with RSS feed and I was trying to add the RSS link to the page header so it could be auto-discovered by feed readers. I went to the More options section for that page, then 'add head tags' and added a new link. But there is no application/rss+xml value in the link type drop down. I also tried to modify the site masterpage to include this link in the header but it was removed at runtime. Maybe I'm missing something here and there is some other way to do this.
     
    Thanks for any advise,
    -Szymon
  8. Vassil Daskalov
    Vassil Daskalov avatar
    261 posts
    Registered:
    18 May 2013
    12 Feb 2008
    Link to this post
    Hi Szymon,

    Indeed you are right that currently we do not allow the application/rss+xml value for the link tag. In the next release (v3.2) there will be more options to choose from when editing the heading of your pages. Currently, to add link head tag with this value you would only need to drop a RssFeed control to your page and set its NavigateUrl property to your rss feed. This control automatically adds the needed tag to your header.

    Hope this would help.

    Kind regards,
    Vassil Daskalov
    the Telerik team

    Instantly find answers to your questions at the new Telerik Support Center
Register for webinar
8 posts, 0 answered