1-888-365-2779
+1-888-365-2779
Try Now
More in this section

Forums / Bugs & Issues / 4.1 Upgrade blew out permissions

4.1 Upgrade blew out permissions

5 posts, 0 answered
  1. Abraham
    Abraham avatar
    29 posts
    Registered:
    11 Aug 2010
    21 Apr 2011
    Link to this post
    I have several users that are members of all application roles except Administrators.  Before the upgrade they could access Design and Analytics, but now they cannot. 

    I compared the upgraded site to a default installation of 4.1 for the designers role.  In the upgraded site designers have no permissions.  In the default site they have several permissions.  I have verified that it also affected other default roles such as editor.  Do you have a script that I can run to set the default application roles back to their default permissions?

    Abraham
  2. Boyan Barnev
    Boyan Barnev avatar
    1429 posts
    Registered:
    28 Aug 2017
    27 Apr 2011
    Link to this post
    Hello Abraham,

     I have replied to you in the support thread you have opened, you can check my response there. For your convenience I'm pasting my reply below:
    " Can you, please, inform me about the exact scenario where this problem reproduces? Generally there might be a reason for default permissions to differ between upgraded version and a blank project created with 4.1 Project Manager - we did introduce some changes in the permissions for the default roles in 4.1 but the upgrade script should not change the permissions on an already running site, that's why it should be disabled during upgrade. Can you, please verify if the issue reproduces with a blank project after upgrade, and provide me with some more details so that I can inspect this issue further. Thanks in advance."
    Looking forward for your feedback on this, if you have any additional questions, please do not hesitate to write back.

    All the best,
    Boyan Barnev
    the Telerik team

  3. Suzanne
    Suzanne avatar
    43 posts
    Registered:
    12 Jul 2012
    29 Apr 2011
    Link to this post
    I just ran the upgrade to 4.1 and administrators cannot login... not sure if this is happening with with other roles yet.  Did you get this resolved?
  4. Boyan Barnev
    Boyan Barnev avatar
    1429 posts
    Registered:
    28 Aug 2017
    02 May 2011
    Link to this post
    Hello Suzanne,

    No, we haven't experienced problems concerning default roles after upgrade. Can you paste the exception that you are getting when trying to login with one of the default roles, and provide me with some background concerning your project so that I can advise you further.

    Kind regards,
    Boyan Barnev
    the Telerik team
    Do you want to have your say in the Sitefinity development roadmap? Do you want to know when a feature you requested is added or when a bug fixed? Explore the Telerik Public Issue Tracking system and vote to affect the priority of the items
  5. Suzanne
    Suzanne avatar
    43 posts
    Registered:
    12 Jul 2012
    02 May 2011
    Link to this post
    I wasn't getting an exception.  The validation message was display - "Invalid username and/or password".  We tried logging in with multiple admin accounts and all had the same issues.

    We had other issues with the upgrade, could not publish etc., so in the end we created a clean install of a 4.1 site and ported our functionality over.
5 posts, 0 answered