+1-888-365-2779
Try Now
More in this section

Forums / Bugs & Issues / 403 - Forbidden: Access is denied

403 - Forbidden: Access is denied

5 posts, 0 answered
  1. Devin
    Devin avatar
    149 posts
    Registered:
    09 Jun 2009
    23 Jun 2011
    Link to this post
    Hi I've setup a page group in Sitefinity 4.0 with a page in it.  When I view this page on my test server it works fine but not when I view it on the live server.  Can you please help?

    Thanks!
    Devin
  2. Boyan Barnev
    Boyan Barnev avatar
    1429 posts
    Registered:
    08 Dec 2016
    23 Jun 2011
    Link to this post
    Hello Devin,

    Could it be taht you have set some different permissions on your page, as Sitefinity returns 403 for pages which the current user does not have rits to view? Can you please make sure if this is the case, and if not, can you check if you have everything setup in IIS according to this article from our Documentation. Thanks in advance.

    All the best,
    Boyan Barnev
    the Telerik team
    Do you want to have your say in the Sitefinity development roadmap? Do you want to know when a feature you requested is added or when a bug fixed? Explore the Telerik Public Issue Tracking system and vote to affect the priority of the items
  3. Devin
    Devin avatar
    149 posts
    Registered:
    09 Jun 2009
    23 Jun 2011
    Link to this post
    Hi Boyan,
    This page group and its subpages have Everyone set for view rights.  I've checked the IIS setup and it appears to be ok.

    Thanks,
    Devin
  4. Boyan Barnev
    Boyan Barnev avatar
    1429 posts
    Registered:
    08 Dec 2016
    24 Jun 2011
    Link to this post
    Hi Devin,

    This behavior is really strange, can you make sure if it reproduces with a blank project created with the same version of the project manager. Generally, if the functionality is working fine on your local machine, there should be no problems in the project itself but the infrastructure setup, could it be that you have uploaded a different database-configurations set to your test server , so the user permissions do not match the default ones set on your site. Also, is it possible that you have set the view permissions to Administrators and Everyone, we used to have an issue with a client who had performed similar setup, which resulted in the same behavior. If the same problems occur with a blank project, is it possible to provide me with temporary login credentials to your site's backend so I can observe this issue myself. Thanks in advance.

    Regards,
    Boyan Barnev
    the Telerik team
    Do you want to have your say in the Sitefinity development roadmap? Do you want to know when a feature you requested is added or when a bug fixed? Explore the Telerik Public Issue Tracking system and vote to affect the priority of the items
  5. Jacques
    Jacques avatar
    427 posts
    Registered:
    28 Jun 2007
    09 Sep 2014
    Link to this post

    I'm suddenly getting the same issues. 

    Sitefinity 4.4 (please don't tell me to upgrade)

    We have a list of pages under /office representing individual offices for example:
    http://www.jawitz.co.za/Office/Kuilsriver

    However we suddenly find some of these office pages returning 403 - Forbidden errors e.g.: 
    http://www.jawitz.co.za/Office/Johannesburg-North

    I've checked:

    1. That the permissions are correct. See attached permissions.png screenshot
    2. That the page is published. See 
    3. That the page is editable. See attached Published.png screenshot.
    4. That the page properties are valid. See attached Page Properties.jpg screenshot.
    5. See the revision history. v 20 is the original, 21 through 23 is me attempting saves just to see if that would fix the problem. 

    Note: We've made no changes to IIS (see iis.png screenshot)

    PS. Please don't tell me you can't replicate the issue, that doesn't help. Some of the office pages are working perfectly others simply return the 403 error. 

     Thanks,
    Jacques

5 posts, 0 answered