1-888-365-2779
+1-888-365-2779
Try Now
More in this section

Forums / Bugs & Issues / The resource cannot be found.

The resource cannot be found.

9 posts, 0 answered
  1. Chris Hayward
    Chris Hayward avatar
    36 posts
    Registered:
    17 Dec 2009
    01 May 2011
    Link to this post
     Very experienced with sitefinity 3.x, new to sitefinity 4.1

    Ran the installer, all is good, went through setup, configured database and ready to go.

    Sitefinity admin is working great, been able to upload our first test master page etc.

    When testing it in browser though, something was odd, our images werent appearing.

    I figured it was our css such as typical path issue, but it wasnt.

    When loading any of our image url's in the browser, they're all returning 404 errors.

    ie:

    /images/template/logo.png
    /images/template/background.gif
    /images/template/test.jpg
    (all formatS)

    When manually browsing to the /images folder, we can browse to the template folder, then click on one of those files (so im positive they exist), and returns 404 error.

    Incase this was some sort of url routing issue with the development server, we've tried:
    - Debugging through visual web developer
    - running it from the sitefinity project manager
    - setting up a website on IIS7 directly and running from there

    our other files, such as /css/test.css, are loading just fine.

    The MIME types for images exist on the server (IIS)

    So currently, i'm stumped.

    Am i missing something really obvious?

    thanks,

    Chris
  2. Victor Velev
    Victor Velev avatar
    1345 posts
    Registered:
    06 Jul 2015
    02 May 2011
    Link to this post
    Hello Chris,

    From the sound of it looks like you are experiencing the problem when creating a new project? Am I right? If that is the case the issue may be originating from your IIS configuration. The wildcard handler mapping method should be enabled in order for the images to function properly.

    Could you please check the following tutorials on how to set up Sitefinity on IIS and especially to Wildcard Mapping:

    How to setup Sitefinity on IIS 6:

    http://www.sitefinity.com/blogs/joshmorales/posts/11-02-23/installing_sitefinity_4_on_iis_6.aspx

    How to setup Sitefinity on IIS 7:

    http://www.sitefinity.com/blogs/joshmorales/posts/11-02-22/installing_sitefinity_4_on_iis_7.aspx

    Please inform me if  the proposed solution helps you.

    Kind regards,
    Victor Velev
    the Telerik team
    Do you want to have your say in the Sitefinity development roadmap? Do you want to know when a feature you requested is added or when a bug fixed? Explore the Telerik Public Issue Tracking system and vote to affect the priority of the items
  3. Chris Hayward
    Chris Hayward avatar
    36 posts
    Registered:
    17 Dec 2009
    02 May 2011
    Link to this post
    Unfortunately no luck

    attached screenshot from iis showing wildcards enabled

    Also yes, this is a new installation

    Keep in mind, this also happens when we dont use IIS and use the sitefinity server or through visual web developer compiling.    Other websites on this computer are functioning normally when testing

    thx

    Chris
  4. Chris Hayward
    Chris Hayward avatar
    36 posts
    Registered:
    17 Dec 2009
    02 May 2011
    Link to this post
    An additional update -- we've tried this on a different, older machine (windows xp instead of windows 7), same result. 

    All we're doing is
    - running sitefinity setup (localhost database)
    - cutting/pasting the images folder into our newly created site
    - trying to load images into our browser

    thx

    Chris
  5. Victor Velev
    Victor Velev avatar
    1345 posts
    Registered:
    06 Jul 2015
    03 May 2011
    Link to this post
    Hello Chris,

    Thank you for getting back to me.

    If you have set all the necessary mappings and settings correctly, the problem may be occurring because in SF 4.1 virtual paths cannot match the physical paths of libraries ( this counts for both images and videos ). Please check the following KB article which explains how to go around this issue.

    There is one more option that you can check if the images are not served, but its mainly concerning IIS.  -uncheck 'Verify if file exists' checkbox located in your Wildcard Application Map setting.

      Please get back to me if the above article & setting cannot resolve the problem.

    Best wishes,
    Victor Velev
    the Telerik team
    Do you want to have your say in the Sitefinity development roadmap? Do you want to know when a feature you requested is added or when a bug fixed? Explore the Telerik Public Issue Tracking system and vote to affect the priority of the items
  6. Chris Hayward
    Chris Hayward avatar
    36 posts
    Registered:
    17 Dec 2009
    03 May 2011
    Link to this post
    Thank you very much!

    This resolved our issue.
  7. Victor Velev
    Victor Velev avatar
    1345 posts
    Registered:
    06 Jul 2015
    04 May 2011
    Link to this post
    Hello Chris,

    Glad to hear the solution helped you. I will close this thread for now but if you have any more questions about this service request do not hesitate to contact me again.

    Kind regards,
    Victor Velev
    the Telerik team
    Do you want to have your say in the Sitefinity development roadmap? Do you want to know when a feature you requested is added or when a bug fixed? Explore the Telerik Public Issue Tracking system and vote to affect the priority of the items
  8. mexner
    mexner avatar
    98 posts
    Registered:
    06 Apr 2006
    15 Jul 2011
    Link to this post
    Hello, I have followed the instructions here -- and have success with all of my images.
    http://www.sitefinity.com/devnet/kb/sitefinity-4-x/static-files-are-not-served-from-images-or-videos-folders.aspx

    My problem is - I'm having a similar issue with my javascript. All my j/s is located at 
    ~/js

    If I try to call a .js file, I get a 404 - but the file IS THERE. Just like Chris explained for the images, I have the same problem for my j/s files located at the root, ~/js

    I don't see a place to apply similar changes for javascript, like I would for images and video's. 

    Do you have a way for me to fix this?
  9. Victor Velev
    Victor Velev avatar
    1345 posts
    Registered:
    06 Jul 2015
    15 Jul 2011
    Link to this post
    Hi Mexner,

    If you want to use javascript in a custom control, you need to add the following:

    <%@ Register Assembly="Telerik.Sitefinity" Namespace="Telerik.Sitefinity.Web.UI" TagPrefix="sf" %>

    and also to register the proper assembly and the following markup for your custom file:

    <sf:ResourceLinksid="resourcesLinks"runat="server">
        <sf:ResourceFileName="JS/myJS.js"/>
    </sf:ResourceLinks

    All the best,
    Victor Velev
    the Telerik team
    Do you want to have your say in the Sitefinity development roadmap? Do you want to know when a feature you requested is added or when a bug fixed? Explore the Telerik Public Issue Tracking system and vote to affect the priority of the items
9 posts, 0 answered