+1-888-365-2779
Try Now
More in this section

Forums / Bugs & Issues / 5.0 upgrade - all custom product edit pages broken

5.0 upgrade - all custom product edit pages broken

6 posts, 1 answered
  1. Nick
    Nick avatar
    113 posts
    Registered:
    21 Oct 2008
    28 Mar 2012
    Link to this post
    I've upgraded from 4.4 to 5.0, and when trying to edit any product that is a custom product type I get this error:

    Server Error in '/' Application.

    Specified argument was out of the range of valid values.
    Parameter name: The view specified in the url cannot be found in the Views collection of the current control.

    Description: An unhandled exception occurred during the execution of the current web request. Please review the stack trace for more information about the error and where it originated in the code. 

    Exception Details: System.ArgumentOutOfRangeException: Specified argument was out of the range of valid values.
    Parameter name: The view specified in the url cannot be found in the Views collection of the current control.

    Source Error: 

    An unhandled exception was generated during the execution of the current web request. Information regarding the origin and location of the exception can be identified using the exception stack trace below.

    Stack Trace: 

    [ArgumentOutOfRangeException: Specified argument was out of the range of valid values.
    Parameter name: The view specified in the url cannot be found in the Views collection of the current control.]
       Telerik.Sitefinity.Web.UI.ContentUI.ContentView.DetermineCurrentViewName() +461
       Telerik.Sitefinity.Web.UI.ContentUI.ContentView.CreateChildControls() +60
       System.Web.UI.Control.EnsureChildControls() +102
       System.Web.UI.Control.PreRenderRecursiveInternal() +42
       System.Web.UI.Control.PreRenderRecursiveInternal() +175
       System.Web.UI.Control.PreRenderRecursiveInternal() +175
       System.Web.UI.Control.PreRenderRecursiveInternal() +175
       System.Web.UI.Control.PreRenderRecursiveInternal() +175
       System.Web.UI.Control.PreRenderRecursiveInternal() +175
       System.Web.UI.Control.PreRenderRecursiveInternal() +175
       System.Web.UI.Page.ProcessRequestMain(Boolean includeStagesBeforeAsyncPoint, Boolean includeStagesAfterAsyncPoint) +2496

    Anyone know how to fix this?
  2. Nick
    Nick avatar
    113 posts
    Registered:
    21 Oct 2008
    28 Mar 2012
    Link to this post
    Whilst I'm at it, if I try to edit a back end page I get this error:

    Could not find the specified key "Breadcrumb" or class id "PageResources".
    Description: An unhandled exception occurred during the execution of the current web request. Please review the stack trace for more information about the error and where it originated in the code. 

    Exception Details: System.ArgumentException: Could not find the specified key "Breadcrumb" or class id "PageResources".

    Source Error: 

    An unhandled exception was generated during the execution of the current web request. Information regarding the origin and location of the exception can be identified using the exception stack trace below.

    Stack Trace: 

    [ArgumentException: Could not find the specified key "Breadcrumb" or class id "PageResources".]
       Telerik.Sitefinity.Localization.Resource.GetString(ResourceDataProvider provider, String classId, String key, CultureInfo culture, Boolean falback, Boolean throws) +411
       Telerik.Sitefinity.Localization.Res.Get(String classId, String key, CultureInfo culture, Boolean fallback, Boolean throws) +152
       Telerik.Sitefinity.Web.UI.ZoneEditor.CreateToolboxDock(ToolboxItem item) +876
       Telerik.Sitefinity.Web.UI.ZoneEditor.ProcessToolboxSection(ToolboxSection section) +232
       Telerik.Sitefinity.Web.UI.ZoneEditor.CreateToolBoxPanelbar(Toolbox toolbox, String id) +316
       Telerik.Sitefinity.Web.UI.ZoneEditor.CreateControlToolBox() +59
       Telerik.Sitefinity.Web.UI.ZoneEditor.CreateToolbox() +167
       Telerik.Sitefinity.Web.UI.ZoneEditor.CreateChildControls() +144
       System.Web.UI.Control.EnsureChildControls() +102
       System.Web.UI.Control.PreRenderRecursiveInternal() +42
       System.Web.UI.Control.PreRenderRecursiveInternal() +175
       System.Web.UI.Control.PreRenderRecursiveInternal() +175
       System.Web.UI.Page.ProcessRequestMain(Boolean includeStagesBeforeAsyncPoint, Boolean includeStagesAfterAsyncPoint) +2496
  3. Stanislav Velikov
    Stanislav Velikov avatar
    1113 posts
    Registered:
    08 Dec 2016
    29 Mar 2012
    Link to this post
    Hello,

    Concerning the error:
    Could not find the specified key "Breadcrumb" or class id "PageResources".
    The Breadcrumb widget that comes with Sitefinity 5.0 is not installed. To fix the error message go to Administration->Settings->Advanced->Toolboxes->Toolboxes->PageControls->Sections->Navigation->Tools->Breadcrumbs and delete the breadcrumb widget. Please to this at a test project first, This will let you access the page, but the breadcrumb widget will be missing.
    Try installing the widget again.

    Control CLR Type or Virtual Path: Telerik.Sitefinity.Web.UI.NavigationControls.Breadcrumb.Breadcrumb, Telerik.Sitefinity, Version=5.0.2472.0, Culture=neutral, PublicKeyToken=b28c218413bdf563

    Name: Breadcrumb
    Title:BreadcrumbTitle
    Description:BreadcrumbDescription
    Global resource class ID:Global resource class ID
    CssClass:sfBreadcrumbIcn
    Check if the breadcrumb is working properly in the project.


    Regards,
    Stanislav Velikov
    the Telerik team
    Do you want to have your say in the Sitefinity development roadmap? Do you want to know when a feature you requested is added or when a bug fixed? Explore the Telerik Public Issue Tracking system and vote to affect the priority of the items
    Answered
  4. Nick
    Nick avatar
    113 posts
    Registered:
    21 Oct 2008
    04 Apr 2012
    Link to this post
    Thank you for pointing me in the right direction. The issue was a conflict between the new Sitefinity breadcrumb control and our own breadcrumb control that we had built and installed ourselves. I only had to change the name of our breadcrumb control and that made it all work again.
  5. Nick
    Nick avatar
    113 posts
    Registered:
    21 Oct 2008
    04 Apr 2012
    Link to this post
    The first issue (editing products with a custom product type produces error page) appears to be because my CatalogConfig.config is missing all the views and definitions for those product types. I've just created a new product type as a test and it's all working fine. So somehow recently I've lost all my custom product settings in the config files. I'm not sure if it was the 4.4 > 5.0 upgrade, or something going horribly wrong in our systems.

    Update: 
    Problem solved. My backup contained most of the relevant settings, and anything missing has been manually recreated. I'm still not sure how it happened, I assume this isn't a recognised upgrade bug?
  6. Ben
    Ben avatar
    44 posts
    Registered:
    27 Sep 2012
    25 Oct 2012 in reply to Nick
    Link to this post
    Must not be because I just upgraded to 5.2 and your post saved me a lot of time. 

    Thanks!
6 posts, 1 answered