+1-888-365-2779
Try Now
More in this section

Forums / Bugs & Issues / 5.4 Upgrading Server Error issue no configuration section named "newsConfig"

5.4 Upgrading Server Error issue no configuration section named "newsConfig"

2 posts, 1 answered
  1. Oliver
    Oliver  avatar
    4 posts
    Registered:
    05 Oct 2012
    05 Mar 2013
    Link to this post

    Doing an upgrade from 5.2 to 5.4.4010.0 everything compiles fine but getting an error when trying to run it saying.

    Server Error in '/' Application.

    There is no configuration section with the name:"newsConfig"

    Stack Trace:

    [ArgumentException: There is no configuration section with the name:"newsConfig"]
    Telerik.Sitefinity.Configuration.Config.GetConfigSection(String name) +153
    Telerik.Sitefinity.Configuration.Config.GetByPath(String path) +61
    Telerik.Sitefinity.Web.UI.DefinitionBase.GetConfigurationDefinition() +21
    Telerik.Sitefinity.Web.UI.DefinitionBase.get_ConfigDefinition() +21
    Telerik.Sitefinity.Web.UI.DefinitionBase.ResolveProperty(String propertyName, T instanceValue, T defaultValue) +226
    Telerik.Sitefinity.Web.UI.DefinitionBase.ResolveProperty(String propertyName, T instanceValue) +62
    Telerik.Sitefinity.Web.UI.ContentUI.ContentViewDefinition.get_ViewVirtualPath() +35
    Telerik.Sitefinity.Web.UI.ContentUI.ContentView.LoadView(String viewName) +86
    Telerik.Sitefinity.Web.UI.ContentUI.ContentView.CreateChildControls() +95
    System.Web.UI.Control.EnsureChildControls() +102
    System.Web.UI.Control.PreRenderRecursiveInternal() +42
    System.Web.UI.Control.PreRenderRecursiveInternal() +175
    System.Web.UI.Control.PreRenderRecursiveInternal() +175
    System.Web.UI.Control.PreRenderRecursiveInternal() +175
    System.Web.UI.Control.PreRenderRecursiveInternal() +175
    System.Web.UI.Control.PreRenderRecursiveInternal() +175
    System.Web.UI.Control.PreRenderRecursiveInternal() +175
    System.Web.UI.Page.ProcessRequestMain(Boolean includeStagesBeforeAsyncPoint, Boolean includeStagesAfterAsyncPoint) +2496

    I checked my AppData\Configuration\NewsConfig.config and saw it there, do I need to reference this somewhere else?

     

  2. Victor
    Victor avatar
    94 posts
    Registered:
    15 Jun 2011
    05 Mar 2013 in reply to Oliver
    Link to this post

    Go to Administration -> Modules and make sure "News" is active and turned on.  I've ran across a few upgrades where the module was deactivated and caused this error.

    Answered
2 posts, 1 answered