1-888-365-2779
+1-888-365-2779
Try Now
More in this section

Forums / Bugs & Issues / after 4.2 Upgrade, can't upload Documents

after 4.2 Upgrade, can't upload Documents

12 posts, 0 answered
  1. Jason
    Jason avatar
    7 posts
    Registered:
    25 Jul 2008
    08 Sep 2011
    Link to this post
    I upgraded our site from 4.0 to 4.2 last week.  Everything has been working OK.

    However, yesterday I tried to edit some content for the first time.  I'm trying to upload some PDF's - after selecting the files and starting the upload, it just hangs.  I've tried with small and large files, multiple and single, and every browser I have - I always get hung up.  I didn't have problems doing this under 4.0.

    Once, in Chrome, I got the following error (see attached)

    The files I've tried using are between 20 and 300k.

  2. Anthony
    Anthony avatar
    108 posts
    Registered:
    29 Sep 2008
    09 Sep 2011
    Link to this post
    I just got the something similar!  I am not getting any error messages, but after choosing to upload an document, I select the document and then the page changes to what you see in the screenshot.  It has happened in Chrome and IE.  I haven't tried in FF.

    The same thing happens for images.  This happens when uploading through Libraries/Albums in the backend.  Everything works normal when uploading images/documents via the content block editor.

    I need help with this ASAP.  I went from 4.1 sp3 to 4.2.

    Anthony
  3. Jason
    Jason avatar
    7 posts
    Registered:
    25 Jul 2008
    09 Sep 2011
    Link to this post
    I temporarily worked around this by ftp'ing my docs and manually linking them. 
  4. Adam
    Adam avatar
    5 posts
    Registered:
    09 Sep 2011
    09 Sep 2011
    Link to this post
    Just started having the exact same issue as Anthony last night.  The odd thing is that no changes were made between when it worked... and when it didn't.
  5. Anthony
    Anthony avatar
    108 posts
    Registered:
    29 Sep 2008
    09 Sep 2011
    Link to this post
    Okay, I have some other weird stuff going on.  I am currently using Windows 7.  Everyone else here is on XP.  All the xp machines are working.  I know that all of these controls use Silverlight.  I went to the www.getsilverlight.net website to see if it is installed. The webpage never stops looking for silverlight.  I have uninstalled the version of Silverlight I had and now it seems I cannot reinstall.  Something is going on with Silverlight and access to my computer.

    It seems that something on my computer is blocking access to silverlight, and hence blocking access to the controls.  I have viewed the source of the information that the website is sending to the browser...and from my limited understanding it looks like all the information is there, but silverlight never responds that it has identified the file so the options of the library, categories and publishing are never displayed.  It is essentially still waiting for silverlight to respond.

    Let me know if this looks like what could be happening for you.

    Anthony
  6. Adam
    Adam avatar
    5 posts
    Registered:
    09 Sep 2011
    09 Sep 2011
    Link to this post
    I uninstalled and reinstalled silverlight using the directions at:
    http://www.microsoft.com/getsilverlight/get-started/install/default.aspx

    I double-checked all the MIME and Mapping settings in IIS.  And I checked and reset all the App_Data folder and sub-folder permissions just to make sure.

    Would be nice if it actually logged an error.... instead all I get is a hung page that looks like this.

  7. Jason
    Jason avatar
    7 posts
    Registered:
    25 Jul 2008
    09 Sep 2011
    Link to this post
    I've had a few cases where it hangs BEFORE the upload control loads, but in most cases it is hanging AFTER the silverlight control loads and I select my files to upload.
  8. Adam
    Adam avatar
    5 posts
    Registered:
    09 Sep 2011
    09 Sep 2011
    Link to this post
    "I've had a few cases where it hangs BEFORE the upload control loads, but in most cases it is hanging AFTER the silverlight control loads and I select my files to upload."

    We are experiencing the same behavior.  The control loads - allows you to select a file you attempt to upload it and it hangs.
  9. Adam
    Adam avatar
    5 posts
    Registered:
    09 Sep 2011
    12 Sep 2011
    Link to this post
    Not just images.... is also occurring on all document libraries now.
  10. Swanand
    Swanand avatar
    3 posts
    Registered:
    15 Jun 2011
    14 Sep 2011
    Link to this post

    We also faced the same issue about which lot of people are talking in this discussion.
    .Actually ClientBin folder of project contains one file as "Telerik.Sitefinity.Silverlight.xap" which is used by sitefinity's

    upload control. We found that in one of our machine where upload control is working well even after upgrading from sf 4.1 to 4.2 

    is having "Telerik.Sitefinity.Silverlight.xap" file which is of size 445 KB and the same file is of 441 KB in another machine

    where upload control is not working after upgrade.We got this issue resolved by taking the contents of ClientBin folder of a

    project where the image upload works and placing them in our ClientBin folder.

    This issue could possibly be caused by those files not being updated with upgrade.

     

    Saurabh V

  11. Jason
    Jason avatar
    7 posts
    Registered:
    25 Jul 2008
    19 Sep 2011
    Link to this post
    Has anyone escalated this issue?  I haven't seen any comment from Telerik in this thread - what's the appropriate way to escalate?
  12. Victor Velev
    Victor Velev avatar
    1345 posts
    Registered:
    06 Jul 2015
    19 Sep 2011
    Link to this post
    Hello,

    The problem is most probably caused by corrupted upgrade process, because the issue may appear only if the contents of the ClientBin contains different versions of the .xap files as expected. For all those who experience issues while uploading documents/images/videos/files ( after upgrading ), please consult the following article.

    Regards,
    Victor Velev
    the Telerik team
    Do you want to have your say in the Sitefinity development roadmap? Do you want to know when a feature you requested is added or when a bug fixed? Explore the Telerik Public Issue Tracking system and vote to affect the priority of the items
12 posts, 0 answered