+1-888-365-2779
Try Now
More in this section

Forums / Bugs & Issues / Ambiguous reference after upgrade to 6.2

Ambiguous reference after upgrade to 6.2

8 posts, 0 answered
  1. Daniel Plomp
    Daniel Plomp avatar
    952 posts
    Registered:
    18 Feb 2004
    19 Oct 2013
    Link to this post
    Hi,

    After upgrading one of my projects to 6.2, I have an error regarding an ambiguous reference. In one of my helper classes I use the Serializable attribute from System.dll which conflicts with the same name inside the Telerik.Everlive.Sdk.dll.

    Is this reproducible?

    Kind regards,
    Daniel
  2. Kaloyan
    Kaloyan avatar
    272 posts
    Registered:
    08 Dec 2016
    23 Oct 2013
    Link to this post
    Hi Daniel,

    I am not having this problem on my upgraded to version 6.2 project. Could you please try the following solution:

    1.In SitefinityWebApp, right click on Telerik.Everlive.SDK and click Properties;
    2.Set the Aliases property to "ExternalLib";
    3.Build the project again;

    Regards,
    Kaloyan
    Telerik
    Do you want to have your say in the Sitefinity development roadmap? Do you want to know when a feature you requested is added or when a bug fixed? Explore the Telerik Public Issue Tracking system and vote to affect the priority of the items
  3. Daniel Plomp
    Daniel Plomp avatar
    952 posts
    Registered:
    18 Feb 2004
    23 Oct 2013 in reply to Kaloyan
    Link to this post
    Hi Kaloyan,

    Thanks for the reply.
    I executed the steps you described and that let me build the project successfully.
    So, problem solved, although I'm not sure what I've solved ;)

    Kind regards,
    Daniel
  4. OregonTech
    OregonTech avatar
    9 posts
    Registered:
    08 Jan 2009
    24 Oct 2013
    Link to this post
    I ran into the same problem.  Kaloyan's solution solved it for me also.
  5. H.J.E. Coppen
    H.J.E. Coppen avatar
    13 posts
    Registered:
    25 Nov 2008
    31 Oct 2013
    Link to this post
    Hi,

    I am not working with the SitefinityWebApp. How can I solve this problem. I get this error when the site startup.

    Regards,
    Hugo Coppen.
  6. Kaloyan
    Kaloyan avatar
    272 posts
    Registered:
    08 Dec 2016
    04 Nov 2013
    Link to this post
    Hello Hugo,

    Could you please clarify what you mean by "I am not working with the SitefinityWebApp" ? You have to expand your solution, then locate Telerik.Everlive.SDK dll and the follow the provided steps in my previous reply.

    Regards,
    Kaloyan
    Telerik
    Do you want to have your say in the Sitefinity development roadmap? Do you want to know when a feature you requested is added or when a bug fixed? Explore the Telerik Public Issue Tracking system and vote to affect the priority of the items
  7. H.J.E. Coppen
    H.J.E. Coppen avatar
    13 posts
    Registered:
    25 Nov 2008
    04 Nov 2013 in reply to Kaloyan
    Link to this post
    What I mean is that we are not using Sitefinity as a Web Application project but as a Web Site project in Visual Studio. Have a look at the attached file. In a Web Site project I can not to set a Aliases when I select the dll in the bin directory.
  8. Kaloyan
    Kaloyan avatar
    272 posts
    Registered:
    08 Dec 2016
    07 Nov 2013
    Link to this post
    Hi Hugo,

    We have provided an answer in your support ticket.

    Regards,
    Kaloyan
    Telerik
    Do you want to have your say in the Sitefinity development roadmap? Do you want to know when a feature you requested is added or when a bug fixed? Explore the Telerik Public Issue Tracking system and vote to affect the priority of the items
8 posts, 0 answered