1-888-365-2779
+1-888-365-2779
Try Now
More in this section

Forums / Bugs & Issues / Anayltics page is Blank

Anayltics page is Blank

8 posts, 0 answered
  1. David
    David avatar
    9 posts
    Registered:
    09 Jul 2008
    23 Feb 2011
    Link to this post
    Hello,
    I'm trying to get the Analytics setup. I added the script to two of may template pages and added the script code from my google account - the same code works fine in my existing 3.7 version site. When i navigate to the Analytics page, there is nothing but a blank white section in the middle - the nav is at the top and the "Analytics" title is there and the footer - but absolutely nothing in the middle and no visible errors.

    Any suggestions on what's going on?
  2. Steve
    Steve avatar
    3037 posts
    Registered:
    03 Dec 2008
    23 Feb 2011
    Link to this post
    1) Latest version of silverlight is installed?
    2) Did you ever go there for the first time and it prompted to enter credentials?...and NOW it's blank, or just always showed nothing.
    3) Which browser?...Firefox?
  3. David
    David avatar
    9 posts
    Registered:
    09 Jul 2008
    23 Feb 2011
    Link to this post
    1) Silverlight: I'll check that - perhaps not
    2) I NEVER recieved credentials prompt. At first it was showing an error when i went to the analytics - sorry i don't remember what the error was, so i did some reseach and decided it might be because i didn't have any of the analytics scripts widgets actually in the new site. So i added them to two template pages, along witht he script from google, and then the analytics pages was simply blank - with no errors, but no controls either.
    3) Happens in both IE 8 and Firefox 3.6
  4. David
    David avatar
    9 posts
    Registered:
    09 Jul 2008
    23 Feb 2011
    Link to this post
    1) I added silverlight to the server the site is running on. Silverlight is also on my laptop where i am viewing the analytics page.

    Now, in IE i get a script error notification that reads:

    Webpage error details

    User Agent: Mozilla/4.0 (compatible; MSIE 8.0; Windows NT 6.1; WOW64; Trident/4.0; SLCC2; .NET CLR 2.0.50727; .NET CLR 3.5.30729; .NET CLR 3.0.30729; Media Center PC 6.0; MDDR; .NET4.0C; InfoPath.3; .NET4.0E)
    Timestamp: Wed, 23 Feb 2011 14:09:12 UTC

    Message: Unhandled Error in Silverlight Application
    Code: 2104   
    Category: InitializeError      
    Message: 2104 An error has occurred.    

    Line: 175
    Char: 9
    Code: 0
    URI: http://xxxxxxxxx.com/Sitefinity/Analytics

     

  5. Ivan Dimitrov
    Ivan Dimitrov avatar
    16072 posts
    Registered:
    12 Sep 2017
    23 Feb 2011
    Link to this post
    Hello Todd,

    Please make sure that you have configured IIS to support Silverlight . The error you get means that the xap cannot be read. The xap is located under http://host/ClientBin/Telerik.Sitefinity.Silverlight.xap

    You can take a look at this blog post.

    Kind regards,
    Ivan Dimitrov
    the Telerik team
  6. David
    David avatar
    9 posts
    Registered:
    09 Jul 2008
    23 Feb 2011
    Link to this post
    Thanks Ivan - that was the problem, IIS was not setup with the Silverlight extensions.
    Thanks!
    Todd
  7. Brad Nickel
    Brad Nickel avatar
    1 posts
    Registered:
    27 Jul 2009
    01 Sep 2011
    Link to this post
    I am having the same problem, but the Analytics module was working fine prior to our upgrade to 4.2 this week. Any idea what may be the cause? 
  8. Carlos Redondo
    Carlos Redondo avatar
    21 posts
    Registered:
    09 Jan 2009
    02 Oct 2011
    Link to this post
    Hi All,
    I had the same "Blank Page" issue with Silverlight not only for Google Analytic Settings but as well on Content Video upload area.  Web site is hosted on a Win2008 IIS 7, and Silverlight settings are configured out-of-the-box, any way I double checked settings just to be sure, but all looked fine.  Then I turned out my attention to the application pool, and that where tricky was... It was configured as "Classic" for Managed Pipeline Mode, and I changed it to "Integrated", and that worked for me.

    Now I'll like to understand why that make the trick!

8 posts, 0 answered