+1-888-365-2779
Try Now
More in this section

Forums / Bugs & Issues / Blogs index

Blogs index

10 posts, 0 answered
  1. Annie
    Annie avatar
    123 posts
    Registered:
    08 Apr 2009
    09 Sep 2011
    Link to this post
    Hi

    We added a search for blogs only, but the search does not return the correct urls for the individual blog posts. Is there a fix for this issue?

    Thanks,
    Annie
  2. Svetoslav Petsov
    Svetoslav Petsov avatar
    456 posts
    Registered:
    24 Sep 2012
    14 Sep 2011
    Link to this post
    Hi Annie,

     Can you please provide some more info on your issue?
    Is this happening with other content items (for example news), as well?
    What exactly do you mean by "the correct urls"? Where do the "incorrect urls" redirect to?
    Did this happen after update? Is your current version 4.2.1650?

    Regards,
    Svetoslav Petsov
    the Telerik team
    Do you want to have your say in the Sitefinity development roadmap? Do you want to know when a feature you requested is added or when a bug fixed? Explore the Telerik Public Issue Tracking system and vote to affect the priority of the items
  3. Andrew
    Andrew avatar
    8 posts
    Registered:
    27 Apr 2016
    27 Apr
    Link to this post

    I'm having the exact same problem for blog posts, news items and events across two sites. Example: The search result for a blog post provides this URL:

     

    http://intranet.crh.org/our-crh/crh-news/crh-news/2016/04/01/policy-change---removable-media-(usb-devices)

    However, the correct URL is:

    http://intranet.crh.org/our-crh/crh-news/news-article/crh-news/2016/04/01/policy-change---removable-media-(usb-devices)

    The blog posts are set up to open in a new page called News Article.

    Is there something I can add in the search index for this to return the correct result? Or is there a tweak I can do to the blog widget on the detail page?

    I'm using Sitefinity 8.1.

  4. Dimitri Cools
    Dimitri Cools avatar
    80 posts
    Registered:
    29 Sep 2016
    28 Apr
    Link to this post
    Hello,

    I cannot reproduce the behavior you are describing.
    Does your "News Article" page contains the Blog posts widget?  

    Do the links resolve correctlty from a page that has the Blog posts widget? 

    Here is a screenshot of my result:
    http://screencast.com/t/QinG3iVYzYqS

    Also, in the Sitefinity backend you can check which are the pages which display content items of a particular type and order them by priority.
    The one with the highest priority is used in the search results, the sitemap and also when previewing the item. This is considered the default location of the item.

    Please set this "News Article" page to be with priority 1 under Content -> Blogs -> your blog -> Pages where BlogPost items are published. 


    Regards,
    Dimitri Cools
    Telerik
     
    Do you want to have your say in the Sitefinity development roadmap? Do you want to know when a feature you requested is added or when a bug fixed? Explore the Telerik Sitefinity CMS Ideas&Feedback Portal and vote to affect the priority of the items
     
  5. Andrew
    Andrew avatar
    8 posts
    Registered:
    27 Apr 2016
    28 Apr
    Link to this post

    Hi Dimitri, thanks for your reply.

    Yes, the "News Article" page has the blog posts widget on it. Also, on the main news page, "CRH News," the blog posts widget points to "News Article" in the "Single Item Settings > Selected existing page."

    I examined the blog post list with Firebug as you did in your test, but on the main CRH News page, the link is fine. The search results, however, list the bad URL.

    HOWEVER, something I noticed: When I had the CRH News page opened in the page edit module, I previewed the page by clicking the button on the top left. When I did this, the links in the blog list were all "bad." showing the same result as the links provided in the search. So I went back to the blog posts widget on that page, checked "Single Item Settings," and it had reverted to "Open single item in... Auto-generated page." That is NOT the setting I had it on. After changing the widget back to the correct setting, the search results were still incorrectly displaying the bad URL, even after re-indexing.

    So, it looks like something is causing the widget to display the blog content as if it were supposed to open in an auto-generated page instead of . Any ideas? 

    Here is another oddity. I went into "Pages where BlogPost items are published" and moved the "News Article" page to #1 priority. I went back and checked 15 minutes later and the "News Article" page had completely vanished from that list, and now "CRH News" is listed as #1 priority. 

  6. Andrew
    Andrew avatar
    8 posts
    Registered:
    27 Apr 2016
    28 Apr
    Link to this post
    *instead of an existing page.
  7. Andrew
    Andrew avatar
    8 posts
    Registered:
    27 Apr 2016
    28 Apr
    Link to this post
    If it helps to know, I have a few different blogs on the site, one of them being a library blog. So, I just went in to that blog and moved its page up to the top priority, not realizing that would change the priority for the news blog. I went back to check the news blog settings, and "News Article" had reappeared in "Pages where BlogPost items are published," and it was displayed at the bottom with the lowest priority.
  8. Andrew
    Andrew avatar
    8 posts
    Registered:
    27 Apr 2016
    28 Apr
    Link to this post
    This is likely part of the issue here (see attached). If I go to edit a blog post and click on More options > Allow multiple URLs for this item... the default URL listed is not correct. When creating a new blog, there doesn't seem to be a way to "tell" the blog that it's not going to display posts on an auto-generated page, correct? This seems like a bug.
  9. Dimitri Cools
    Dimitri Cools avatar
    80 posts
    Registered:
    29 Sep 2016
    29 Apr
    Link to this post
    Hi,

    The location where one specifies which page from the existing pages will display the blog post when clicked is done in the Blog posts widget, not the Blog itelf.
    (cfr. Blog posts widget - http://docs.sitefinity.com/blog-posts-widget)

    Also a bit more technically, by default Sitefinity uses the IContentLocatableView interface implemented on the out of the box content widgets in order to track their locations on different pages. This interface powers the Preview functionality from the content modules as well as the Search indexing and the correct resolving of the links in it. 
    When you click on the Preview button of a built-in content item, Sitefinity searches the page where you have placed the module's widget and then renders the item on its details page.
    More on Locations of content items:
    http://docs.sitefinity.com/for-developers-locations-of-content-items

    This said, I did notice that you mentioned you are only using version 8.1.
    There was a bug which caused the urls not to render properly, which was fixed in Sitefinity Internal Build 8.2.5905.0.
    http://feedback.telerik.com/Project/153/Feedback/Details/135727-search-results-doesnt-render-properly-the-blog-posts-url-when-they-are-in-separa

    Which could explain why I could not reproduce this behavior.


    I therefor suggest to upgrade this version or higher to overcome this issue.

    I hope the above information helps. 
     


    Regards,
    Dimitri Cools
    Telerik
     
    Do you want to have your say in the Sitefinity development roadmap? Do you want to know when a feature you requested is added or when a bug fixed? Explore the Telerik Sitefinity CMS Ideas&Feedback Portal and vote to affect the priority of the items
     
  10. Andrew
    Andrew avatar
    8 posts
    Registered:
    27 Apr 2016
    29 Apr
    Link to this post
    Thanks for clearing that up Dimitri. That sounds exactly like the problem I'm having. I'll see if our development partner can update our version.
10 posts, 0 answered