+1-888-365-2779
Try Now
More in this section

Forums / Bugs & Issues / Bug with layout element's classes & labels

Bug with layout element's classes & labels

1 posts, 0 answered
  1. Michelle
    Michelle avatar
    9 posts
    Registered:
    17 Apr 2014
    12 Aug 2014
    Link to this post

    Using Sitefinity 7.0. I'm running into a problem with the layout editor within the master page that I created. I want to split up each placeholder using the layout elements. When I drag, for example, a 33% 33% 33% layout element into my placeholder, everything floats beside each other like normal. When I go to edit the Classes & Labels for that layout element, suddenly each column decides to stack on top of each other, rather than float next to each other like I wanted it to.
    I took screenshots to walk you through my process:

    First Step: Uploaded my master page template. It looked like this:
    http://i.imgur.com/71CIGy7.jpg

    Second Step: I split up the top bar using layout elements, so that it's split into 67% and 33%.
    http://i.imgur.com/cqRNMBI.jpg

    Third Step: I want to change the classes & labels for the layout element I just applied. As you can see, they're still floating side by side:
    http://i.imgur.com/bBCKETK.jpg

    Fourth Step: Changed the first column class to 'hello'. Immediately the second column gets pushed down a line, so they are no longer floating next to each other:
    http://i.imgur.com/bIZicDs.jpg

    Fifth Step: I changed the class name of the second column to 'sitefinity'. This pushed the second column to  below the first one, and floated to the left.
    http://i.imgur.com/l1OlTxy.jpg

    Sixth Step: Try this with a bunch of layout elements. Everytime I change a class and/or label name, they stack on top of each other:
    http://i.imgur.com/b7wHiVy.jpg

    Seventh Step: I decide to test the template, to see whether they just stack within my template, or if they stack on the page as well. I renamed the top template element columns, so they stacked on each other. Below that I decided not to name the columns, so they're all still floating nicely next to each other:
    http://i.imgur.com/VQyqJmG.jpg

    Eighth Step: I recreated the step above, and decided to add pictures. The top layout element is split into three columns, 33%, 34% (slightly annoying this isn't 33%) and 33%. These columns I did NOT change the names to. They're still floating next to each other. Below that is the layout element that I DID change the class names to. You can see that they're stacked on top of each other.
    http://i.imgur.com/rOXrgwl.jpg

    Ninth Step: And finally, when I view my page, it looks exactly the same as in my template where the labeled columns are stacked, and the unlabeled columns are floated next to each other like I want:
    http://i.imgur.com/5gVNdvX.jpg



    So is this a bug?

    ALSO: I wasn't able to recreate this, as it's random, so I couldn't get a screenshot. Sometimes when I click 'edit' on a layout element that is specifically set to 33% 33% 33%, it automatically changes my percents to something random (usually 100% 0% 0%) even though I had specifically dragged a 3 column 33% divider into there. All I do is click 'edit' and it changes. I tried to get sitefinity to do it again so I could show you, but I can't recreate it.

1 posts, 0 answered