+1-888-365-2779
Try Now
More in this section

Forums / Bugs & Issues / Cannot create a user nor modify any user in Sitefinity 5.4

Cannot create a user nor modify any user in Sitefinity 5.4

7 posts, 0 answered
  1. Ernest
    Ernest avatar
    4 posts
    Registered:
    24 Mar 2015
    24 Mar 2015
    Link to this post
    When I go to Administration (drop-down menu appears) and choose and go to the 'users' page (where all users are listed) and try to either modify or create a new user, I get the following error (How do I fix this?? What can I do? I cannot create nor modify any users! :-(  ):

    Specified dynamic type 'Telerik.Sitefinity.Security.Model.SitefinityProfile' was not found.Description: An unhandled exception occurred during the execution of the current web request. Please review the stack trace for more information about the error and where it originated in the code. 

    Exception Details: System.InvalidOperationException: Specified dynamic type 'Telerik.Sitefinity.Security.Model.SitefinityProfile' was not found.

    Source Error: 

    An unhandled exception was generated during the execution of the current web request. Information regarding the origin and location of the exception can be identified using the exception stack trace below.
    Stack Trace: 

    [InvalidOperationException: Specified dynamic type 'Telerik.Sitefinity.Security.Model.SitefinityProfile' was not found.]
    Telerik.Sitefinity.Fluent.DynamicData.DynamicTypeDescriptionFacade.LoadDynamicTypeDescription(Type dynamicType) +98
    Telerik.Sitefinity.Modules.UserProfiles.Web.UI.UserProfilesControl.InitializeControls(GenericContainer dialogContainer) +483
    Telerik.Sitefinity.Web.UI.SimpleView.CreateChildControls() +52
    System.Web.UI.Control.EnsureChildControls() +83
    System.Web.UI.Control.PreRenderRecursiveInternal() +42
    System.Web.UI.Control.PreRenderRecursiveInternal() +155
    System.Web.UI.Control.PreRenderRecursiveInternal() +155
    System.Web.UI.Control.PreRenderRecursiveInternal() +155
    System.Web.UI.Control.PreRenderRecursiveInternal() +155
    System.Web.UI.Control.PreRenderRecursiveInternal() +155
    System.Web.UI.Control.PreRenderRecursiveInternal() +155
    System.Web.UI.Page.ProcessRequestMain(Boolean includeStagesBeforeAsyncPoint, Boolean includeStagesAfterAsyncPoint) +974
  2. Stefani Tacheva
    Stefani Tacheva avatar
    718 posts
    Registered:
    06 Dec 2016
    09 Apr 2015
    Link to this post
    Hi,

    Would it be possible for you to go to Administration -> Advanced Settings ->  UserProfiles -> ProfileTypesSettings and check whether you have SitefinityProfile added. If not please try to recreate it by clicking on the Create new button and setting the values in the field as following:

    Name: Telerik.Sitefinity.Security.Model.SitefinityProfile
    ProfileProviderCaption: OpenAccessProfileProvider
    UseAllMembershipProvidersCaption: True

    Save the changes and restart the application.

    If the problem still persist please inform us what changes have been done before you start encountering this problem.

    Regards,
    Stefani Tacheva
    Telerik
     
    Do you want to have your say in the Sitefinity development roadmap? Do you want to know when a feature you requested is added or when a bug fixed? Explore the Telerik Sitefinity CMS Ideas&Feedback Portal and vote to affect the priority of the items
     
  3. Ernest
    Ernest avatar
    4 posts
    Registered:
    24 Mar 2015
    09 Apr 2015 in reply to Stefani Tacheva
    Link to this post

    Stefani, 

         Thanks for your reply.  Well, I would just like to reiterate that we are using Sitefinity version 5.4.  I'm mentioning this because your instructions (Administration->Advanced Settings->UserProfiles->ProfileTypesSettings) do not seem to 100% coincide with what I had to do to get to where you're directing me (I had to go to Administration->Settings->Advanced->UserProfiles->ProfileTypesSettings)  See attached pictures/files.

    In any case, I went there and we do already have Telerik.Sitefinity.Security.Model.SitefinityProfile under ProfileTypesSettings.  Is there anything else we can do to solve this problem? If I were to delete this file (Telerik.Sitefinity.Security.Model.SitefinityProfile) and REcreate it, would I lose credentials of all users, including mine (admin)? If so, how would I log back in?

    Regarding your question about what we may have done before before we started encountering the problem... nothing drastic that we can remember. We were simply using Sitefinity the normal way, but when we wanted to create an additional user, we could not do so.

    Your prompt attention will be appreciated as we have some users who need their own username and credentials.

    Thank you.

  4. Sabrie Nedzhip
    Sabrie Nedzhip avatar
    534 posts
    Registered:
    09 Dec 2016
    14 Apr 2015
    Link to this post
    Hello Ernest,

    The issue you are experiencing really strange. As I can see from the screenshots you have a SitefinityProfile under the ProfileTypesSettings and you should not receive this error message.

    In order to make sure that the Sitefinity profile is configured properly, can you please click on the Telerik.Sitefinity.Security.Model.SitefinityProfile under the ProfileTypesSettings and let me know if the fields contain the below information:

    Name: Telerik.Sitefinity.Security.Model.SitefinityProfile
    ProfileProviderCaption: OpenAccessProfileProvider
    UseAllMembershipProvidersCaption: True

    Please refer to the attached screenshot for your reference.

    In addition to this, can you please let me know if this is a project which has been migrated from Sitefinity 3.7? If so, can you please go to Administration -> Modules, please find the Migration tool module and if it not enabled please install it from its Actions link. Then please restart the application and test the behavior again. We have a known issue that if the Migration tool module is disabled in a migrated project issues may appear when creating and deleting users.

    This is because when you migrate your site the Migration module creates a new provider - the OpenAccessMembership37Provider - this provider will store the migrated users form your Sitefintiy 3.7 site. This provider is configured in the Migration Module (i.e. it's not present by default), and its settings are read form the migration module's configuration. When you disable the Migration module, these configurations are no longer loaded, and thus might be the reason for the issues you are experiencing.

    Regards,
    Sabrie Nedzhip
    Telerik
     
    Do you want to have your say in the Sitefinity development roadmap? Do you want to know when a feature you requested is added or when a bug fixed? Explore the Telerik Sitefinity CMS Ideas&Feedback Portal and vote to affect the priority of the items
     
  5. Ernest
    Ernest avatar
    4 posts
    Registered:
    24 Mar 2015
    16 Apr 2015 in reply to Sabrie Nedzhip
    Link to this post

    Sabrie, 

       No, this project has not been migraded.  The error still persists despite having done everything you instructed. Sadly.

    With respect to the Sitefinity Profile being configured properly, well, all the fields in the Telerik.Sitefinity.Security.Model.SitefinityProfile under ProfileTypesSettings are exactly the same as what you described (see attached file)

    Thank you and please let me know anything else to try.  We are in severe need to get this fixed.

    Regards, 

    Ernest

      

  6. Ernest
    Ernest avatar
    4 posts
    Registered:
    24 Mar 2015
    15 May 2015
    Link to this post

    Sabrie & Stefani, 

     

           I am still waiting for a reply to my problem.  Or is there any way to reinstall everything from scratch!? Please help.  It has been almost 2 months since I last wrote my reply to both of you.  PLEASE HELP! We need to get this working ASAP!

  7. Sabrie Nedzhip
    Sabrie Nedzhip avatar
    534 posts
    Registered:
    09 Dec 2016
    19 May 2015
    Link to this post
    Hello Ernest,

    It is really hard to say what is causing the issue on your side. The issue occurs in the InitializeControls() method in the UserProfilesControl.cs class where Sitefinity tries to get the SitefinityProfile type and is not able to find it.

    In order to research the issue in more depth we need to debug the project against the source code. What I can suggest is that you open a support ticket so that we can further help you with this issue.

    Regards,
    Sabrie Nedzhip
    Telerik
     
    Do you want to have your say in the Sitefinity development roadmap? Do you want to know when a feature you requested is added or when a bug fixed? Explore the Telerik Sitefinity CMS Ideas&Feedback Portal and vote to affect the priority of the items
     
7 posts, 0 answered