1-888-365-2779
+1-888-365-2779
Try Now
More in this section

Forums / Bugs & Issues / Cell padding issue with items created in News Content

Cell padding issue with items created in News Content

4 posts, 0 answered
  1. Don
    Don avatar
    2 posts
    Registered:
    12 May 2011
    12 May 2011
    Link to this post
    Hi to all,

    I am having an issue that shows a large behaviour distinction between content loaded from a page or a news item

    If a client creates content in a Word document that includes a table containing numerical values, it pastes fine into the content block. The cell padding almost perfectly mimics the content pasted from the Word document. Word 2010 is being used (docx). This produces the desired result from the client's perspective.

    However, this content is invariably a news release and should be more correctly entered into a content box from the "Content > News" menu. If this is done, a completey different result occurs. Instead of the table displaying almost indistinguishable from the Word document it has ballooned. I have attached two screen shots.

    The use of tables in news releases is a dominant factor for our client base and a solution must be found.

    Any assistance would be appreciated. Sitefinity 4.0 is in use for this event.

    Thanks in advance.
  2. Katia
    Katia avatar
    194 posts
    Registered:
    01 Jul 2016
    16 May 2011
    Link to this post
    Hello Don,

    The control used in Content block widget in Page editor and the one in News module is the same and it also has the same configurations. I have tried to reproduce the issue to no avail. I have created a table in Word 2007 (after that tried with Word 2010 as well), aligned the text in the cells to top center, after that create a news item and pasted the table there. Then created a page, dropped a Content block widget and pasted the table again. After that dropped News widget. Published the page and opened in another tab. You can see the result in the screenshot I have attached.

    I can think of two reason which might cause this behavior. First, the copied tables (source tables) are different therefore the produced HTML is different. Second, Content block and News widgets are dropped to different places on the page so the applied CSS is different.

    I tried the url from the screenshots (http://kivalliq.ellevate.net/) but it's not opening. Can you provide a public URL where I can see the HTML and CSS of the tables?

    Regards,
    Katia
    the Telerik team
    Do you want to have your say in the Sitefinity development roadmap? Do you want to know when a feature you requested is added or when a bug fixed? Explore the Telerik Public Issue Tracking system and vote to affect the priority of the items
  3. Don
    Don avatar
    2 posts
    Registered:
    12 May 2011
    16 May 2011
    Link to this post
    Hi Katia,

    Thank you for responding. 

    Perhaps the best approach (since I am not allowed to upload a Word docx) is to provide the direct link to the client website showing the news release that is producing this failure.

    Please go to this page: http://www.kivalliqenergy.com/news/index.php?&content_id=87
    Then copy the entire news release into a Word docx. 

    When I did this and then attempt to create a new page - I can paste from the created Word document into a content block and it will preview correctly.

    However, when I attempt to create a news item and follow the same process (with the exception that the news release title line is pasted into the Title line of the news item content field) the table balloons up to may times its original size.

    If I can be allowed to send the Word docx to you this will allow you to skip the first step.

    Thanks,

    Don

    Incidentally, the client usually creates these news releases in a Word docx initially.



  4. Katia
    Katia avatar
    194 posts
    Registered:
    01 Jul 2016
    17 May 2011
    Link to this post
    Hi Don,

    I followed your instructions but still cannot reproduce the issue. See the three screenshots I have attached.

    Anyways, can you send the problematic pages saved as HTML. When saving them choose "Web page, complete" as "Save as type". Send the .htm(l) file and the corresponding folder (see Save-as-web-page.jpg).

    Best wishes,
    Katia
    the Telerik team
    Do you want to have your say in the Sitefinity development roadmap? Do you want to know when a feature you requested is added or when a bug fixed? Explore the Telerik Public Issue Tracking system and vote to affect the priority of the items
4 posts, 0 answered