1-888-365-2779
+1-888-365-2779
Try Now
More in this section

Forums / Bugs & Issues / Content PlaceHolder Not Displaying to Public User?

Content PlaceHolder Not Displaying to Public User?

4 posts, 0 answered
  1. Matthew
    Matthew avatar
    33 posts
    Registered:
    15 Dec 2008
    18 Feb 2011
    Link to this post
    For some reason the content I've added to my master page place holders doesn't display to public users.

    I have 3 Content Place Holders each containing a "Content Block" widget, each with a few lines of text. These display when I am authenticated to the SI admin, but not to the public. I poked around to see if there was some crazy page permission setup in there, but didn't see a thing. 

    I am using a custom master page, nothing different from the way I did things in SI3. I reverted once during content population and from what I've read on a few related forum posts, this may be the issue. 

    Any help would be great. Obviously, without the content displaying to the public is absolutely pointless.

    Thanks,
    Matt
  2. Ivan Dimitrov
    Ivan Dimitrov avatar
    16072 posts
    Registered:
    16 Jun 2017
    18 Feb 2011
    Link to this post
    Hi Matthew,

    1. Please check the permissions you have set over the widgets and layout elements in your master page and your page.

    2. Have you reverted the template to another version, because there is a bug if you do this. Can you replicate the issue with a new template

    - create a new template
    - drop a control on it
    - save the template
    - create a new page and set the newly created tempalte

    All the best,
    Ivan Dimitrov
    the Telerik team
  3. Matthew
    Matthew avatar
    33 posts
    Registered:
    15 Dec 2008
    18 Feb 2011
    Link to this post
    I created a new master page, unassigned the old master page and assigned the new master page. This seemed to work, content is now displaying to the public. Is there a way to disable reverts globally? 

    This seems like a bubble gum fix for now. When can we expect a solid fix for this? I'm hesitant to continue developing this application in SI4 mainly because if our end client reverts something as I did, the same thing can happen causing a mess on their production site.

    Thanks,
    Matt
  4. Ivan Dimitrov
    Ivan Dimitrov avatar
    16072 posts
    Registered:
    16 Jun 2017
    21 Feb 2011
    Link to this post
    Hi Matthew,

    Page templates do not support versioning and the revert button will be removed from the UI for the SP1.

    Regards,
    Ivan Dimitrov
    the Telerik team
4 posts, 0 answered