Try Now
More in this section

Forums / Bugs & Issues / Could not deserialize service response, because it was empty or not valid JSON

Could not deserialize service response, because it was empty or not valid JSON

6 posts, 2 answered
  1. John
    John avatar
    3 posts
    14 Sep 2011
    08 May 2013
    Link to this post
    We have recently encountered the following error in the admin of one of our sites
    "Could not deserialize service response, because it was empty or not valid JSON"
    We receive this error in multiple spots in the admin. Mostly when in the pages section we a user clicks to expand the list of child pages or when trying to add a new page.
    I have seen other posts on this from a couple years ago but resolutions.
    The site was working fine until about a week ago and then this issue appeared out of nowhere
    We have 2 other Sitefinity sites on this server and those are NOT having this issue.
    The front of the site is working fine but I did notice that we are now also having issues saving some settings in the admin that started around the same time this error surfaced.
    an example of the other error is
    administration > comments > check "Comments have to be approved before appearing on the site"  > click save.
    I get a "Changes are successfully saved." message but when I come back the page "Comments have to be approved before appearing on the site"  box is unchecked again.

    There is nothing in the event viewer or cms error log
    I also tried the logging settings found here
    but it did not produce any error log files
    I have double checked the permissions and IIS settings
    and like I said we have 2 other sitefinity sites on the server that are running fine and this site was fine until about a week ago as well

    The site is running on 
    server 2008 
    iis 7.0
    cms version: 4.2.1650.0

  2. Stefani Tacheva
    Stefani Tacheva avatar
    718 posts
    26 Oct 2016
    09 May 2013
    Link to this post

    Based on the provided information it seems that the error you are getting is most likely coming from your server configuration. I would like to note that the following article can be very useful when deploying a Sitefinity website on IIS:


    1. Verify that the Application Pool Identity is NetworkService.
    2. Check the Authentication section of your website in IIS. Verify that only Anonymous authentication is enabled and the anonymous user identity is the application pool identity.
    3. Assign proper permissions over the App_Data folder for the NetworkService account

    Aside from the issue I want to note that your current version of Sitefinity - 4.2.1650.0 is very old and I would suggest you to consider upgrading the project as we have included numerous bug fixes, new features and optimizations in each major version of Sitefinity after 4.2.1650.0 which will improve significantly your Sitefinity experience.More information about the upgrading process could be found in our Sitefinity documentation.

    There is a similar case discussed in the following thread:


    In all cases the reported problem was related to the hosting environment ( all users encountering similar symptoms when browsing their projects ) which was always a shared hosting environment with limited resources, which were in conflict with Sitefinity. For example if there is not enough memory for the CMS or there is some restriction ( permission ) which was preventing the system to pass the requests.

    Stefani Tacheva
    the Telerik team
    Do you want to have your say in the Sitefinity development roadmap? Do you want to know when a feature you requested is added or when a bug fixed? Explore the Telerik Public Issue Tracking system and vote to affect the priority of the items
  3. John
    John avatar
    3 posts
    14 Sep 2011
    09 May 2013 in reply to Stefani Tacheva
    Link to this post
    Thanks for your reply but nothing below helps.
    Like I said in my original post we have two other sitefinity sites on this server that are running fine ( one is v5 and one is v4)
    I have verified that the APP pool is using Networkservice
    the authentication was set to allow Anonymous and Forms ( which was that way per the Sitefinity install instructions and the other two sites have the same settings) but I removed Forms per your instructions below, which did not help
    and the proper permissions are set on the App_Data folder

    The link to the thread also doesn't have a solid resolution, the final post is a person saying he needed to update his Java runtime, which I did, but again there are two other sitefinity sites that are running fine on this server.
    this site has been running for a long time without issue, it is not a new site, and then about a week ago this error started, but it's not affecting the other two sites, just this one.
    I'm not saying it isn't a permission or setting issue but we have full control over the server and if it was a server issue you would think it would affect the other two sites as well so I have been focusing only on the settings for this site which all appear to be correct. Are there any other settings that could have caused this?
    Are there any other settings that we can test?
    if I recall we had run into an issue a year ago so wth another sitefinity site ( on a different server) and someone had us set/change the service path somewhere in the advanced settings, I don't recall the reason for this but it solved that problem, could that be a similar issue to this?
  4. John
    John avatar
    3 posts
    14 Sep 2011
    09 May 2013
    Link to this post
    I have resolved this issue.
    If anyone is interested, there was a URL rewriting conflict between one of our own rewrite rules in the config file and some of the service URL's from sitefinity.
    It was hard to detect because the conflict only matched certain service URL's so it wasn't affecting all area's of the admin. and the area's in the admin affected by this were not reporting the error properly. for example when updating the settings for comments we were getting a "Changes are successfully saved." message, with no settings actually being saved, instead we should have received an error when sitefinity could not reach the service URL.
  5. cli
    cli avatar
    50 posts
    21 May 2007
    13 Mar 2015
    Link to this post
    We had the same error.  Turned out we were running out of free ram on the server.  Restarting and freeing up ram fixed it for us.
  6. Sailen
    Sailen avatar
    1 posts
    13 May 2016
    13 May
    Link to this post

    this might be helpful for someone running IIS8.0 on Windows 2012 R2

    All features should be installed as mentioned here http://docs.sitefinity.com/configure-the-iis-to-host-sitefinity-projects (under section: Microsoft® Windows Server 2012 and Windows 8.0 with IIS 8.0)

    Then make sure: On IIS, your site >> Authentication >> Enable both Anonymous & Form Authentication

6 posts, 2 answered