+1-888-365-2779
Try Now
More in this section

Forums / Bugs & Issues / Could not load file or assembly Telerik.Web.UI, Version=2010.2.826.40, while Migrating 3.7 site to 5.2

Could not load file or assembly Telerik.Web.UI, Version=2010.2.826.40, while Migrating 3.7 site to 5.2

5 posts, 0 answered
  1. Amit
    Amit avatar
    43 posts
    Registered:
    15 Nov 2012
    21 Nov 2012
    Link to this post
    Hi,

    I have a website successfully running in 3.7 sp4 (on IIS7)
    and I am trying to migrate it as per the documention avilable on
    Sitefinity. I used Automatic method & that was successful, then I
    used administrator panel of 5.2 website (on IIS7) , gave the Database
    crendentials (same of 3.7 DB credentials), And i Next click I got the
    following exception:

    Server Error in '/TestWebsiteNew' Application.
    Could not load file or assembly 'Telerik.Web.UI, Version=2010.2.826.40, Culture=neutral, PublicKeyToken=121fae78165ba3d4' or one of its dependencies. The located assembly's manifest definition does not match the assembly reference. (Exception from HRESULT: 0x80131040)
    Description: An unhandled exception occurred during the execution of the current web request. Please review the stack trace for more information about the error and where it originated in the code.
      
    Exception Details: System.IO.FileLoadException: Could not load file or assembly 'Telerik.Web.UI, Version=2010.2.826.40, Culture=neutral, PublicKeyToken=121fae78165ba3d4' or one of its dependencies. The located assembly's manifest definition does not match the assembly reference. (Exception from HRESULT: 0x80131040)
      
    Source Error:
      
    An unhandled exception was generated during the execution of the current web request. Information regarding the origin and location of the exception can be identified using the exception stack trace below.
      
    Assembly Load Trace: The following information can be helpful to determine why the assembly 'Telerik.Web.UI, Version=2010.2.826.40, Culture=neutral, PublicKeyToken=121fae78165ba3d4' could not be loaded.
      
      
    WRN: Assembly binding logging is turned OFF.
    To enable assembly bind failure logging, set the registry value [HKLM\Software\Microsoft\Fusion!EnableLog] (DWORD) to 1.
    Note: There is some performance penalty associated with assembly bind failure logging.
    To turn this feature off, remove the registry value [HKLM\Software\Microsoft\Fusion!EnableLog].
      
      
    Stack Trace:
      
      
    [FileLoadException: Could not load file or assembly 'Telerik.Web.UI, Version=2010.2.826.40, Culture=neutral, PublicKeyToken=121fae78165ba3d4' or one of its dependencies. The located assembly's manifest definition does not match the assembly reference. (Exception from HRESULT: 0x80131040)]
       Telerik.Cms.Web.FormAdapter.Render(HtmlTextWriter writer) +0
       System.Web.UI.Control.RenderControlInternal(HtmlTextWriter writer, ControlAdapter adapter) +8997531
       System.Web.UI.Control.RenderControl(HtmlTextWriter writer, ControlAdapter adapter) +100
       System.Web.UI.HtmlControls.HtmlForm.RenderControl(HtmlTextWriter writer) +40
       System.Web.UI.Control.RenderChildrenInternal(HtmlTextWriter writer, ICollection children) +208
       System.Web.UI.Control.RenderChildren(HtmlTextWriter writer) +8
       System.Web.UI.Page.Render(HtmlTextWriter writer) +29
       System.Web.UI.Control.RenderControlInternal(HtmlTextWriter writer, ControlAdapter adapter) +27
       System.Web.UI.Control.RenderControl(HtmlTextWriter writer, ControlAdapter adapter) +100
       System.Web.UI.Control.RenderControl(HtmlTextWriter writer) +25
       System.Web.UI.Page.ProcessRequestMain(Boolean includeStagesBeforeAsyncPoint, Boolean includeStagesAfterAsyncPoint) +3060
      
      
    Version Information: Microsoft .NET Framework Version:4.0.30319; ASP.NET Version:4.0.30319.272


    Please help me what chould I do in order to correct this.

    Thanks
  2. Victor Velev
    Victor Velev avatar
    1345 posts
    Registered:
    06 Jul 2015
    21 Nov 2012
    Link to this post
    Hello Ashish,

    The error you are encountering is caused by the fact that there is some code / custom controls / dlls which are referencing to the RadControls assembly with that version. The version in 5.2 is:

    2012.3.1016.40 ( 5.2 SP1 build 3800 ).

    As you can see the version that you are referencing is older than the one that comes with 5.2 - you can perform a binding redirect or verify that your 5.2 project is referencing the proper assemblies.

    Also please bear in mind that it is not suggested to have a single database for your 3.7 and 5.2 projects.

    All the best,
    Victor Velev
    the Telerik team
    Do you want to have your say in the Sitefinity development roadmap? Do you want to know when a feature you requested is added or when a bug fixed? Explore the Telerik Public Issue Tracking system and vote to affect the priority of the items
  3. Amit
    Amit avatar
    43 posts
    Registered:
    15 Nov 2012
    21 Nov 2012
    Link to this post
    Hi Victor,

    Yes you are right the error occurred because in project old dll's were calling the Varsion="2010.2.826.40" but in new project there is Version="2012.3.1016.40" as mentioned by you.

     
    The following Link solved my problem:
     

    And, yes you are right I should not work on same database for both 3.7 & 5.2 versions, but I wasn't sure that If I use different Databases for both versions would that impact negative or positive (as in case of upgrading from 3.7 sp2 to 3.7 sp4 we give the same connection string).

    Thanks
  4. Sudhir
    Sudhir avatar
    1 posts
    Registered:
    20 Jan 2016
    08 Jul
    Link to this post

    Hi,

    I am getting the same problem during migrating 3.7 site to sitefinity version 8.0.
    "Could not load file or assembly 'Telerik.Web.UI, Version=2010.2.826.40, Culture=neutral, PublicKeyToken=121fae78165ba3d4' or one of its dependencies. The located assembly's manifest definition does not match the assembly reference. (Exception from HRESULT: 0x80131040)"

    If I upload the old dll then it shows

    Could not load file or assembly 'Telerik.Web.UI, Version=2015.1.225.40, Culture=neutral, PublicKeyToken=121fae78165ba3d4' or one of its dependencies. The located assembly's manifest definition does not match the assembly reference. (Exception from HRESULT: 0x80131040).

     

    Please help me to resolve this problem.

    Thanks

     

     

     

     

  5. Svetoslav Manchev
    Svetoslav Manchev avatar
    735 posts
    Registered:
    29 Nov 2016
    13 Jul
    Link to this post
    Hello Sudhir,

    You can check all the projects and custom code if there is referenced the older 'Telerik.Web.UI assembly and point it to the one in your current version.
    Alternatively you can try use assembly binding in your web.config like:
    <dependentAssembly>
      <assemblyIdentity name="'Telerik.Web.UI" publicKeyToken="121fae78165ba3d4" culture="neutral" />
      <bindingRedirect oldVersion="0.0.0.0-2015.1.225.40" newVersion="2015.1.225.40" />
    </dependentAssembly>

    Regards,
    Svetoslav Manchev
    Telerik by Progress
     
    Do you want to have your say in the Sitefinity development roadmap? Do you want to know when a feature you requested is added or when a bug fixed? Explore the Telerik Sitefinity CMS Ideas&Feedback Portal and vote to affect the priority of the items
     
5 posts, 0 answered