+1-888-365-2779
Try Now
More in this section

Forums / Bugs & Issues / Custom Animated CSS Navigation not working

Custom Animated CSS Navigation not working

4 posts, 0 answered
  1. Stepahnie
    Stepahnie avatar
    18 posts
    Registered:
    19 May 2016
    06 Jul
    Link to this post
    I created a animated navigation using css and javascript. As I was creating it, I tested in an html file. I attached the navigation to the theme so it automatically shows. It works perfectly in any browser in html but when I loaded into sitefinity the links that pop-out of the menu bar are not in the proper li and can be seen. Does anyone have any suggestions to fix this? I have attached screenshots to better explain.
  2. Victor Leontyev
    Victor Leontyev avatar
    65 posts
    Registered:
    01 Jul 2014
    06 Jul in reply to Stepahnie
    Link to this post
    Hi Stephanie. You need to edit your widget template for navigation widget. Or you need to fix your CSS. Can you please share examples where everything is working in your html and example of existing problem. It will be easier to determine problem, when i will be able to see your css and html
  3. Stepahnie
    Stepahnie avatar
    18 posts
    Registered:
    19 May 2016
    07 Jul in reply to Victor Leontyev
    Link to this post
    Hey Victor. Yup I have attached images of the html as well as the master file I am using for the theme. I also attached the css file but unfortunately i had to take screenshots in parts.
  4. Stepahnie
    Stepahnie avatar
    18 posts
    Registered:
    19 May 2016
    07 Jul
    Link to this post
    I found the cause of the problem. The content is being blocked due to insecure content, I believe it is the javascript. Does anyone know how to fix it so it allows it to load.
4 posts, 0 answered