+1-888-365-2779
Try Now
More in this section

Forums / Bugs & Issues / Custom Theme looking for Window.css and MenuMoreActions.css

Custom Theme looking for Window.css and MenuMoreActions.css

13 posts, 1 answered
  1. Kiril
    Kiril avatar
    19 posts
    Registered:
    09 Dec 2008
    29 Dec 2010
    Link to this post
    Hi,

    We have a custom theme and the SF4 RC2 looks for MenuMoreActions.css and Window.css.
    The Basic theme works just fine, but custom one or "No theme" doesn't.

    //Kiril
  2. Jordan
    Jordan avatar
    172 posts
    Registered:
    20 Oct 2015
    29 Dec 2010
    Link to this post
    Hello Kiril,

    These CSS files are part of the back-end themes so it is very strange that RC2 is looking for them in the front-end.

    Are these requests on all pages or only on a specific page. Are there any requests for these files if there aren't any controls/widgets on the  page?

    Kind regards,
    Jordan
    the Telerik team
    Do you want to have your say when we set our development plans? Do you want to know when a feature you care about is added or when a bug fixed? Explore the Telerik Public Issue Tracking system and vote to affect the priority of the items
  3. Kiril
    Kiril avatar
    19 posts
    Registered:
    09 Dec 2008
    29 Dec 2010
    Link to this post
    Hi

    This is part of the Editing the page in the backend.
    The easiest way to reproduce it is to open the page in the backend for editing when the template is using a custom theme.

    //Kiril
  4. Jordan
    Jordan avatar
    172 posts
    Registered:
    20 Oct 2015
    29 Dec 2010
    Link to this post
    Hello Kiril,

    Thank you for reporting this issue. We fixed in internally a few days ago and the fix will be provided with one of the weekly builds that we have.

    Greetings,
    Jordan
    the Telerik team
    Do you want to have your say when we set our development plans? Do you want to know when a feature you care about is added or when a bug fixed? Explore the Telerik Public Issue Tracking system and vote to affect the priority of the items
    Answered
  5. Phill Hodgkinson
    Phill Hodgkinson avatar
    362 posts
    Registered:
    10 Nov 2004
    29 Dec 2010
    Link to this post
    I had this issue when I had added telerik:RadScriptManager to the .master file of my custom template. As it turns out this doesn't need to be added as Sitefinity adds a script manager as required (I think this might be what causes the issue in the back end, script manager being added twice) If this is your case, you can remove the RadScriptManager but be sure to add an extra attribute to any custom user controls that use RadControls (or other) that require a script manager. The new attribute (that wasn't around in SF3.x) is:

    using Telerik.Sitefinity.Modules.Pages.Web.UI;
    namespace SitefinityWebApp.Custom.Navigation
    {
        [RequireScriptManager]
        public partial class CustomMenu : System.Web.UI.UserControl
        {
        // menu code
        }
    }

    If that is indeed the cause of your issue, hopefully it will help until the next build is available. 

    Cheers,
    Phill
  6. Kiril
    Kiril avatar
    19 posts
    Registered:
    09 Dec 2008
    29 Dec 2010
    Link to this post
    Hi Phill,

    Sorry to disapoint you, but I don't have a script manager in the master page.

    //Kiril
  7. Phill Hodgkinson
    Phill Hodgkinson avatar
    362 posts
    Registered:
    10 Nov 2004
    29 Dec 2010
    Link to this post
    Hi Kiril,
    No disappointment to me, just thought it might be a temp work around for you.

    Cheers,
    Phill
  8. Cheryl Forrest
    Cheryl Forrest avatar
    4 posts
    Registered:
    19 Jun 2010
    15 Jun 2011
    Link to this post
    We are using Sitefinity 4.1 SP1 which still has this annoying error logged.  What build specifically was this fix released in?

    Thank you!!!
  9. Justin
    Justin avatar
    4 posts
    Registered:
    26 May 2011
    16 Jun 2011
    Link to this post
    We're seeing the error logs fill up with this problem as well, on 4.1sp1.
    we're using master pages with a custom theme, set in the back end.
  10. Lilia Messechkova
    Lilia Messechkova avatar
    42 posts
    Registered:
    13 Jul 2016
    20 Jun 2011
    Link to this post
    Hello Justin,

    Thank you for reporting this problem. We were able to reproduce it in Sitefinity 4.1sp1. The bug was fixed. It will go in the next internal build.

    All the best,
    Lilia Messechkova
    the Telerik team
    Do you want to have your say in the Sitefinity development roadmap? Do you want to know when a feature you requested is added or when a bug fixed? Explore the Telerik Public Issue Tracking system and vote to affect the priority of the items
  11. Suzanne
    Suzanne avatar
    43 posts
    Registered:
    12 Jul 2012
    27 Jun 2011
    Link to this post
    Is this fixed in 4.1 1501?
  12. Lilia Messechkova
    Lilia Messechkova avatar
    42 posts
    Registered:
    13 Jul 2016
    28 Jun 2011
    Link to this post
    Hello Suzanne,

    The version which you specify was released to solve only a few critical issues in the service pack.
    The bug fix which you are waiting for is planned to be released at the end of this week when we will make the internal build.

    Best wishes,
    Lilia Messechkova
    the Telerik team
    Do you want to have your say in the Sitefinity development roadmap? Do you want to know when a feature you requested is added or when a bug fixed? Explore the Telerik Public Issue Tracking system and vote to affect the priority of the items
  13. Tim
    Tim avatar
    11 posts
    Registered:
    11 Nov 2012
    03 Dec 2014
    Link to this post

    We are experiencing this issue still in Sitefinity 5.x - 7.x

    The site is looking for Window.css and Treeview.css. (404 errors in fiddler)

     Please review

     

13 posts, 1 answered