1-888-365-2779
+1-888-365-2779
Try Now
More in this section

Forums / Bugs & Issues / Debugging Sitefinity 4.2 with Visual Studio Cassie

Debugging Sitefinity 4.2 with Visual Studio Cassie

4 posts, 0 answered
  1. Doug
    Doug avatar
    34 posts
    Registered:
    20 Sep 2010
    25 Aug 2011
    Link to this post
    I have a basic sitefinity project up and running. In my project I have several folders. Images, Scripts, and Styles. When I inspect element in Chrome, I am able to browser to my different scripts and styles; however, I can not view the images. In the developer tools, I receive a good number of errors (14) all saying 'Failed to load resource: the server responded with a status of 404 (Not Found)'. I know that the images are in the 'Images' folder as I can view them in Visual Studio. Any reason why I'd be getting such an error?

    Also, when I view the sitefinity test site from within the 'Sitefinity Project Manager' by clicking 'Go to Administration'. My project is called Test.

    I navigate directly to my images directory. http://localhost:36808/Test/Images/ and I can see the images. If I click on any one of them I receive a 'The resource cannot be found.' 

    I should note that I am using an external aspx page where my images are being referenced from. 

    Some of our content will be out side of sitefinity and some in side. The reason for this is we would need to migrate our existing asp.net application into sitefinity but this would occur slowly.
  2. Markus
    Markus avatar
    2763 posts
    Registered:
    25 Nov 2005
    26 Aug 2011
    Link to this post
    A while back it was a bad idea to have manually add a folder called images. I don't know if this has been resolved.

    You might want to search for image folder

    http://www.sitefinity.com/devnet/forums/sitefinity-4-x/general-discussions/sf-4-1-does-not-server-static-images-properly-404-error.aspx

    Sorry that I have no answer but this might be a lead if the old problem was not fixed in 4.2.

    Markus
  3. Markus
    Markus avatar
    2763 posts
    Registered:
    25 Nov 2005
    26 Aug 2011
    Link to this post
    A while back it was a bad idea to have manually add a folder called images. I don't know if this has been resolved.

    You might want to search for image folder

    http://www.sitefinity.com/devnet/forums/sitefinity-4-x/general-discussions/sf-4-1-does-not-server-static-images-properly-404-error.aspx

    Sorry that I have no answer but this might be a lead if the old problem was not fixed in 4.2.

    Try with myImages instead of images and see what happens

    Markus
  4. Victor Velev
    Victor Velev avatar
    1345 posts
    Registered:
    06 Jul 2015
    30 Aug 2011
    Link to this post
    Hello Doug,

    As Markus pointed in his post, the Images folder is reserved for Sitefinitys library images. However you can change it to whatever name you want, thus freeing the Images folder for your files. Please consult the video I recorded for you.


    Best wishes,
    Victor Velev
    the Telerik team

    Thank you for being the most amazing .NET community! Your unfailing support is what helps us charge forward! We'd appreciate your vote for Telerik in this year's DevProConnections Awards. We are competing in mind-blowing 20 categories and every vote counts! VOTE for Telerik NOW >>

4 posts, 0 answered