More in this section

Forums / Bugs & Issues / Deploying/Publishing a site

Deploying/Publishing a site

5 posts, 1 answered
  1. Scott Bradley
    Scott Bradley avatar
    27 posts
    Registered:
    20 Jan 2010
    12 Apr 2012
    Link to this post
    I am developing a site in Sitefinity 5.  I have a local dev copy where I was doing all of my work and want to roll it out to a QA site.  I published out of Visual Studio the files and did a backup and restore of the database to the new server.  All the content and styles are there, but the images in my image library are showing up as broken images.  Any ideas why?
  2. Jochem Bökkers
    Jochem Bökkers avatar
    787 posts
    Registered:
    13 Aug 2007
    16 Apr 2012
    Link to this post
    Hey Scott,

    Sounds like a permission/configuration problem on your QA server, are you using IIS6 or IIS7?
    From a recent struggle I had, I'd say you're using IIS6 and forgot to add the wildcard mapping to your configuration. 

     - Right click your website in the IIS manager.
     - On the 'home directory' tab click 'configuration'. 
     - Add the bottom you'll see wildcard application maps, 
     - Insert  %windir%\Microsoft.NET\Framework\v4.0.30319\aspnet_isapi.dll  (or \Framework64\ if its 64bits).
     - Restart
     
    Jochem
  3. Scott Bradley
    Scott Bradley avatar
    27 posts
    Registered:
    20 Jan 2010
    16 Apr 2012
    Link to this post
    Jochem: Thanks.  Sounds reasonable.  It is an IIS6 box.  I was just trying to push it to a quick QA environment.  I have dev and production IIS 7, sadly, no QA.

    However, I implemented your solution as you specified and it just takes the site down.  I even did a full iisreset with no joy.  Am I missing any steps that should be done?
  4. Jochem Bökkers
    Jochem Bökkers avatar
    787 posts
    Registered:
    13 Aug 2007
    16 Apr 2012
    Link to this post
    Hey Scott,

    If it takes the site down, then you probably have the checkbox 'Verify that file exists' checked - which shouldn't.

    Have you also verified that the individual mappings for .svc and .xamlx are set and pointing to the same aspnet_isapi.dll ?

    Jochem
    Answered
  5. Scott Bradley
    Scott Bradley avatar
    27 posts
    Registered:
    20 Jan 2010
    16 Apr 2012
    Link to this post
    That did the trick.  Thanks.
5 posts, 1 answered