+1-888-365-2779
Try Now
More in this section

Forums / Bugs & Issues / Document Download via PPTX

Document Download via PPTX

1 posts, 0 answered
  1. Steve
    Steve avatar
    3037 posts
    Registered:
    03 Dec 2008
    22 Feb 2013
    Link to this post

    This is strange, wonder if anyone else has come across it...

     User put a link to a sitefinity document into a pptx. When you click the link fiddler shows me it 302s the user over to login...even though they are logged in.  To validate I can just change the url to be the site root and it loads (protected site).  If I then take the url itself and paste it into the browser...it loads.  If we convert the pptx to a pdf and click the link, it loads...

     What would cause a link ONLY from a pptx to react differently, any idea?

    On the 302 the user agent is msoffice
    GET http://www.domain.ca/sf-docs/doc.pdf HTTP/1.1
    Accept: */*
    X-IDCRL_ACCEPTED: t
    User-Agent: Mozilla/4.0 (compatible; MSIE 7.0; Windows NT 6.2; Win64; x64; Trident/6.0; .NET4.0E; .NET4.0C; .NET CLR 3.5.30729; .NET CLR 3.0.30729; .NET CLR 2.0.50727; ms-office)
    UA-CPU: AMD64
    Accept-Encoding: gzip, deflate
    Host: www.domain.ca
    Connection: Keep-Alive
    Pragma: no-cache

    But in the browser it's firefox (or whatever)...and direct in browser works

    GET http://www.domain.ca/sf-docs/doc.pdf?sfvrsn=5 HTTP/1.1
    Host: www.domain.ca
    User-Agent: Mozilla/5.0 (Windows NT 6.2; WOW64; rv:19.0) Gecko/20100101 Firefox/19.0
    Accept: text/html,application/xhtml+xml,application/xml;q=0.9,*/*;q=0.8
    Accept-Language: en-US,en;q=0.5
    Accept-Encoding: gzip, deflate
    Cookie: ...
    Connection: keep-alive


      **EDIT** Found the problem, office doesn't share cookies
    https://community.jivesoftware.com/docs/DOC-32157

1 posts, 0 answered