1-888-365-2779
+1-888-365-2779
Try Now
More in this section

Forums / Bugs & Issues / ECommerce Bug: Department Item Counts not updated when product deleted

ECommerce Bug: Department Item Counts not updated when product deleted

4 posts, 0 answered
  1. SteveV
    SteveV avatar
    178 posts
    Registered:
    06 Nov 2011
    25 Jan 2012
    Link to this post

    Steps to reproduce:

    1. Create the following departments:

    Training (parent)
    Books (child of Training)
    Videos (child of Training)

    2. Create 3 products:

    Book1
    Departments - Training, Books

    Book2
    Departments - Training, Books

    Video1
    Departments - Training, Videos

    3. Create a new page named Store, drag a "Departments" widget and a "Product List" widget onto the page. 

    Edit the "Departments" widget, select "Tree (vertical with sub-levels)", "Show item count", and "Show empty items."

    Publish the page

    4. View the published front-end page.  The page should show 3 products; Book 1, Book 2, and Video 1. The Departments widget should show the following:

    Training (3)
       Books (2)
       Videos (1)

    5. From the Back-end, delete the Book 2 product.

    6. Refresh the frontend product page.  Note that the Book 2 product is no longer there.  Also note that the Department widget still indicates:

    Training (3)
       Books (2)
       Videos (1)

    7. On the frontend page, click on the Departments "Books (2)" node. Note that while the node indicates there are 2 items in this department only one product (Book 1) is displayed.

    Probably not related but while I'm at it:  In the backend, navigate to the ECommerce>Departments page.  Note that this page has an "Applied to" column which should presumabley show the number of items assigned to each department.  The values in this column always read 0.

    I had a look in PITS and didn't find any open issues related to this problem.

    --Steve

  2. Sonya
    Sonya avatar
    205 posts
    Registered:
    09 Dec 2016
    26 Jan 2012
    Link to this post
    Hi,

    Thank you for contacting Telerik Support.  

    The bug is already logged and fixed. The fix will be availabe in the next release scheduled for the middle of February. You can follow the PITS Issue by its ID: 9479 . 

     

    Greetings,
    Sonya
    the Telerik team
    Do you want to have your say in the Sitefinity development roadmap? Do you want to know when a feature you requested is added or when a bug fixed? Explore the Telerik Public Issue Tracking system and vote to affect the priority of the items
  3. SteveV
    SteveV avatar
    178 posts
    Registered:
    06 Nov 2011
    26 Jan 2012
    Link to this post
    Hmm, very odd.  I did a search for "department" in PITS (in the Sitefinity area) yesterday before taking the time to qrite it up and this did not show up in the results.

    Also, is the second part of my post affected by the fix:
    [ In the backend, navigate to the ECommerce>Departments page. Note that this page has an "Applied to" column which should presumabley show the number of items assigned to each department. The values in this column always read 0.]

    Anyway, glad it's been resolved--will wait patiently for the next release cycle.

    Thanks--Steve
  4. Stanislav Velikov
    Stanislav Velikov avatar
    1113 posts
    Registered:
    18 Aug 2017
    03 Aug 2012
    Link to this post
    Hi Steve,

    The bug with the count of the products in a department not updating this is a bug, here is the link for it in PITS.
    Thank you for bringing this to our attention.

    I have updated your Telerik points!

    All the best,
    Stanislav Velikov
    the Telerik team
    Do you want to have your say in the Sitefinity development roadmap? Do you want to know when a feature you requested is added or when a bug fixed? Explore the Telerik Public Issue Tracking system and vote to affect the priority of the items
4 posts, 0 answered