+1-888-365-2779
Try Now
More in this section

Forums / Bugs & Issues / Edits to published events do not save

Edits to published events do not save

7 posts, 0 answered
  1. Tony
    Tony avatar
    13 posts
    Registered:
    07 Jun 2012
    01 Apr 2013
    Link to this post
    If you open a published event and make changes, then click Publish, it acts like it is updating the event and goes back to the events list where the time of the attempted update is shown as the "last modified" date. But when you open the item, the changes were not saved. Tried this several time not believing what I was seeing.

    Got it to work by opening the item, unpublishing it, making the changes, then publishing. Ugh.
  2. Steve
    Steve avatar
    3037 posts
    Registered:
    03 Dec 2008
    02 Apr 2013
    Link to this post
    Do you have the L2 Cache disabled?
    http://www.sitefinitysteve.com/blog/code/2012/03/16/row-not-found-genericoid-error

    If the answer is NO, I bet that will fix you up...I (and many others) have had this exact problem on tons of sites, disable that, haven't had a support call since (would normally be few times a week).

    Telerik is working on the problem, it's just hard b/c it's not always easy to replicate.

    Steve
  3. Atanas Valchev
    Atanas Valchev avatar
    414 posts
    Registered:
    04 Jan 2016
    04 Apr 2013
    Link to this post
    Hi,

    The solution described by Steve is the temporary solution for this issue. Recently were successful at reliably reproducing it and are currently investigating the exact causes. 

    Greetings,
    Atanas Valchev
    the Telerik team
    Do you want to have your say in the Sitefinity development roadmap? Do you want to know when a feature you requested is added or when a bug fixed? Explore the Telerik Public Issue Tracking system and vote to affect the priority of the items
  4. Steve
    Steve avatar
    3037 posts
    Registered:
    03 Dec 2008
    04 Apr 2013 in reply to Atanas Valchev
    Link to this post
    @Atanas ...so it's maybe only PARTIALLY L2 related?

    I haven't had a single issue since disabling it a month or so ago
  5. Atanas Valchev
    Atanas Valchev avatar
    414 posts
    Registered:
    04 Jan 2016
    04 Apr 2013
    Link to this post
    Hello,

    L2 is definitely part of it. We are  working with the OpenAccess guys to track this problem down and resolve it. It is being handled with a high priority. Reproducing it was very tricky but we found a project and reliable way to do it. I will post any updates here as I get  them. 

    Kind regards,
    Atanas Valchev
    the Telerik team
    Do you want to have your say in the Sitefinity development roadmap? Do you want to know when a feature you requested is added or when a bug fixed? Explore the Telerik Public Issue Tracking system and vote to affect the priority of the items
  6. Steve
    Steve avatar
    3037 posts
    Registered:
    03 Dec 2008
    04 Apr 2013 in reply to Atanas Valchev
    Link to this post
    Awesome!  Thanks :)
  7. Tony
    Tony avatar
    13 posts
    Registered:
    07 Jun 2012
    04 Apr 2013
    Link to this post
    Thank you. I have my IT support looking into the L2 cache suggestion.
7 posts, 0 answered