+1-888-365-2779
Try Now
More in this section

Forums / Bugs & Issues / Email Notification (Comments, Workflow)

Email Notification (Comments, Workflow)

17 posts, 0 answered
  1. William
    William avatar
    108 posts
    Registered:
    15 Feb 2011
    26 Apr 2011
    Link to this post
    Hey all,

    I'm having a difficult time getting email notifications to work in 4.1.  When setting up workflow to notify admins by email when something has been submitted for approval, or when setting up blog comments to email the author, no emails appear to be sent.  Forgot Password, however, does successfully send email.

    I have setup my SMTP settings, which if used natively through code, do send messages.  They just don't seem to from within Sitefinity.

    I'm not going to screenshot publicly (as passwords are revealed), but I've filled in:
    - Host
    - Port
    - UserName
    - Password
    - DeliveryMethod ("Network")
    - Checked SSL
    - Timeout (default setting)
    - DefaultSenderEmailAddress
    - EmailSubjectEncoding (default value)
    - EmailBodyEncoding (default value)

    Not sure what else I have to do.  Any tips?

    Thanks

    - William
  2. Ivan Dimitrov
    Ivan Dimitrov avatar
    16072 posts
    Registered:
    25 Nov 2016
    26 Apr 2011
    Link to this post
    Hi William,

    The workflow notification uses SMTP settings set under Administration >> Settings >> System. I experienced issues when DefaultSenderEmailAddress was not set.

    Kind regards,
    Ivan Dimitrov
    the Telerik team

  3. William
    William avatar
    108 posts
    Registered:
    15 Feb 2011
    26 Apr 2011
    Link to this post
    Hi Ivan,

    Actually, that list I mentioned in my post were the fields that I'd filled in through the SMTP settings in Administration -> Settings.  DefaultSenderEmailAddress is filled in with a valid email address and still no joy.

    Any other ideas?

    Thanks

    - William
  4. Ivan Dimitrov
    Ivan Dimitrov avatar
    16072 posts
    Registered:
    25 Nov 2016
    26 Apr 2011
    Link to this post
    Hi William,

    I saw that, I shared that I was able to replicate issues If this field is not valid there would be an issues. I am testing the notifications with a local SMTP client and I am not able to replicate issues. Emails are received.

    The reasons could be

    1. There is no recipient - we catch the exception and there is no notification about this error
    2. The sender is not valid

    Since DefaultSenderEmailAddress is set I believe that there is some issue with the recipient. Please check whether you have set the proper workflow users that should receive a message.

    Greetings,
    Ivan Dimitrov
    the Telerik team

  5. William
    William avatar
    108 posts
    Registered:
    15 Feb 2011
    26 Apr 2011
    Link to this post
    Ivan,

    Thanks for the fast response.

    Should the admin users receive notification by default?  I haven't set any specific user up to receive notifications.  My testing was just with one admin user (set as an administrator role) and one editor (set as an editor role).  Editor submits for approval and I was assuming that meant the admin user got the email automatically.  I'd assumed that as the administrator users don't appear in the list I get when I hit the button to choose users to receive notification.

    My admin user is set up with a valid email in his profile.  Also the DefaultSenderEmailAddress is my own email, so I'm sure that's fine too.

    Forgot password is working fine, though.  Is that tied into the same system?

    - William

  6. Ivan Dimitrov
    Ivan Dimitrov avatar
    16072 posts
    Registered:
    25 Nov 2016
    26 Apr 2011
    Link to this post
    Hi William,

    Notifications are sent only when content is waiting for approval. When a new comment is submitted we do not send an notification.

    Please make sure that you have configured the workflow properly. I am sending a screenshot that shows how the workflow should be configured if you want an admin to receive notifications.

    Best wishes,
    Ivan Dimitrov
    the Telerik team

  7. William
    William avatar
    108 posts
    Registered:
    15 Feb 2011
    26 Apr 2011
    Link to this post
    Ah ha,

    So you do have to specify a user.  Question then.  Users with administrator roles do not show up in the list to add users to be notified.  So I'm assuming I'd have to create a new, non-admin user and give he or she sufficient permissions and then specify them there.

    Or is there a way to list an admin user in that list?  I'm not seeing any in mine.

    Thanks

    - William
  8. William
    William avatar
    108 posts
    Registered:
    15 Feb 2011
    28 Apr 2011
    Link to this post
    Ivan,

    That absolutely fixed the workflow problem.  Thank you.  It was a bit misleading as my administrator users weren't showing in the list of users.  Once I typed "admin", I found that user.

    Email sent successfully.

    In terms of blog comments, though, I'm still struggling.  If my admin users makes a post and then somebody else comments on that post, the admin user never receives an email.  Keep in mind that my admin user is the same one that is now successfully receiving update notifications, so I know the settings are correct.

    I've even tried to show the EmailAuthor field on all backend pages, to allow for each post to set that value.  Still no comment notification.

    Is there something I'm missing?  Some global setting somewhere?  Should comments automatically email the post author (owner)?

    Thanks much

    - William

  9. Ivan Dimitrov
    Ivan Dimitrov avatar
    16072 posts
    Registered:
    25 Nov 2016
    28 Apr 2011
    Link to this post
    Hello William,

    We do not send notifications when you make a comment. We left this implementations for one of the next Q releases.

    "When a new comment is submitted we do not send an notification"

    To get this working I could come up with a custom solution only.Content notifications are sent through the workflow, but comments are not.

    Greetings,
    Ivan Dimitrov
    the Telerik team

  10. William
    William avatar
    108 posts
    Registered:
    15 Feb 2011
    28 Apr 2011
    Link to this post
    Ivan,

    Well that would explain it :)

    I'd love to see an example of a custom solution if it's possible.  Barring that, I may have to get at comments through Fluent instead of the widget so I can handle that email notification piece.

    Thanks

    - William
  11. Ivan Dimitrov
    Ivan Dimitrov avatar
    16072 posts
    Registered:
    25 Nov 2016
    04 May 2011
    Link to this post
    Hi William,

    The easiest way here is creating a custom class that inherits from  OpenAccessEventProvider and there you can override CreateComment method

    public override GenericContent.Model.Comment CreateComment(GenericContent.Model.ICommentable commentedItem)
            {

                // add your custom logic here
                return base.CreateComment(commentedItem);
            }

    The custom provider should be registered through the configuration - Settings >> Advanced >> Events >> Providers

    Best wishes,
    Ivan Dimitrov
    the Telerik team
    Do you want to have your say in the Sitefinity development roadmap? Do you want to know when a feature you requested is added or when a bug fixed? Explore the Telerik Public Issue Tracking system and vote to affect the priority of the items
  12. Fabien
    Fabien avatar
    3 posts
    Registered:
    20 Jul 2011
    20 Jul 2011
    Link to this post
    Hi,

    I wanna send a email when a personn post a comment like William. So I try to follow your solution but i've got some problems. How can I do to register my custom provider? Should I create a new DataProviderSettings or a StorageProviderSettings? What's the ProviderType? For information my new class is in a folder of SitefinityWebApp and I use the latest version of Sitefinity.

    Thanks for your answer and sorry for my poor english. ;)

    Fabien
  13. Radoslav Georgiev
    Radoslav Georgiev avatar
    3370 posts
    Registered:
    01 Feb 2016
    25 Jul 2011
    Link to this post
    Hi Fabien,

    You should register your custom provider (inherit from OpenAccessEventProvider) in Administration -> Settings -> Advanced -> Events -> Providers. Here you can edit the default provider and substitute the default type with the type of your custom provider.

    All the best,
    Radoslav Georgiev
    the Telerik team
    Do you want to have your say in the Sitefinity development roadmap? Do you want to know when a feature you requested is added or when a bug fixed? Explore the Telerik Public Issue Tracking system and vote to affect the priority of the items
  14. Jay
    Jay avatar
    2 posts
    Registered:
    09 Nov 2011
    10 Nov 2011
    Link to this post
    I also am not receiving workflow notifications.  I'm using an SMTP server that does not require authentication so I'm just entering hostname, port and default sender using a valid email address.

    I was able to verify the hostname and port by entering them in the Email campaign configuration and clicking the Send Test button.  I received the test message, but when using the same hostname and port in the System SMTP settings, no email notifications are received.
     
    Any suggestions on how to fix or troubleshoot this issue?
  15. Radoslav Georgiev
    Radoslav Georgiev avatar
    3370 posts
    Registered:
    01 Feb 2016
    14 Nov 2011
    Link to this post
    Hello Jay,

    Can you show us a screen shot of your SMTP settings? You can blank out the domain specifics, we need to be sure that the settings are properly set. Also, please check the error log files located under ~/App_Data/Sitefinity/Logs. What you can do is to empty this folder. Then push an item through workflow, which should trigger the notifications process and then see if there are any relevant error messages in the error logs directory.

    Best wishes,
    Radoslav Georgiev
    the Telerik team
    Do you want to have your say in the Sitefinity development roadmap? Do you want to know when a feature you requested is added or when a bug fixed? Explore the Telerik Public Issue Tracking system and vote to affect the priority of the items
  16. Laura
    Laura avatar
    1 posts
    Registered:
    24 Jun 2014
    24 Jun 2014 in reply to Ivan Dimitrov
    Link to this post

    Has this been added yet? I cannot find a way to get an email notification that a comment is waiting for approval. (I can see it if I go to Content > Comments where it is marked with an orange question mark)

  17. Sabrie Nedzhip
    Sabrie Nedzhip avatar
    534 posts
    Registered:
    02 Dec 2016
    25 Jun 2014
    Link to this post
    Hi Laura,

    Can you please take a look at the following article describing in details how you can subscribe to news items' comments that are awaiting approval. Please also make sure that you have configured the SMTP settings following the steps in this article

    Regards,
    Sabrie Nedzhip
    Telerik
     
    Do you want to have your say in the Sitefinity development roadmap? Do you want to know when a feature you requested is added or when a bug fixed? Explore the Telerik Sitefinity CMS Ideas&Feedback Portal and vote to affect the priority of the items
     
17 posts, 0 answered