+1-888-365-2779
Try Now
More in this section

Forums / Bugs & Issues / Embedded flash file breaks layout widgets edit mode

Embedded flash file breaks layout widgets edit mode

4 posts, 0 answered
  1. Stacey
    Stacey avatar
    291 posts
    Registered:
    18 Oct 2012
    20 Mar 2013
    Link to this post
    I have an old site I am migrating over to Sitefinity.  There is a swf file that does nothing else than cycles images that are embedded into the flash file (i.e. not advanced scripting).  I know there are much better ways to handles this, but again this is a pure migration at this point.

    This happens with the built in Sitefinity templates and also with custom templates via masterpages.

    1.) I drop a content widget onto the page and use the embed flash feature to select my swf.  It displays and functions correctly.
    2.) Now anytime I click edit on a layout widget the edit modal breaks.  See the attached image.

    I have read similar issues when there are jQuery conflicts, but the only control on the page is the content block where I load the flash and I am not explicitly loading jQuery for anything.  When I view the resources being loaded into the page I am only seeing 1 reference to jQuery (1.8.3) and the typical Telerik version of jQuery UI and etc.

    Any ideas?
  2. Jen Peleva
    Jen Peleva avatar
    568 posts
    Registered:
    10 Nov 2016
    25 Mar 2013
    Link to this post
    Hi Stacey,

     Thank you for reporting this behavior!

    I was able to reproduce it on a new instance of Sitefinity 5.4 It turns out to be a bug in our system, which requires further investigation. Please excuse us for the inconvenience. I have updated your Telerik points! You can track the status of the bug here:

    http://www.telerik.com/support/pits.aspx#/public/sitefinity/14620

    Kind regards,
    Jen Peleva
    the Telerik team
    Do you want to have your say in the Sitefinity development roadmap? Do you want to know when a feature you requested is added or when a bug fixed? Explore the Telerik Public Issue Tracking system and vote to affect the priority of the items
  3. Stacey
    Stacey avatar
    291 posts
    Registered:
    18 Oct 2012
    10 May 2013 in reply to Jen Peleva
    Link to this post
    Still seeing this in 6.0.  Any update on this?  I am also seeing this exact same thing anytime I use embed code that has an iframe from vendors like YouTube. 

    This line of html will break it every time. NOTE:  This is added in the Content Block widget via HTML mode.
    <iframe width="250" height="200" src="http://www.youtube.com/embed/#######" frameborder="0"></iframe>


    I cannot expect my clients to know they need to remove this every time they want to make a change on their page layouts.

    I played around a bit in Chrome and found that I can turn off the Overflow: hidden in the following line and the UI will be the way it should, but I prefer not to try overriding your ZoneEditor.

    <span id="ZoneEditor" style="top:-10000px;left:-10000px;position:absolute;overflow:hidden;height:1px;width:1px;">


    Temp Workaround:  This needs more testing as I am sure there may be a scenario that this is not good for, but for now I can at least use the page layouts in my templates without having to remove embed code by adding the following to my CSS.
    #ZoneEditor {
        overflow: visible !important;
    }
  4. Jen Peleva
    Jen Peleva avatar
    568 posts
    Registered:
    10 Nov 2016
    14 May 2013
    Link to this post
    Hi Stacey,

    The bug hasn't been scheduled for fixing for now, bu I can assure you that the team will do its best to fix it as soon as possible. 

    Kind regards,
    Jen Peleva
    the Telerik team
    Do you want to have your say in the Sitefinity development roadmap? Do you want to know when a feature you requested is added or when a bug fixed? Explore the Telerik Public Issue Tracking system and vote to affect the priority of the items
4 posts, 0 answered