+1-888-365-2779
Try Now
More in this section

Forums / Bugs & Issues / Error navigating to administration section - Value cannot be null. Parameter name: node

Error navigating to administration section - Value cannot be null. Parameter name: node

2 posts, 0 answered
  1. Kiruthiga
    Kiruthiga avatar
    2 posts
    Registered:
    20 Jul 2015
    24 Jul 2015
    Link to this post

    Hi , I am new to Sitefinity. I am using a trial version 8.1.5800.0 for development purpose.  I am getting this error while trying to navigate to administration section. Any help will be greatly appreciated.

     

    Exception Details: System.ArgumentNullException: Value cannot be null.
    Parameter name: node

    Source Error:

    An unhandled exception was generated during the execution of the current web request. Information regarding the origin and location of the exception can be identified using the exception stack trace below.
    Stack Trace:

    [ArgumentNullException: Value cannot be null. Parameter name: node] Telerik.Sitefinity.Web.RouteHelper.SslRedirectIfNeeded(HttpContextBase httpContext, PageSiteNode node) +122 Telerik.Sitefinity.Modules.Pages.PageManager.RenderPage(HttpContextBase context, Guid pageNodeId, Action`1 pageAction) +99 Telerik.Sitefinity.Security.Claims.ClaimsResolver.RenderLoginForm(HttpContextBase context, String errorMessage) +134 Telerik.Sitefinity.Security.Claims.SecurityTokenServiceHttpHandler.SendLoginForm(HttpContextBase context, String message) +19 Telerik.Sitefinity.Security.Claims.SecurityTokenServiceHttpHandler.ProcessRequest(HttpContextBase context) +1349 Telerik.Sitefinity.Security.Claims.SecurityTokenServiceHttpHandler.ProcessRequest(HttpContext context) +40 System.Web.CallHandlerExecutionStep.System.Web.HttpApplication.IExecutionStep.Execute() +188 System.Web.HttpApplication.ExecuteStep(IExecutionStep step, Boolean& completedSynchronously) +69 ​

  2. Svetoslav Manchev
    Svetoslav Manchev avatar
    735 posts
    Registered:
    30 Sep 2016
    03 Aug 2015
    Link to this post
    Hi Kiruthiga,

    Would you please check the and ensure that all the IIS settings are correct as per the articles below:
    http://docs.sitefinity.com/configure-the-iis-to-host-sitefinity-projects
    http://docs.sitefinity.com/run-projects-on-iis-7-0-and-above

    In case you are using SSL you can also take a look here:
    http://docs.sitefinity.com/administration-configure-ssl

    I hope this information helps.

    Regards,
    Svetoslav Manchev
    Telerik
     
    Do you want to have your say in the Sitefinity development roadmap? Do you want to know when a feature you requested is added or when a bug fixed? Explore the Telerik Sitefinity CMS Ideas&Feedback Portal and vote to affect the priority of the items
     
2 posts, 0 answered