+1-888-365-2779
Try Now
More in this section

Forums / Bugs & Issues / Error on editing: "undefined"

Error on editing: "undefined"

10 posts, 0 answered
  1. Ben Alexandra
    Ben Alexandra avatar
    215 posts
    Registered:
    15 Sep 2012
    08 Apr 2015
    Link to this post

    Hi,

     I am getting an intermittent error in the admin. When I got to edit pages I often get a popup that says "undefined" and nothing else. If I look at the console I see the following page throws this error: /Sitefinity/Services/Workflow/WorkflowService.svc

    If I follow the link in a new tab I will get an error {"Detail":"Object reference not set to an instance of an object."} (ever developers favorite error!)

    The only way I've figured out how to get around this is to restart the site. It then usually works and if I refresh that link I get actual JSON returned and no "undefined" error appears and everything is good.

    I am attaching 3 screenshots

    1. Error 1 = When I first went go and get the error
    2. Error 2 = When I go to the .svc page
    3. Error 3 = The .svc page after restarting the application pool

    /Sitefinity/Services/Workflow/WorkflowService.svc/06f1a4be-e8c5-4413-b521-a0332b18790a/?itemType=Telerik.Sitefinity.Pages.Model.PageNode&showMoreActions=true&unv_tstmp_prm=1428524792412

     Thank you!

     

  2. Laurent Poulain
    Laurent Poulain avatar
    17 posts
    Registered:
    08 Dec 2016
    13 Apr 2015
    Link to this post
    Hello,

    Could you attach both any JavaScript error in the JavaScript console when you are getting this error, as well as your Error.log file located in your project App_Data\Sitefinity\Logs directory? This should shed some light on the reason for that error.

    Regards,
    Sitefinity Laurent
    Telerik
     
    Do you want to have your say in the Sitefinity development roadmap? Do you want to know when a feature you requested is added or when a bug fixed? Explore the Telerik Sitefinity CMS Ideas&Feedback Portal and vote to affect the priority of the items
     
  3. Ben Alexandra
    Ben Alexandra avatar
    215 posts
    Registered:
    15 Sep 2012
    13 Apr 2015 in reply to Laurent Poulain
    Link to this post

    There are no logs. That folder you mentioned has no new log entries (I cleared the folder and got the error and then checked and that folder (App_Data\Sitefinity\Logs ) was still empty).

     The page it is calling (see earlier entry in this ticket) just doesn't come up. So that's why you get the error.

     I need that page to come up reliably, but not sure how to get it to do that. Restarting the site usually fixes it for a bit, as I mentioned...

  4. Laurent Poulain
    Laurent Poulain avatar
    17 posts
    Registered:
    08 Dec 2016
    14 Apr 2015
    Link to this post
    Hello,

    Thank you for the JavaScript console output. It shows there are several errors:
    • Some errors come from trying to load a URL from http://70.52.238.12 but failed because a server-side issue. What is that server?
    • Other errors come from attempting to load resources from http://www.yourorganicsources.com, but failed because of permission issues. Do you see the problem when editing pages after being idle for a while in the backend? I'm wondering if the login session didn't timeout for some reason.
    Regards,
    Sitefinity Laurent
    Telerik
     
    Do you want to have your say in the Sitefinity development roadmap? Do you want to know when a feature you requested is added or when a bug fixed? Explore the Telerik Sitefinity CMS Ideas&Feedback Portal and vote to affect the priority of the items
     
  5. Ben Alexandra
    Ben Alexandra avatar
    215 posts
    Registered:
    15 Sep 2012
    14 Apr 2015 in reply to Laurent Poulain
    Link to this post

    Hi,

     Thanks for the quick reply.

    Yes, the IP address is for their in-house chat but that's not the issue. I can try to go to the page it is complaining about and get {"Detail":"Object reference not set to an instance of an object."} as an error. When I restart that same link fixes itself and I get JSON again from the .svc Url and the permissions issues are fixed, too, on those images. Since every request goes through Sitefinity, it seems to be an issue with your software, no? I am not sure how to fix it, though. Any suggestions? What can I send you to help you get to the bottom of this?

    Thank you so much!

  6. Laurent Poulain
    Laurent Poulain avatar
    17 posts
    Registered:
    08 Dec 2016
    14 Apr 2015
    Link to this post
    Hello,

    If you start having errors on an edit page, it is not surprising that clicking on any other link will lead to an error. But it does appear like your account got automatically logged out.

    When you get the error on the edit page, what happens if you click on Back or go directly to the Sitefinity Administration page? Are you presented with a login page? If you log out and back in, can you then edit the page again?

    Regards,
    Sitefinity Laurent
    Telerik
     
    Do you want to have your say in the Sitefinity development roadmap? Do you want to know when a feature you requested is added or when a bug fixed? Explore the Telerik Sitefinity CMS Ideas&Feedback Portal and vote to affect the priority of the items
     
  7. Ben Alexandra
    Ben Alexandra avatar
    215 posts
    Registered:
    15 Sep 2012
    19 Apr 2015 in reply to Laurent Poulain
    Link to this post

    Hi,

    Thanks for the reply! I don't see where you see me being logged out. I am not. I edit that page and get the error message. If I go back to the admin I am NOT logged out and can edit other pages. And if I bring up the .svc page I mentioned above I get the error I have mentioned. If I restart the IIS app pool and then refresh that .svc page (without doing anything else, including having to log in again), it comes up fine. So something is hanging or having issues when I try to edit and once I restart it then it works fine for a while.

    Thanks for any help you can provide. I appreciate it

    Ben

  8. Laurent Poulain
    Laurent Poulain avatar
    17 posts
    Registered:
    08 Dec 2016
    22 Apr 2015
    Link to this post
    Hello,

    At this point I would advise you to file a Support Ticket. This will allow you to send us your project so we can try to reproduce it in-house.

    Regards,
    Sitefinity Laurent
    Telerik
     
    Do you want to have your say in the Sitefinity development roadmap? Do you want to know when a feature you requested is added or when a bug fixed? Explore the Telerik Sitefinity CMS Ideas&Feedback Portal and vote to affect the priority of the items
     
  9. Abdul
    Abdul avatar
    0 posts
    Registered:
    26 Oct 2016
    26 Oct
    Link to this post

    Hi 

    I'm getting error while trying to edit content in Sitefinity 7.3. The error is coming only after publishing the project and hosted it in IIS. When debugging the project from visual studio, I am able to edit the content .  This is the error from log

    Type : System.NullReferenceException, mscorlib, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089
    Message : Object reference not set to an instance of an object.
    Source : Telerik.Sitefinity
    Help link : 
    Data : System.Collections.ListDictionaryInternal
    TargetSite : Boolean LoadCollectionElement(Telerik.Sitefinity.Configuration.ConfigElementCollection, System.Xml.XmlReader, Telerik.Sitefinity.Configuration.ConfigPolicyHandler, System.String, UpgradingInfo)
    HResult : -2147467261
    Stack Trace :    at Telerik.Sitefinity.Configuration.Data.XmlConfigProvider.LoadCollectionElement(ConfigElementCollection collection, XmlReader reader, ConfigPolicyHandler policyHandler, String policyName, UpgradingInfo upgradingInfo)
       at Telerik.Sitefinity.Configuration.Data.XmlConfigProvider.LoadElement(ConfigElement element, XmlReader reader, ConfigPolicyHandler policyHandler, String policyName, UpgradingInfo upgradingInfo, Boolean isNew, Boolean validateTagName)
       at Telerik.Sitefinity.Configuration.Data.XmlConfigProvider.LoadPropertyElement(ConfigElement element, XmlReader reader, ConfigPolicyHandler policyHandler, String policyName, UpgradingInfo upgradingInfo)
       at Telerik.Sitefinity.Configuration.Data.XmlConfigProvider.LoadElement(ConfigElement element, XmlReader reader, ConfigPolicyHandler policyHandler, String policyName, UpgradingInfo upgradingInfo, Boolean isNew, Boolean validateTagName)
       at Telerik.Sitefinity.Configuration.Data.XmlConfigProvider.LoadCollectionElement(ConfigElementCollection collection, XmlReader reader, ConfigPolicyHandler policyHandler, String policyName, UpgradingInfo upgradingInfo)
       at Telerik.Sitefinity.Configuration.Data.XmlConfigProvider.LoadElement(ConfigElement element, XmlReader reader, ConfigPolicyHandler policyHandler, String policyName, UpgradingInfo upgradingInfo, Boolean isNew, Boolean validateTagName)
       at Telerik.Sitefinity.Configuration.Data.XmlConfigProvider.LoadPropertyElement(ConfigElement element, XmlReader reader, ConfigPolicyHandler policyHandler, String policyName, UpgradingInfo upgradingInfo)
       at Telerik.Sitefinity.Configuration.Data.XmlConfigProvider.LoadElement(ConfigElement element, XmlReader reader, ConfigPolicyHandler policyHandler, String policyName, UpgradingInfo upgradingInfo, Boolean isNew, Boolean validateTagName)
       at Telerik.Sitefinity.Configuration.Data.XmlConfigProvider.LoadSectionFromReader(ConfigSection section, XmlReader reader, ConfigPolicyHandler policyHandler, String policyName, Boolean checkForUpgrade, UpgradingInfo& upgradingInfo)
       at Telerik.Sitefinity.Configuration.Data.XmlConfigProvider.LoadElementFromDatabase(ConfigSection section, ConfigPolicyHandler policyHandler, String policyName)
       at Telerik.Sitefinity.Configuration.Data.XmlConfigProvider.TryLoadSectionFromDatabase(ConfigSection section, ConfigPolicyHandler policyHandler, String policyName, Boolean initial)
       at Telerik.Sitefinity.Configuration.Data.XmlConfigProvider.LoadSection(ConfigSection section, ConfigPolicyHandler policyHandler, String policyName)
       at Telerik.Sitefinity.Configuration.ConfigSection.Initialize(ConfigProvider provider, ConfigPolicyHandler policyHandler, String policyName, Boolean singlePolicy)
       at Telerik.Sitefinity.Configuration.ConfigSection.Initialize(ConfigProvider provider)
       at Telerik.Sitefinity.Configuration.Config.GetSectionInternal(Type sectionType, Boolean safeMode, String sectionName)
       at Telerik.Sitefinity.Configuration.Config.GetSectionPrivate(Type sectionType, Boolean safeMode, String sectionName)
       at Telerik.Sitefinity.Configuration.Config.GetSectionPrivate[TSection](Boolean safeMode)
       at Telerik.Sitefinity.DynamicModules.DynamicModuleManager.get_ProvidersSettings()
       at Telerik.Sitefinity.Data.ManagerBase`1.GetProvidersSettings()
       at Telerik.Sitefinity.Data.ManagerBase`1.Initialize()

  10. Scott
    Scott avatar
    1 posts
    Registered:
    22 May 2014
    16 Nov
    Link to this post
    Has there been any resolution to this? Would be helpful to post the solution instead of hiding it away in a private support ticket.
10 posts, 0 answered