+1-888-365-2779
Try Now
More in this section

Forums / Bugs & Issues / Error sending system message in load balancer

Error sending system message in load balancer

3 posts, 0 answered
  1. Pankaj
    Pankaj avatar
    4 posts
    Registered:
    30 Apr 2014
    01 Mar
    Link to this post

    Hi,

    We are developing cms on SiteFinity 8.2 and deploying application on webfarm. It has two hosts with port on which application is deployed. We have done setting as per documentation http://docs.sitefinity.com/administration-ensure-content-consistency-on-all-nodes for load balancer.

     Url of the application: http://mydomain.com/sitefinity/

     Settings for hosts in Advanced Setting -> System -> LoadBalancing-> WebServerUrls are like below:
    http://host1.com:12600/Sitefinity
    http://host2.com:12600/Sitefinity

     We have also added below values in Administration -> Settings -> Advanced -> Security -> SecurityTokenIssuers:

     i.http://localhost
     ii. http://mydomain.com/sitefinity/Sitefinity/Authenticate/SWT

     
     and for RelyingParties we have below values:
     i.http://localhost
     ii. http://mydomain.com/sitefinity
     iii. http://host1.com:12600/sitefinity
     iv. http://host2.com:12600/sitefinity
     
     I am getting below errros in our logs:
     
     Message : Error sending system message to URL: http://host1:12600/Sitefinity/Sitefinity/Services/LoadBalancing/SystemWebService.svc/HandleMessages; HTTP method: PUT; Host: 'host1:12600'

     Inner Exception
     ---------------
     Type : System.Net.WebException, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089
     Message : The remote server returned an error: (401) Unauthorized.
     Source : System
     
     Please let us know what is going wrong and also suggest if above settings are good or not.

     

    Thanks,

    Pankaj

  2. Sahil
    Sahil avatar
    1 posts
    Registered:
    11 Nov 2015
    02 Mar
    Link to this post

    Even we are facing same kind of issues after migration to sitefinity 8.2

    Here is the log:

     

    Timestamp: 2/29/2016 7:00:30 AM

    Message: HandlingInstanceID: c713af6a-053f-4ba6-a61c-cd78f854a318
    An exception of type 'System.Exception' occurred and was caught.
    ----------------------------------------------------------------
    02/29/2016 01:00:30
    Type : System.Exception, mscorlib, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089
    Message : Error sending system message to URL: http://sf-prod1.test/Sitefinity/Services/LoadBalancing/SystemWebService.svc/HandleMessages; HTTP method: PUT; Host: null
    Source : 
    Help link : 
    Data : System.Collections.ListDictionaryInternal
    TargetSite : 
    HResult : -2146233088
    Stack Trace : The stack trace is unavailable.
    Additional Info:

    MachineName : US1111111111
    TimeStamp : 2/29/2016 7:00:30 AM
    FullName : Telerik.Sitefinity.Utilities, Version=8.2.5900.0, Culture=neutral, PublicKeyToken=111111111
    AppDomainName : /LM/W3SVC/3/ROOT-1-131012028000824965
    ThreadIdentity : 
    WindowsIdentity : IIS APPPOOL\SF_Global_PRD
    Inner Exception
    ---------------
    Type : System.Net.WebException, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=11111111
    Message : The remote server returned an error: (401) Unauthorized.
    Source : System
    Help link : 
    Status : ProtocolError
    Response : System.Net.HttpWebResponse
    Data : System.Collections.ListDictionaryInternal
    TargetSite : System.IAsyncResult BeginGetResponse(System.AsyncCallback, System.Object)
    HResult : -2146233079
    Stack Trace :    at System.Net.HttpWebRequest.BeginGetResponse(AsyncCallback callback, Object state)
      at Telerik.Sitefinity.LoadBalancing.WebServiceSystemMessageSender.WithExceptionHandling(String url, String httpMethod, String hostHeader, Action action)



    Category: ErrorLog

    Priority: 0

    EventId: 9010

    Severity: Warning

    Title:Enterprise Library Exception Handling

    Machine: US111111111

    App Domain: /LM/W3SVC/3/ROOT-1-131012028000824965

    ProcessId: 12040

    Process Name: c:\windows\system32\inetsrv\w3wp.exe

    Thread Name: http://sf-prod1.test.jll.de/Sitefinity/Services/LoadBalancing/SystemWebService.svc/HandleMessages-Thread-1

    Win32 ThreadId:10028

    Extended Properties: 

     

     

     

    It will be really great if someone can provide a helping hand here on priority basis.

     

    Thanks ,
    Sahil

  3. Svetoslav Manchev
    Svetoslav Manchev avatar
    735 posts
    Registered:
    07 Dec 2016
    04 Mar
    Link to this post
    Hi,

    @Pankaj, 
    Judging from the provided information "Sitefinity" is not a virtual in your set-up, can you please try to remove the "/sitefinity" part of the url settings in your project, save the changes and restart the application.

    @Sahil
    The issue seems related to that feedback item:
    http://feedback.telerik.com/Project/153/Feedback/Details/179543-load-balancing-service-throws-401-unauthorized-on-restart-when-configs-are-in-t
    If so, this is just a warning that you see during the site initialization, as all the notes are not available at the same time but you should not have any issue after that.

    Regards,
    Svetoslav Manchev
    Telerik
     
    Do you want to have your say in the Sitefinity development roadmap? Do you want to know when a feature you requested is added or when a bug fixed? Explore the Telerik Sitefinity CMS Ideas&Feedback Portal and vote to affect the priority of the items
     
3 posts, 0 answered