+1-888-365-2779
Try Now
More in this section

Forums / Bugs & Issues / Error when saving thumbnail settings

Error when saving thumbnail settings

6 posts, 0 answered
  1. Daniel Plomp
    Daniel Plomp avatar
    952 posts
    Registered:
    18 Feb 2004
    04 Aug 2014
    Link to this post

    Hi,

    When I try to create or edit thumbnail settings from the backend settings section, I'm getting the following error:

    ----------------------------------------
    Timestamp: 8/4/2014 7:37:23 AM
     
    Message: HandlingInstanceID: 34c6444d-8fc0-4bfd-b888-8d2b74989388
    An exception of type 'System.NullReferenceException' occurred and was caught.
    -----------------------------------------------------------------------------
    08/04/2014 09:37:23
    Type : System.NullReferenceException, mscorlib, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089
    Message : Object reference not set to an instance of an object.
    Source : Telerik.Sitefinity
    Help link :
    Data : System.Collections.ListDictionaryInternal
    TargetSite : System.String SaveMethodParameters()
    HResult : -2147467261
    Stack Trace :    at Telerik.Sitefinity.Modules.Libraries.Web.UI.Thumbnails.ThumbnailProfileDialog.SaveMethodParameters()
       at Telerik.Sitefinity.Modules.Libraries.Web.UI.Thumbnails.ThumbnailProfileDialog.RaisePostBackEvent(String eventArgument)
       at System.Web.UI.Page.ProcessRequestMain(Boolean includeStagesBeforeAsyncPoint, Boolean includeStagesAfterAsyncPoint)
     
    Additional Info:
     
    MachineName : KNSTR-DEV
    TimeStamp : 8/4/2014 7:37:23 AM
    FullName : Telerik.Sitefinity.Utilities, Version=7.1.5200.0, Culture=neutral, PublicKeyToken=b28c218413bdf563
    AppDomainName : /LM/W3SVC/1/ROOT/egz-1-13337833
    ThreadIdentity : admin
    WindowsIdentity : IIS APPPOOL\.NET v4.5
     
     
    Category: ErrorLog
     
    Priority: 0
     
    EventId: 90000
     
    Severity: Error
     
    Title:Enterprise Library Exception Handling
     
    Machine: KNSTR-DEV
     
    App Domain: /LM/W3SVC/1/ROOT/egz-1-13337833
     
    ProcessId: 5276
     
    Process Name: c:\windows\system32\inetsrv\w3wp.exe
     
    Thread Name:
     
    Win32 ThreadId:5916
     
    Extended Properties:
    ----------------------------------------

    This happens with a new generated Sitefinity 7.1 website.

    Daniel

  2. Kaloyan
    Kaloyan avatar
    272 posts
    Registered:
    08 Dec 2016
    07 Aug 2014
    Link to this post
    Hi Daniel,

    Would it be possible to share a bit more details how this problem can be reproduced? I have tried multiple times to replicate this issue on a blank 7.1 project, but without any success. 

    Regards,
    Kaloyan
    Telerik
     
    Do you want to have your say in the Sitefinity development roadmap? Do you want to know when a feature you requested is added or when a bug fixed? Explore the Telerik Sitefinity CMS Ideas&Feedback Portal and vote to affect the priority of the items
     
  3. Daniel Plomp
    Daniel Plomp avatar
    952 posts
    Registered:
    18 Feb 2004
    11 Aug 2014 in reply to Kaloyan
    Link to this post

    Hi Kaloyan,

    Can't say anything specific about this problem. It is just how it is. I uploaded images into a library. After that I went to Settings -> Thumbnail Settings and tried to edit / add new settings. It gives the error with both adding and editing settings.

    Best,
    Daniel

  4. Nikola Zagorchev
    Nikola Zagorchev avatar
    424 posts
    Registered:
    08 Dec 2016
    13 Aug 2014
    Link to this post
    Hi Daniel,

    Could you please open a support ticket regarding this issue and send us the error logs? This way we could proceed faster in resolving the problem and provide a solution. Thank you in advance for your cooperation.

    Regards,
    Nikola Zagorchev
    Telerik
     
    Do you want to have your say in the Sitefinity development roadmap? Do you want to know when a feature you requested is added or when a bug fixed? Explore the Telerik Sitefinity CMS Ideas&Feedback Portal and vote to affect the priority of the items
     
  5. Chris
    Chris avatar
    11 posts
    Registered:
    16 Sep 2014
    18 May 2015
    Link to this post
    Was a solution ever found for this? We're having a similar issue on 8.0. The only difference is that the null reference is happening on Telerik.Sitefinity.Modules.Libraries.Web.UI.Thumbnails.ThumbnailProfileDialog.ValidateFields() instead of SaveMethodParameters().
  6. Nikola Zagorchev
    Nikola Zagorchev avatar
    424 posts
    Registered:
    08 Dec 2016
    21 May 2015
    Link to this post
    Hello Chris,

    I would recommend you to submit a support ticket describing the issue and providing the error logs located in App_Data -> Sitefinity -> Logs. We were not able to reproduce the issue or continue the communication with Daniel on the problem, since he did not get back to us.

    Regards,
    Nikola Zagorchev
    Telerik
     
    Do you want to have your say in the Sitefinity development roadmap? Do you want to know when a feature you requested is added or when a bug fixed? Explore the Telerik Sitefinity CMS Ideas&Feedback Portal and vote to affect the priority of the items
     
6 posts, 0 answered