+1-888-365-2779
Try Now
More in this section

Forums / Bugs & Issues / Error when uploading image

Error when uploading image

9 posts, 1 answered
  1. Damian
    Damian avatar
    27 posts
    Registered:
    01 Dec 2010
    20 Dec 2010
    Link to this post
    When I try to upload an image to the library on the our staging server, I get this error in a popup:

    "You can not check in since the item is locked by another user and are not admin"

    I am running Sitefinity 4.0.907.0 SE and logged in as an admin.  Image upload works fine from localhost.
  2. Ivan Dimitrov
    Ivan Dimitrov avatar
    16072 posts
    Registered:
    25 Nov 2016
    21 Dec 2010
    Link to this post
    Hello Damian,

    There are two cases that this could happen

    The user you use does not belongs to unrestricted role or the current user is not the item owner. The message you receive says that you cannot perform checks in of the content in the temp state, because one of the reasons above. Please verify that you are using a user which is unrestricted and let me know if you have made some changes to the workflow.

    Kind regards,
    Ivan Dimitrov
    the Telerik team
    Do you want to have your say when we set our development plans? Do you want to know when a feature you care about is added or when a bug fixed? Explore the Telerik Public Issue Tracking system and vote to affect the priority of the items
  3. Damian
    Damian avatar
    27 posts
    Registered:
    01 Dec 2010
    21 Dec 2010
    Link to this post
    The user I am logged in as belongs to the Administrators group and I have not done anything to modify the workflow.  I am uploading a completely new image so I think the user should be its owner.

    When I try to upload an image with the same user on localhost, I do not get the error and it works fine.
  4. Ivan Dimitrov
    Ivan Dimitrov avatar
    16072 posts
    Registered:
    25 Nov 2016
    21 Dec 2010
    Link to this post
    Hello Damian,

    Can you use the latest build 4.0.992.0 and try to upload the images.  Since this works on the local host and not on another machine there must be something on the server that breaks the workflow.

    All the best,
    Ivan Dimitrov
    the Telerik team
    Do you want to have your say when we set our development plans? Do you want to know when a feature you care about is added or when a bug fixed? Explore the Telerik Public Issue Tracking system and vote to affect the priority of the items
    Answered
  5. Damian
    Damian avatar
    27 posts
    Registered:
    01 Dec 2010
    21 Dec 2010
    Link to this post
    Upgrading to Sitefinity 4.0.992.0 fixed the issue. Thanks.
  6. Tys
    Tys avatar
    21 posts
    Registered:
    21 Jul 2011
    12 Dec 2012
    Link to this post
    We are running 5.1.3270 and i'm experiencing the same problem. I've gone over the long list of possible fixes, but none works. Any suggestions on what could be the solution in combination with this version? 
  7. Pavel Benov
    Pavel Benov avatar
    341 posts
    Registered:
    14 Mar 2016
    17 Dec 2012
    Link to this post
    Hi Tys,

    You have been given an answer to this question in Ticket 639745. You can go and give a reply and also share the possible resolution with the community. 

    Kind regards,
    Pavel Benov
    the Telerik team
    Do you want to have your say in the Sitefinity development roadmap? Do you want to know when a feature you requested is added or when a bug fixed? Explore the Telerik Public Issue Tracking system and vote to affect the priority of the items
  8. Jeremy
    Jeremy avatar
    33 posts
    Registered:
    22 Apr 2010
    24 Sep 2013
    Link to this post
    I am running into the same issue with a user trying to upload documents. We are running 6.0.42. The user is the admin for the site and has full permission. The site does not have a workflow. There are 2 users and both are admins. One has the issue and the other does not. 

    Is there a solution to this issue?
  9. Pavel Benov
    Pavel Benov avatar
    341 posts
    Registered:
    14 Mar 2016
    27 Sep 2013
    Link to this post
    Hi Jeremy,

    This issue is project specific so I would suggest to open a support ticket and supply any additional information there - such as error logs and backend credentials to the project so we can inspect and reproduce the problem.

    Regards,
    Pavel Benov
    Telerik
    Do you want to have your say in the Sitefinity development roadmap? Do you want to know when a feature you requested is added or when a bug fixed? Explore the Telerik Public Issue Tracking system and vote to affect the priority of the items
9 posts, 1 answered