+1-888-365-2779
Try Now
More in this section

Forums / Bugs & Issues / Expiration custom field always set to empty when publishing

Expiration custom field always set to empty when publishing

5 posts, 0 answered
  1. Jae Hong
    Jae Hong avatar
    29 posts
    Registered:
    07 May 2012
    10 Dec 2012
    Link to this post
    I am using Sitefinity 5.2 and have an issue with 'Custom fields for news'.
    In the default News item without adding any custom fields, I can save 'Expiration Date' through "More actions - Publish/Unpublish on specific Date" feature. I would like visually show those fields in "Edit a news" and "Create a news" backend page so that I changed Appearance of ExpirationDate and PublicationDate to "All screens where you work with news in the Backend". After this changes,  I can see Publication and Expiration Date fields on the Backend pages; however, expiration date field always set to empty when the existing or new news items have been published. At this time, "More actions - Publish/Unpublish on specific Date" feature doesn't work either.

    Could anyone help me to resolve this feature??
    Thanks.
  2. Jae Hong
    Jae Hong avatar
    29 posts
    Registered:
    07 May 2012
    12 Dec 2012 in reply to Jae Hong
    Link to this post
    As you see the attachments, After I show PublicationDate and ExpirationDate and publish a news item (Issue 1-1.png), ExpirationDate's year is set to "0000" (Issue 1-2.png). When I go back to the item edit mode, ExpirationDate is empty.

    Please give me an advice to resolve this.
  3. Jae Hong
    Jae Hong avatar
    29 posts
    Registered:
    07 May 2012
    13 Dec 2012
    Link to this post
    I think overall Custom field feature has a bug in Sitefinity 5.2

    I changed 'PublicationDate' field to visible on Blog Posts. When I view in backend, I can see the modified publication date and time; however, 'BlogPosts' widget keep showing the date and time before I modified. As same as News custom field, everything is fine when I use "More actions - Publish/Unpublish on specific Date"

    I am wondering whether I doing wrong with custom field settings or Bugs in the custom field....
  4. Stefani Tacheva
    Stefani Tacheva avatar
    718 posts
    Registered:
    06 Dec 2016
    18 Dec 2012
    Link to this post
    Hi,

    I was able to reproduce the behavior with the Expiration Date. However I need to make some more tests regarding the problem. I will get back to you tomorrow with an updated information. Furthermore, I will test the behavior with the PublicationDate and Blog Posts widget.

    Thank you for the understanding.

    All the best,
    Stefani Tacheva
    the Telerik team
    Do you want to have your say in the Sitefinity development roadmap? Do you want to know when a feature you requested is added or when a bug fixed? Explore the Telerik Public Issue Tracking system and vote to affect the priority of the items
  5. Jae Hong
    Jae Hong avatar
    29 posts
    Registered:
    07 May 2012
    21 Dec 2012 in reply to Stefani Tacheva
    Link to this post
    @Stefani: I am still waiting for your updated info....

    Also, there is another bug when publish existing a news item that already has expiration date.
    Here is what I tested:
    1. Created a NewsItem, went to "Action - Publish/Unpublish on Specific date", set both Publication and Expiration date, and saved (IMG1).
    2. In backend News grid, I could see expiration was saved properly (IMG2)
    3. went back to the item and clicked "Publish" without any midification.
    4. In backend, the year of expiration date was changed to "0000" (IMG3)
    5. In edit mode, expiration date field changed to empty.

    I cannot give my backend users to publish news items with this very limited restriction of expiration date feature.

    Please resolve this issue soon as possible and respond to me.
    Thanks

5 posts, 0 answered