1-888-365-2779
+1-888-365-2779
Try Now
More in this section

Forums / Bugs & Issues / First time compile

First time compile

5 posts, 0 answered
  1. Paulo
    Paulo avatar
    21 posts
    Registered:
    06 Dec 2010
    03 Jan 2011
    Link to this post
    Hi,

    I am developing some custom controls and after build my custom control when I reload the page to view the results, it take 3 minutes to rebuild the site....

    I know that when we change a dll, App_code or web.config the iis recompiles the site, but 3 minutes is too long
    and 198 MB ocupied by the w3c process is to much for a simple site with one page

    This is not normal, and the previous RC didn't have this problem.

    It also occours an "time out " error if I change de Debug mode to release on web.config.

    Can someone help me??

    thanks.
  2. Paulo
    Paulo avatar
    21 posts
    Registered:
    06 Dec 2010
    03 Jan 2011
    Link to this post
    Hi.

    Just to add some info:

    - I have a recent machine,  4gb Ram, etc...
    - I went to IIS manager and cannot edit compilation settings, (view attached image)
  3. Ivan Dimitrov
    Ivan Dimitrov avatar
    16072 posts
    Registered:
    16 Jun 2017
    03 Jan 2011
    Link to this post
    Hello Paulo,

    How many custom controls you have? I am running an application with about 30 custom controls and it is working file at my end. The application is not timing out.

    If you have custom class libraries you can build them as a part of the solution.  Could you translate in English the error from attached screenshot.



    All the best,
    Ivan Dimitrov
    the Telerik team
    Do you want to have your say when we set our development plans? Do you want to know when a feature you care about is added or when a bug fixed? Explore the Telerik Public Issue Tracking system and vote to affect the priority of the items
  4. Paulo
    Paulo avatar
    21 posts
    Registered:
    06 Dec 2010
    03 Jan 2011
    Link to this post
    Hi

    I I just have 2 controls, wich is not the problem.

    The IIS problem translated means : Error: impossible to add a duplicated collection entry of type "add" with an attribute of unique key "assembly"

    PS: I think the problem resides on my connection to the non local database "witch I dont understand the connection".  meanwhile I created a new project connected to a local DB and it works fine.

    Thanks anyway.
  5. Radoslav Georgiev
    Radoslav Georgiev avatar
    3370 posts
    Registered:
    01 Feb 2016
    04 Jan 2011
    Link to this post
    Hi Paulo,

    Are you trying the same project connecting to different databases or it is two different project? If it is different projects are there any differences in the configuration of the projects?

    All the best,
    Radoslav Georgiev
    the Telerik team
    Do you want to have your say when we set our development plans? Do you want to know when a feature you care about is added or when a bug fixed? Explore the Telerik Public Issue Tracking system and vote to affect the priority of the items
5 posts, 0 answered