+1-888-365-2779
Try Now
More in this section

Forums / Bugs & Issues / "Forgot your password?" link not working (404 error)

"Forgot your password?" link not working (404 error)

3 posts, 0 answered
  1. Kev
    Kev avatar
    1 posts
    Registered:
    24 Apr 2014
    13 Jun 2014
    Link to this post

    Working with the Login widget on a page, the "Forgot your password?" link at the bottom simply leads to a 404 error.

    The PasswordRecoveryUrl of the widget is the default, ~/Sitefinity/Login/PasswordRecovery. In the advanced settings I have enablePasswordReset set to true, and a recoveryMailAddress set.

    Is there something more that needs to be configured to get this working?

  2. Sabrie Nedzhip
    Sabrie Nedzhip avatar
    534 posts
    Registered:
    09 Dec 2016
    17 Jun 2014
    Link to this post
    Hello Kev,

    It is really a strange issue. Can you please make sure that you have configured the password recovery as described in the following KB article. You can also take a look at the following article for more details.

    Can you please set the PasswordRecoveryUrl to the url of the page where you have dragged the Change password widget. I have also tested the behavior on my side and configured the password recovery in a Sitefinity 7.0 test project and here is a short video for you reference demonstrating my steps. 

    If the issue persists after performing the above, please let me know your Sitefinity version and the exact steps you take to configure the password recovery. You can also record a video demonstrating how the issue is reproduced on your side. 

    Regards,
    Sabrie Nedzhip
    Telerik
     
    Do you want to have your say in the Sitefinity development roadmap? Do you want to know when a feature you requested is added or when a bug fixed? Explore the Telerik Sitefinity CMS Ideas&Feedback Portal and vote to affect the priority of the items
     
  3. Markus
    Markus avatar
    2763 posts
    Registered:
    25 Nov 2005
    17 Jun 2014 in reply to Sabrie Nedzhip
    Link to this post

    Dear Kev

    Do you have forms or claims authentification?

    Markus

3 posts, 0 answered