+1-888-365-2779
Try Now
More in this section

Forums / Bugs & Issues / How to deploy Sitefinity site developed in 3.7 SP2, in IIS7 under 4.0 framework?

How to deploy Sitefinity site developed in 3.7 SP2, in IIS7 under 4.0 framework?

4 posts, 0 answered
  1. Amit
    Amit avatar
    43 posts
    Registered:
    15 Nov 2012
    17 Nov 2012
    Link to this post
    Hi,

    I have a website developed in Sitefinity 3.7 SP2, that is running successfully on server.
    But when I try to run on local system, by Integrating the project in asp.net 4.0 environment. I get following Error:
    Compilation Error
    Description: An error occurred during the compilation of a resource required to service this request. Please review the following specific error details and modify your source code appropriately.
     
    Compiler Error Message: CS0104: 'DynamicHyperLink' is an ambiguous reference between 'Telerik.Cms.Web.UI.DynamicHyperLink' and 'System.Web.DynamicData.DynamicHyperLink'
     
    Source Error:
     
     
    Line 15:             if (item.ItemType == ListItemType.Item || item.ItemType == ListItemType.AlternatingItem)
    Line 16:             {
    Line 17:                 DynamicHyperLink link = item.FindControl("dhl") as DynamicHyperLink;
    Line 18:                 if (link != null)
    Line 19:                 {
     
     
    Source File: d:\Demo\miamiparking\Sitefinity\ControlTemplates\News\ListPageMaster.ascx    Line: 17
     
     
    Show Detailed Compiler Output:
     
     
    Version Information: Microsoft .NET Framework Version:4.0.30319; ASP.NET Version:4.0.30319.272
  2. Pavol Kokinda
    Pavol Kokinda avatar
    39 posts
    Registered:
    28 Sep 2012
    17 Nov 2012 in reply to Amit
    Link to this post
    Hi Ashish,

    first version of Sitefinity which support .NET Framework 4.0 was 3.7 Service Pack 4. In my opinion first thing to do is upgrade you project to Sitefinity 3.7 SP4.

    Greetings,

    Pavol
  3. Victor Velev
    Victor Velev avatar
    1345 posts
    Registered:
    06 Jul 2015
    20 Nov 2012
    Link to this post
    Hi Ashish,

    As Pavol suggested, the 3.7 SP2 version is only for .NET 2.0, which may be in conflict when running the project on IIS 7 .NET 4.0. As suggested in the other forum threads, you can go ahead and apply a patch which will upgrade your 3.x site to SP4 .NET 3.5 / .NET 4.0. The following KB can help you find the proper version of Sitefinity 3.x you have ( and the .NET version ):

    http://www.sitefinity.com/devnet/kb/how-to-check-your-current-sitefinity-version

    All the best,
    Victor Velev
    the Telerik team
    Do you want to have your say in the Sitefinity development roadmap? Do you want to know when a feature you requested is added or when a bug fixed? Explore the Telerik Public Issue Tracking system and vote to affect the priority of the items
  4. Amit
    Amit avatar
    43 posts
    Registered:
    15 Nov 2012
    21 Nov 2012
    Link to this post
    Hi all,

    Thanks for the support. I have upgraded the 3.7 sp2 project to 3.7 sp4 successfully by following the steps as given in the http://tv.telerik.com/watch/sitefinity/upgrading-to-sitefinity-37-sp4
4 posts, 0 answered