+1-888-365-2779
Try Now
More in this section

Forums / Bugs & Issues / How to Enable Built-in Controls Under Type of content

How to Enable Built-in Controls Under Type of content

4 posts, 0 answered
  1. Ajay
    Ajay avatar
    46 posts
    Registered:
    14 Nov 2013
    02 Jan 2014
    Link to this post
    Hi All..
    i'm using  "Sitefinity 6.2 Enterprise EditionBuild 6.2.4910.0" 

    im unable to see built in controls in dashboard like News, Blogs, Images, Dynamic modules...(please find attached image for reference)

    Im able to see only Forms, Comments , Tags, Categiries and all clasification  only

    i checked Enable properties in settings, but i'm unable to get these controls, please help me how to get these controls

    Thanks in Advance


  2. Sabrie Nedzhip
    Sabrie Nedzhip avatar
    534 posts
    Registered:
    09 Dec 2016
    02 Jan 2014
    Link to this post
    Hi Ajay,

    Most frequently this issue happens when the content modules are deactivated. Could you please go to Administration -> Modules and Services and make sure that all the content modules are marked as active. Here is a link to the article on how to activate and deactivate modules.

    Regards,
    Sabrie Nedzhip
    Telerik
    Do you want to have your say in the Sitefinity development roadmap? Do you want to know when a feature you requested is added or when a bug fixed? Explore the Telerik Public Issue Tracking system and vote to affect the priority of the items
  3. Ajay
    Ajay avatar
    46 posts
    Registered:
    14 Nov 2013
    03 Jan 2014 in reply to Sabrie Nedzhip
    Link to this post
    Hello Sabrie,

    Thanks for Quick Reply,
    Im Already Installed and Active All content Modules , but im unable to get Controls in Page Edit
    Please find Attached image(Modules installation Screen shot)

    Thanks in Advance,
    Excuse my bad English!
  4. Sabrie Nedzhip
    Sabrie Nedzhip avatar
    534 posts
    Registered:
    09 Dec 2016
    07 Jan 2014
    Link to this post
    Hello Ajay,

    Could you please open the ToolboxesConfig.config file located in ~/App_Data/Sitefinity/Configuration folder and make sure that all the content modules are listed under the PageControls section:

    <toolbox name="PageControls">
          <sections>
            <add name="ContentToolboxSection">
              <tools>
                <add enabled="True" type="Telerik.Sitefinity.Modules.News.Web.UI.NewsView, Telerik.Sitefinity.ContentModules" title="NewsViewTitle" description="NewsViewDescription" resourceClassId="NewsResources" cssClass="sfNewsViewIcn" moduleName="News" visibilityMode="None" name="NewsView" />
                <add enabled="True" type="Telerik.Sitefinity.Modules.Blogs.Web.UI.BlogPostView, Telerik.Sitefinity.ContentModules" title="BlogPostsViewTitle" description="BlogPostsViewDescription" resourceClassId="BlogResources" cssClass="sfBlogsViewIcn" moduleName="Blogs" visibilityMode="None" name="BlogPostsView" />

    ...

    Then please refresh the application and go to the backend to check if the content modules have appeared under the Content tab. If they have appeared you should be able to add them to a page. 

    Also to make sure that some scripts on specific page doesn`t block the display of controls in page edit please create new test page and when making it don`t select a template, choose the option "start from scratch" and check if this page with no template encounters the same problem. If it doesn`t then a script on the master page used as page template to create the page that encounter a problem causes the problem.

    Regards,
    Sabrie Nedzhip
    Telerik
    Do you want to have your say in the Sitefinity development roadmap? Do you want to know when a feature you requested is added or when a bug fixed? Explore the Telerik Public Issue Tracking system and vote to affect the priority of the items
4 posts, 0 answered