+1-888-365-2779
Try Now
More in this section

Forums / Bugs & Issues / Image Manager broken?

Image Manager broken?

20 posts, 0 answered
  1. Gaston County
    Gaston County avatar
    38 posts
    Registered:
    23 Feb 2012
    08 Feb 2011
    Link to this post
    When I'm working in the WYSIWYG editor (such as in a content block) and look at the properties for image I've dropped in, if I click on the little landscape symbol to choose a different image I get the mess I've attached shown to me. Is anyone else seeing this?

    This is IE8 on Windows 7.
  2. Sonya
    Sonya avatar
    205 posts
    Registered:
    29 Sep 2016
    10 Feb 2011
    Link to this post
    Hello Zak,

    The Image Manage of the RadControls>Editor is not broken. This is the default image dialog for RadControls>Editor. This editor is different than Sitefinity's Content Editor and the insert image dialogs for  these controls are also different.

    Regards,
    Sonya
    the Telerik team
    Do you want to have your say when we set our development plans? Do you want to know when a feature you care about is added or when a bug fixed? Explore the Telerik Public Issue Tracking system and vote to affect the priority of the items
  3. Jeremy
    Jeremy avatar
    37 posts
    Registered:
    17 Jan 2011
    10 Feb 2011
    Link to this post
    I have the same issue. Are you saying it's behaving as expected? If so, why in the world can we even right click an image and choose properties? Is there some other way to edit the properties of an inserted image?
  4. Gaston County
    Gaston County avatar
    38 posts
    Registered:
    23 Feb 2012
    10 Feb 2011
    Link to this post
    It certainly doesn't appear to be working--I can't figure out how to do anything with it. Scrolling between Page 1 of 2 and Page 2 of 2 doesn't cause anything to happen that I've seen.
  5. Sonya
    Sonya avatar
    205 posts
    Registered:
    29 Sep 2016
    15 Feb 2011
    Link to this post
    Hello Zak,

    Please check if the following code is added to your web.config. If the code is missing please add the code below under <httpHandlers> section:

    <httpHandlers>
    <add verb="*" path="Telerik.Web.UI.DialogHandler.aspx" type="Telerik.Web.UI.DialogHandler, Telerik.Web.UI, Culture=neutral, PublicKeyToken=121fae78165ba3d4" />

    To set Image Manager:
    • Go to Administration>Files – create new folder named Files and upload few images
    • Go back to the page where RadEditor is and click ‘Edit’
    • Under Image Manager section – define UploadPath /ViewPath  i.e. ~/Files
    • Save
    • Click Image Manager – the images uploaded in ~/Files directory should be listed
    I noticed some issues when you have nested pages and we will need some more time to investigate the issue.

    Another option is creating a custom or user control where you have RadEditor control declared and you should set DialogHandlerUrl="~/Telerik.Web.UI.DialogHandler.axd"



    Greetings,
    Sonya
    the Telerik team
    Do you want to have your say when we set our development plans? Do you want to know when a feature you care about is added or when a bug fixed? Explore the Telerik Public Issue Tracking system and vote to affect the priority of the items
  6. Steve
    Steve avatar
    3037 posts
    Registered:
    03 Dec 2008
    15 Feb 2011
    Link to this post
    This was always the problem with 3.x as well...there was never a single source for images\documents.  Depending on the control you used (image control or RadEditor) and where you were, you only had access to files in that repository (filesystem or database library)

    Sonya, it gets really annoying really quickly for content editors who have no idea that's the case...it would be awesome if you guys worked towards a single source\single dialog.  So whenever I use an image regardless of where\how I add it, I get the same dialog.
  7. Gaston County
    Gaston County avatar
    38 posts
    Registered:
    23 Feb 2012
    16 Feb 2011
    Link to this post
    Sonya,

    I have a very similar line:

    <add verb="*" validate="false" path="Telerik.Web.UI.DialogHandler.axd" type="Telerik.Web.UI.DialogHandler, Telerik.Web.UI"/>

    Do I need the one you provided as well?

    Thanks!
  8. Georgi
    Georgi avatar
    3583 posts
    Registered:
    28 Oct 2016
    18 Feb 2011
    Link to this post
    Hello Zak,

    This is fine. Have you created Files directory in the root of your web application?
    Steve, we are going to sort this out for the service pack.

    Best wishes,
    Georgi
    the Telerik team
  9. Gaston County
    Gaston County avatar
    38 posts
    Registered:
    23 Feb 2012
    21 Feb 2011
    Link to this post
    I have not--is this a requirement, as I don't recall seeing it in the installation documentation?
  10. Georgi
    Georgi avatar
    3583 posts
    Registered:
    28 Oct 2016
    22 Feb 2011
    Link to this post
    Hi Zak,

    No, it's not in the system requirements - we found that this fixes the issue after the release. Service Pack 1 will contain this directory though, out of the box.
    You may create it, and check if the problem persists.

    Regards,
    Georgi
    the Telerik team
  11. Gaston County
    Gaston County avatar
    38 posts
    Registered:
    23 Feb 2012
    22 Feb 2011
    Link to this post
    Hi Georgi,

    I'm still seeing the issue after creating the Files directory. Does it need any special permissions?

    Thanks!
  12. Radoslav Georgiev
    Radoslav Georgiev avatar
    3370 posts
    Registered:
    01 Feb 2016
    28 Feb 2011
    Link to this post
    Hello Zak,

    Thank you for getting back to us.

    The FileManager requires permissions to create files in under the Files folder if you wish to upload images from the manager. If you wish only to use the manager for including file links in content blocks you do not need special permissions.

    Best wishes,
    Radoslav Georgiev
    the Telerik team
  13. Vijay
    Vijay avatar
    1 posts
    Registered:
    18 Sep 2011
    18 Sep 2011
    Link to this post
    Hi Sonya,

    This Forum is very helpful. Thanks a lot for sharing these great tips.
    I just upgraded from DNN 5.6.3 to DNN 6.0.1 with DotNetNuke.RadEditor provider

    My current Problem:
    I am not able to add / insert images / media files in the HTML editor.
    When I click on "Insert Media" button, "Image Manager" window pops-up. But I don't see any files there.
    Naturally, this is a problem with "Image Path" setting for the Editor in this Child Portal.
    I want to know how to set the "Path" for the images. I can't navigate to any folder - not even portal root folder (I am the host; working on a Child portal)

    Some Observations:
    I opened an existing HTML module with an image in the new editor.
    I right-clicked on the existing image and saw the "Properties"
    I can clearly see the correct path in the "Image properties window".
    Image Src shows the correct Path : /P2/portals/26/logo.gif

    But when I click the "image" icon next to the file name text box, it opens "Image manager" but no list of files (everything is empty; it doesn't even show the file whose properties I was just viewing).

    When I changed the file name directly on the Image Properties window, it picked up the right / correct image and displayed.

    If I don't have an existing image, I can't get to the "Properties" window and do this "work-around".

    Please help me with this: How to set the Image files Path for the new Telerik Editor.

    Thanks a lot in advance!

    ================ Your Guidance ================================
    To set Image Manager:
    • Go to Administration>Files – create new folder named Files and upload few images
    • Go back to the page where RadEditor is and click ‘Edit’ <<< "I can't see any "Edit" button???
    • Under Image Manager section – define UploadPath /ViewPath  i.e. ~/Files
    • Save
    • Click Image Manager – the images uploaded in ~/Files directory should be listed
    ==================================================================
  14. Rumen
    Rumen avatar
    26 posts
    Registered:
    01 Dec 2016
    21 Sep 2011
    Link to this post
    Hello Vijay,

    Please, note that version 5.4 or later of DNN uses the Professional provider of RadEditor, which is implementation of the DNN developers and it is not supported by Telerik.

    Our suggestion is to post your question in the DNN forums and contact the support of DNN for help. This article could be also helpful : Taming (customizing) The new Telerik RadEditor.

    You can find information about:



    All the best,
    Rumen
    the Telerik team
    If you want to get updates on new releases, tips and tricks and sneak peeks at our product labs directly from the developers working on the RadControls for ASP.NET AJAX, subscribe to their blog feed now
  15. Jaime Weise
    Jaime Weise avatar
    120 posts
    Registered:
    02 Nov 2008
    25 Oct 2011
    Link to this post
    Still broken after all these years
    This is still terribly broken and the steps you have given don't make any sense. There is no Page with the RadEditor. There is only a content block on the page. You right click the image and click the properties button followed by the image icon for popping up the Image Manager--which I might add is effectively disable for any logical purposes. And, yes I have a permission to a folder called files on my main drive with images uploaded into it. If a developer can't figure it out how to use the feature the design is flawed. Could you please make the image manager make sense or at least give some reliable instructions on how to use it. I am on 4.2.17xx. 

    Not a DNN installation
    I might add that this is not a DNN installation I am working with. 
  16. Radoslav Georgiev
    Radoslav Georgiev avatar
    3370 posts
    Registered:
    01 Feb 2016
    27 Oct 2011
    Link to this post
    Hi Jaime Weise,

    The built in image manager of the RadEditor requires folder called Images. We do not create such folder because we have custom dialogs for the RadEditor in Sitefinity. They use the libraries instead of the regular files system.

    Kind regards,
    Radoslav Georgiev
    the Telerik team
    If you want to get updates on new releases, tips and tricks and sneak peeks at our product labs directly from the developers working on the RadControls for ASP.NET AJAX, subscribe to their blog feed now
  17. Carsten Koster
    Carsten Koster avatar
    12 posts
    Registered:
    05 Sep 2006
    04 Nov 2011
    Link to this post
    I have a custom control with a RadEditor in it. Everything works fine, but I want to be able to insert images from the Image-Library with the RadEditor. How can I tell the RadEditor to use Images from the Image-Libraray and not from the ~/images folder?

    Using Sitefinity 4.2. Thank you!
  18. Radoslav Georgiev
    Radoslav Georgiev avatar
    3370 posts
    Registered:
    01 Feb 2016
    08 Nov 2011
    Link to this post
    Hello Carsten Koster,

    If your control is built for Sitefinity 3.x versions you can use this KB article for reference: How to reuse Sitefinity editor dialogs .

    If your control is built for Sitefinity 4.x versions you can use the HtmlField control, which wraps the RadEditor in a widget and extends it with the dialogs for retrieving items from the libraries. In this case you can register the HtmlField in your user control:
    <%@ Register Assembly="Telerik.Sitefinity" Namespace="Telerik.Sitefinity.Web.UI.Fields" TagPrefix="sfFields" %>

    Then use the HtmlField control:
    <sfFields:FormManager ID="formManager" runat="server" />
     <sfFields:HtmlField
     ID="htmlFilmDetails"
     runat="server"
     Width="100%"
     Height="150px"
     EditorContentFilters="DefaultFilters"
     EditorStripFormattingOptions="MSWord,Css,Font,Span,ConvertWordLists"
     DisplayMode="Write"
     FixCursorIssue="True"
     >
    </sfFields:HtmlField>


    Kind regards,
    Radoslav Georgiev
    the Telerik team
    Do you want to have your say in the Sitefinity development roadmap? Do you want to know when a feature you requested is added or when a bug fixed? Explore the Telerik Public Issue Tracking system and vote to affect the priority of the items
  19. Paul
    Paul avatar
    18 posts
    Registered:
    14 Jan 2011
    10 May 2012
    Link to this post
    I would like to report that this issue, as reported by Gaston County on the 8th of February 2011 still persists in the Sitefinity 4.4 version we are using for a client.

    As I could not find any documentation, please advise on how to set up this tool correctly.

    Thanks
  20. Conrad Ehinger
    Conrad Ehinger avatar
    59 posts
    Registered:
    22 Sep 2009
    11 Mar 2014 in reply to Paul
    Link to this post

    I know this post is fairly old however due to the possibility of still running into this issue I am posting the resolution. The HtmlField Radoslav included is missing the "IsToOverrideDialogs" property that allows the managers to function. see below:

    <sfFields:HtmlField ID="Content1" runat="server" DisplayMode="Write" EditorToolsConfiguration="Standard" HtmlFieldEditModes="All" EditorContentFilters="DefaultFilters,RemoveScripts" EditorStripFormattingOptions="AllExceptNewLines" Height="200" Width="330" IsToOverrideDialogs="true"></sfFields:HtmlField>
    Hopefully this helps anyone in the future who runs into the same issue.

20 posts, 0 answered