1-888-365-2779
+1-888-365-2779
Try Now
More in this section

Forums / Bugs & Issues / invalid culture breaks sitefinity (4.0.1210.0)

invalid culture breaks sitefinity (4.0.1210.0)

2 posts, 0 answered
  1. Jochem Bökkers
    Jochem Bökkers avatar
    787 posts
    Registered:
    13 Aug 2007
    15 Apr 2011
    Link to this post
    I was strolling along the advanced settings and came across the culture setting and changed it but unfortunately entered "en--US" instead of "en-US". Everything worked fine for the remaining session.

    But when trying to login the next time I get the cool "Server error in application" screen (which I still think for honoring history they should make blue with with letters)

    This totally breaks the site (obvious) but also makes it impossible to login and correct the error. Perhaps in a future fix you could implement a fall back to accomodate for people with thick fingers?

    Just a check to verify culture is valid, if not set it to en-US and warn the user on login?


    (in case there are idiots like me out there, you'll find the culture settings stored in \App_Data\Sitefinity\Configuration\ResourcesConfig.config)
  2. Lyubomir Dokov
    Lyubomir Dokov avatar
    43 posts
    Registered:
    06 Jun 2017
    15 Apr 2011
    Link to this post

    Hi Jochem,

    Thank you for the suggestion. As I understand it, you have worked around the issue by editing the config file directly.

    Please note, that the advanced settings are meant just for easier editing of the config files. There is no validation there and this is normal. Theoretically you can break much more things from there. When possible, you should make changes using the simple settings page. It is the user-friendly way of editing configurations.



    Best wishes,
    Lyubomir Dokov
    the Telerik team

2 posts, 0 answered