+1-888-365-2779
Try Now
More in this section

Forums / Bugs & Issues / Issue creating custom membership provider

Issue creating custom membership provider

3 posts, 0 answered
  1. Jim
    Jim avatar
    3 posts
    Registered:
    06 Jun 2012
    05 Jun 2014
    Link to this post

    Hello,

       I am trying to implement a custom membership provider in an instance of sitefinity. The sitefinity version is 6.3.5. When filling out the fields and clicking the 'Save Changes' button, it gives me an error message that the following parameter does not have a value: type

    When I review the post data I do not see a value in the json being passed for type, but see one for profile type.
    I cannot save a new membership provider. How do I get around this issue?

  2. Svetoslav Manchev
    Svetoslav Manchev avatar
    735 posts
    Registered:
    07 Dec 2016
    09 Jun 2014
    Link to this post
    Hi Jim,

    What type you are trying to fill-in when adding your Membership provider? You can manually add the provider to the SecurityConfig.config file, in the ~/App_Data/Sitefinity/Configuration folder.

    You can check also this tutorial for creation of custom membership provider and ensure that the steps are strictly followed.

    Regards,
    Svetoslav Manchev
    Telerik
     
    Do you want to have your say in the Sitefinity development roadmap? Do you want to know when a feature you requested is added or when a bug fixed? Explore the Telerik Sitefinity CMS Ideas&Feedback Portal and vote to affect the priority of the items
     
  3. Jim
    Jim avatar
    3 posts
    Registered:
    06 Jun 2012
    09 Jun 2014 in reply to Svetoslav Manchev
    Link to this post

    I actually figured this one out. I was putting in the class name, and namespace instead of the class name, assembly name.

    Thank you.

3 posts, 0 answered