+1-888-365-2779
Try Now
More in this section

Forums / Bugs & Issues / Issue in upgrading sitefinity 5.3.3900 to 7.1

Issue in upgrading sitefinity 5.3.3900 to 7.1

6 posts, 0 answered
  1. Rehan
    Rehan avatar
    4 posts
    Registered:
    20 Dec 2012
    23 Jul 2014
    Link to this post

    Hi,

    I am upgrading sitefinity 5.3.3900 to 7.1, I have installed new trial version, imported my project into it and upgraded it.

    but now I am getting error

    "Could not load file or assembly 'Telerik.Sitefinity.Analytics.Server.DependencyResolution' or one of its dependencies. The system cannot find the file specified."

    this DLL has version 5.3.39 so i had removed it from Bin folder, kindly help me what are specific steps that I should follow to upgrade from old to latest version.

    also if I create new project and import my all logic (user controls that i have created ) to new project then how could I get all data from old sitefinity database to new sitefinity databas (database of version 7) ?

    Please help me

     

  2. Ian
    Ian avatar
    7 posts
    Registered:
    02 Mar 2009
    26 Jul 2014 in reply to Rehan
    Link to this post

    Same here from 4.4

    I have copied all dlls from a working blank solution on my dev machine - still the same error.

    Thanks

    Ian

  3. Nikola Zagorchev
    Nikola Zagorchev avatar
    424 posts
    Registered:
    24 Nov 2016
    28 Jul 2014
    Link to this post
    Hello,

    Could you please check if the dll is still referenced from your project? The only Analytics dll in Sitefinity 7.1 is Telerik.Sitefinity.Analytics.Server.Infrastructure. Please, verify it is referenced and with the correct version - 7.1.5200.

    Regards,
    Nikola Zagorchev
    Telerik
     
    Do you want to have your say in the Sitefinity development roadmap? Do you want to know when a feature you requested is added or when a bug fixed? Explore the Telerik Sitefinity CMS Ideas&Feedback Portal and vote to affect the priority of the items
     
  4. Ian
    Ian avatar
    7 posts
    Registered:
    02 Mar 2009
    28 Jul 2014 in reply to Nikola Zagorchev
    Link to this post

    Thanks Nikola

    Mine was an unaltered version of Sitefinity 4.4 - no code changes so updated in situ, not compiled.

    That assembly is present in the bin folder.

    Kind regards

    Ian

  5. Nikola Zagorchev
    Nikola Zagorchev avatar
    424 posts
    Registered:
    24 Nov 2016
    30 Jul 2014
    Link to this post
    Hello,

    Could you please check whether the referenced assembly is the correct version for Sitefinity 7.1? You can also remove the reference and add it again using the dll from an 7.1 empty project.

    Regards,
    Nikola Zagorchev
    Telerik
     
    Do you want to have your say in the Sitefinity development roadmap? Do you want to know when a feature you requested is added or when a bug fixed? Explore the Telerik Sitefinity CMS Ideas&Feedback Portal and vote to affect the priority of the items
     
  6. Ian
    Ian avatar
    7 posts
    Registered:
    02 Mar 2009
    30 Jul 2014 in reply to Nikola Zagorchev
    Link to this post

    Hi Nikola,

    I checked this and eventually realised it related to an obsolete reference in the web.config file that had not been removed by the upgrade process.

    I've encountered further issues and have opened a support ticket.

    Kind regards

    Ian

     

6 posts, 0 answered