Try Now
More in this section

Forums / Bugs & Issues / Issue with changing storage providers on images.

Issue with changing storage providers on images.

3 posts, 0 answered
  1. Brett Whittington
    Brett Whittington avatar
    33 posts
    12 Jan 2012
    14 Apr 2015
    Link to this post

    Recently upgrade a 4.2 site to 8.0.  The 4.2 site had its image storage providers set to FileSystem.  I wanted to change it back to database driven so I chose the option to do so.  However, I received an error stating "Status Deleted is not supported." Luckily for me, I remembered I had deleted some of the images out of that library and they were still in my recycle bin.  Once I removed from the recycle bin, I was able to switch the storage provider.  I wanted to report a possible bug as my users generally would not have figured that out and would have expected it to work.

     TL:DR - There may be a bug when switching storage providers when the library has had some items still in the recycle bin.

  2. Atanas Valchev
    Atanas Valchev avatar
    414 posts
    04 Jan 2016
    17 Apr 2015
    Link to this post

    Thank you for sharing this information.

    I tested this on a new 8.0 project and was not able to reproduce the issue. It is good to have your experience in the forum so other users can find it if they have the same behavior.

    Atanas Valchev
    Do you want to have your say in the Sitefinity development roadmap? Do you want to know when a feature you requested is added or when a bug fixed? Explore the Telerik Sitefinity CMS Ideas&Feedback Portal and vote to affect the priority of the items
  3. Erwann
    Erwann avatar
    3 posts
    18 Feb 2015
    02 Dec 2015 in reply to Brett Whittington
    Link to this post

    This is exactly what I was looking for. Thanks Brett.

    And yes, there is a problem when you want to switch storage. 

    Cleaning the bin is the answer.

3 posts, 0 answered