+1-888-365-2779
Try Now
More in this section

Forums / Bugs & Issues / Issue with Libraries Module

Issue with Libraries Module

2 posts, 0 answered
  1. Zachary
    Zachary avatar
    3 posts
    Registered:
    30 Oct 2013
    26 Mar 2015
    Link to this post

    I have a SiteFinity site that was recently upgraded to version 7.3. 

     When a user clicks on a document library on the backend the application throws an Object Not Set to an Instance of an object exception. 

     

    I noticed that the backend is trying to navigate to ../LibraryDocument but I believe that the libraries reside in the ../Libraries app_name in the database. If you manually type "Libaries" into the url in the place of "LibaryDocuments" the libraries and the documents in those libraries are viewable. 

     

    How can resolve the libraries to be under the correct page node?

     

     

  2. Svetoslav Manchev
    Svetoslav Manchev avatar
    735 posts
    Registered:
    30 Sep 2016
    31 Mar 2015
    Link to this post
    Hello Zachary,

    You can try to re-upgrade the libraries module by setting in the SystemConfig.config the Libraries row like 
    <add name="Libraries" />
    under  ~/App_Data/Sitefinity/Configuration

    and than restart the application.

    In case this do not solve the issue I would recommend you to open support ticket in order to inspect the project more detailed.

    Regards,
    Svetoslav Manchev
    Telerik
     
    Do you want to have your say in the Sitefinity development roadmap? Do you want to know when a feature you requested is added or when a bug fixed? Explore the Telerik Sitefinity CMS Ideas&Feedback Portal and vote to affect the priority of the items
     
2 posts, 0 answered